aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/circe/Makefile33
-rw-r--r--net-mgmt/circe/distinfo2
-rw-r--r--net-mgmt/circe/files/patch-Makefile82
-rw-r--r--net-mgmt/circe/pkg-descr4
-rw-r--r--net-mgmt/circe/pkg-plist22
6 files changed, 144 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 073093358a78..9321bef64acd 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -47,6 +47,7 @@
SUBDIR += chillispot
SUBDIR += choparp
SUBDIR += cidr
+ SUBDIR += circe
SUBDIR += cisco_conf
SUBDIR += ciscoconf
SUBDIR += clog
diff --git a/net-mgmt/circe/Makefile b/net-mgmt/circe/Makefile
new file mode 100644
index 000000000000..e699feba9207
--- /dev/null
+++ b/net-mgmt/circe/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: circe
+# Date created: 23 July 2010
+# Whom: Berkeley NAC-Team
+#
+# $FreeBSD$
+#
+
+PORTNAME= circe
+PORTVERSION= 0.1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://bws.berkeley.edu/ports/
+
+MAINTAINER= circe-port-maintainers@bws.berkeley.edu
+COMMENT= Code that implements a perl based circe captive portal system
+
+DIST_SUBDIR= ${PORTNAME}
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/Net/IP/Match/XS.pm:${PORTSDIR}/net-mgmt/p5-Net-IP-Match-XS \
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/mach/IO.pm:${PORTSDIR}/devel/p5-IO \
+ ${SITE_PERL}/mach/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface \
+ ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
+ ${SITE_PERL}/mach/Sys/Syslog.pm:${PORTSDIR}/sysutils/p5-Sys-Syslog \
+ ${SITE_PERL}/mach/TryCatch.pm:${PORTSDIR}/lang/p5-TryCatch
+
+MANCOMPRESSED= no
+
+WRKSRC= ${WRKDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(SITE_PERL)|${SITE_PERL}|g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/circe/distinfo b/net-mgmt/circe/distinfo
new file mode 100644
index 000000000000..57c215d91d85
--- /dev/null
+++ b/net-mgmt/circe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (circe/circe-0.1.2.tar.gz) = dab6c929febfefa20f283f37f65311f9a129793d3e6c3e387b3bd9fabfb8a84f
+SIZE (circe/circe-0.1.2.tar.gz) = 37597
diff --git a/net-mgmt/circe/files/patch-Makefile b/net-mgmt/circe/files/patch-Makefile
new file mode 100644
index 000000000000..477a445c27f8
--- /dev/null
+++ b/net-mgmt/circe/files/patch-Makefile
@@ -0,0 +1,82 @@
+--- ./Makefile.orig 2011-02-18 00:42:24.000000000 +0100
++++ ./Makefile 2011-03-13 19:47:52.000000000 +0100
+@@ -1,7 +1,7 @@
+ PREFIX ?= /usr/local
+
+-DIRFLAGS = -d -o root -g wheel -m 0555
+-EXFLAGS = -Sp -o root -g wheel -m 0555
++DIRFLAGS = -d -o root -g wheel -m 0755
++EXFLAGS = -Sp -o root -g wheel -m 0755
+ INFLAGS = -Sp -o root -g wheel -m 0444
+ DIFFFLAGS = -u
+ BINFILES =
+@@ -15,9 +15,8 @@
+ CONFFILES = nac.conf
+ PERLLIBFILES = LibNAC.pm
+ IPFWFILES = ipfw.begin ipfw.circe ipfw.common ipfw.end ipfw.init ipfw.local
+-DIRECTORIES = /etc /etc/env.d /sbin /bin /libexec /libexec/nac \
+- /share /share/nac /lib /lib/perl5 lib/perl5/site_perl \
+- /lib/perl5/site_perl/5.10.1
++DIRECTORIES = /etc /etc/env /sbin /bin /libexec /libexec/nac \
++ /share /share/nac /lib
+
+ all:
+
+@@ -38,16 +37,14 @@
+ install $(INFLAGS) ${file} $(PREFIX)/share/nac/
+ .endfor
+ .for file in $(ENVFILES)
+- install $(INFLAGS) ${file} $(PREFIX)/etc/env.d/
++ install $(INFLAGS) ${file} $(PREFIX)/etc/env/
+ .endfor
+ .for file in $(CONFFILES)
+ install ${INFLAGS} ${file} $(PREFIX)/etc/${file}.dist
+ .endfor
+-.for file in $(PERLLIBFILES)
+- install ${INFLAGS} ${file} ${PREFIX}/lib/perl5/site_perl/5.10.1/
+-.endfor
++ install ${INFLAGS} $(PERLLIBFILES) $(SITE_PERL)
+ .for file in $(IPFWFILES)
+- install ${INFLAGS} ipfw/${file} /etc/${file}.dist
++ install ${INFLAGS} ipfw/${file} ${PREFIX}/etc/${file}.dist
+ .endfor
+
+ diff :
+@@ -64,16 +61,16 @@
+ diff $(DIFFFLAGS) ${file} $(PREFIX)/share/nac/${file} || echo
+ .endfor
+ .for file in $(ENVFILES)
+- diff $(DIFFFLAGS) ${file} $(PREFIX)/etc/env.d/${file} || echo
++ diff $(DIFFFLAGS) ${file} $(PREFIX)/etc/env/${file} || echo
+ .endfor
+ .for file in $(CONFFILES)
+ diff $(DIFFFLAGS) ${file} $(PREFIX)/etc/${file}-sample || echo
+ .endfor
+ .for file in $(PERLLIBFILES)
+- diff $(DIFFFLAGS) ${file} $(PREFIX)/lib/perl5/5.10.1/${file} || echo
++ diff $(DIFFFLAGS) ${file} $(SITE_PERL)/${file} || echo
+ .endfor
+ .for file in $(IPFWFILES)
+- diff $(DIFFFLAGS) ${file} /etc/${file}.dist || echo
++ diff $(DIFFFLAGS) ${file} ${PREFIX}/etc/${file}.dist || echo
+ .endfor
+
+ deinstall :
+@@ -90,14 +87,14 @@
+ unlink $(PREFIX)/share/nac/${file} || echo
+ .endfor
+ .for file in $(ENVFILES)
+- unlink $(PREFIX)/etc/env.d/${file} || echo
++ unlink $(PREFIX)/etc/env/${file} || echo
+ .endfor
+ .for file in $(CONFFILES)
+ unlink $(PREFIX)/etc/${file}.dist || echo
+ .endfor
+ .for file in $(PERLLIBFILES)
+- unlink $(PREFIX)/lib/perl5/5.10.1/${file} || echo
++ unlink $(SITE_PERL)/${file} || echo
+ .endfor
+ .for file in $(IPFWFILES)
+- unlink etc/${file}.dist || echo
++ unlink ${PREFIX}/etc/${file}.dist || echo
+ .endfor
diff --git a/net-mgmt/circe/pkg-descr b/net-mgmt/circe/pkg-descr
new file mode 100644
index 000000000000..0867b619accc
--- /dev/null
+++ b/net-mgmt/circe/pkg-descr
@@ -0,0 +1,4 @@
+Circe is a captive portal system. It is built using Perl and is a program that
+allows you to monitor and control who has access between two networks.
+
+WWW: http://bws.berkeley.edu/
diff --git a/net-mgmt/circe/pkg-plist b/net-mgmt/circe/pkg-plist
new file mode 100644
index 000000000000..27c0617fa301
--- /dev/null
+++ b/net-mgmt/circe/pkg-plist
@@ -0,0 +1,22 @@
+@comment $FreeBSD:
+sbin/circe-redirect
+sbin/circe-context-daemon
+sbin/circe-flush-state
+sbin/circe-get-context
+sbin/circe-get-redirect-url
+sbin/circe-ipfw-daemon
+sbin/circe-list-clients
+sbin/circe-nagios-info
+sbin/circe-set-context
+sbin/circe-set-ipfw-context
+etc/nac.conf.dist
+etc/ipfw.begin.dist
+etc/ipfw.circe.dist
+etc/ipfw.common.dist
+etc/ipfw.end.dist
+etc/ipfw.init.dist
+etc/ipfw.local.dist
+%%SITE_PERL%%/LibNAC.pm
+@unexec rmdir %D/etc/env 2>/dev/null || true
+@unexec rmdir %D/share/nac 2>/dev/null || true
+@unexec rmdir %D/libexec/nac 2>/dev/null || true