aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Any/Makefile24
-rw-r--r--devel/p5-Log-Any/distinfo3
-rw-r--r--devel/p5-Log-Any/pkg-descr5
-rw-r--r--devel/p5-Log-Any/pkg-plist15
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e9a171cdef38..9efe8caf396c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1571,6 +1571,7 @@
SUBDIR += p5-Log-Accounting-SVN
SUBDIR += p5-Log-Agent
SUBDIR += p5-Log-Agent-Logger
+ SUBDIR += p5-Log-Any
SUBDIR += p5-Log-Dispatch
SUBDIR += p5-Log-Dispatch-Colorful
SUBDIR += p5-Log-Dispatch-Config
diff --git a/devel/p5-Log-Any/Makefile b/devel/p5-Log-Any/Makefile
new file mode 100644
index 000000000000..1e59f76c7a18
--- /dev/null
+++ b/devel/p5-Log-Any/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Log::Any
+# Date created: 30 Aug 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Any
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to bring loggers and listeners together
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Any.3 \
+ Log::Any::Adapter::Base.3 \
+ Log::Any::Adapter::Development.3 \
+ Log::Any::Adapter::Null.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Any/distinfo b/devel/p5-Log-Any/distinfo
new file mode 100644
index 000000000000..6e7c933fe56c
--- /dev/null
+++ b/devel/p5-Log-Any/distinfo
@@ -0,0 +1,3 @@
+MD5 (Log-Any-0.03.tar.gz) = 0dc949bcf675621e80df4c3b7946ecb1
+SHA256 (Log-Any-0.03.tar.gz) = 30c82ab23099b36767e32608bc968e3a3e37157256130f116f43e447ef5617f0
+SIZE (Log-Any-0.03.tar.gz) = 31255
diff --git a/devel/p5-Log-Any/pkg-descr b/devel/p5-Log-Any/pkg-descr
new file mode 100644
index 000000000000..eb91fd64ec6f
--- /dev/null
+++ b/devel/p5-Log-Any/pkg-descr
@@ -0,0 +1,5 @@
+Log::Any allows CPAN modules to safely and efficiently log messages,
+while letting the application choose (or decline to choose) a logging
+mechanism such as Log::Dispatch or Log::Log4perl.
+
+WWW: http://search.cpan.org/dist/Log-Any/
diff --git a/devel/p5-Log-Any/pkg-plist b/devel/p5-Log-Any/pkg-plist
new file mode 100644
index 000000000000..88697a521467
--- /dev/null
+++ b/devel/p5-Log-Any/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Any/.packlist
+%%SITE_PERL%%/Log/Any.pm
+%%SITE_PERL%%/Log/Any/Adapter/Base.pm
+%%SITE_PERL%%/Log/Any/Adapter/Development.pod
+%%SITE_PERL%%/Log/Any/Adapter/Null.pm
+%%SITE_PERL%%/Log/Any/Manager.pm
+%%SITE_PERL%%/Log/Any/Test/Adapter/Memory.pm
+%%SITE_PERL%%/Log/Any/Util.pm
+@dirrm %%SITE_PERL%%/Log/Any/Test/Adapter
+@dirrm %%SITE_PERL%%/Log/Any/Test
+@dirrm %%SITE_PERL%%/Log/Any/Adapter
+@dirrm %%SITE_PERL%%/Log/Any
+@dirrmtry %%SITE_PERL%%/Log
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Any
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log