aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/44bsd-rdist/Makefile32
-rw-r--r--net/44bsd-rdist/distinfo1
-rw-r--r--net/44bsd-rdist/pkg-comment1
-rw-r--r--net/44bsd-rdist/pkg-descr2
-rw-r--r--net/44bsd-rdist/pkg-plist1
-rw-r--r--net/Makefile1
6 files changed, 38 insertions, 0 deletions
diff --git a/net/44bsd-rdist/Makefile b/net/44bsd-rdist/Makefile
new file mode 100644
index 000000000000..2012ba3afffe
--- /dev/null
+++ b/net/44bsd-rdist/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: rdist
+# Date created: 11 November 2000
+# Whom: David O'Brien <obrien@NUXI.com>
+#
+# $FreeBSD$
+#
+PORTNAME= 44bsd-rdist
+PORTVERSION= 20001111
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= obrien
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+
+NO_WRKSUBDIR= yes
+MAN1= 44bsd-rdist.1
+
+post-extract:
+ cd ${WRKSRC} ; co RCS/*,v
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rdist ${PREFIX}/bin/44bsd-rdist
+ ${INSTALL_MAN} ${WRKSRC}/rdist.1 ${PREFIX}/man/man1/44bsd-rdist.1
+
+tarup:
+ -cd ${WRKSRC} ; rm *
+ cd ${WRKSRC} ; tar cvyf /tmp/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} .
+
+.include <bsd.port.mk>
diff --git a/net/44bsd-rdist/distinfo b/net/44bsd-rdist/distinfo
new file mode 100644
index 000000000000..ea83cc4c7dcb
--- /dev/null
+++ b/net/44bsd-rdist/distinfo
@@ -0,0 +1 @@
+MD5 (44bsd-rdist-20001111.tar.bz2) = 0d145736ce13efb493e856ddf2a80a79
diff --git a/net/44bsd-rdist/pkg-comment b/net/44bsd-rdist/pkg-comment
new file mode 100644
index 000000000000..421eb7693bea
--- /dev/null
+++ b/net/44bsd-rdist/pkg-comment
@@ -0,0 +1 @@
+The traditional 4.4BSD rdist
diff --git a/net/44bsd-rdist/pkg-descr b/net/44bsd-rdist/pkg-descr
new file mode 100644
index 000000000000..0cc7ad28a7b2
--- /dev/null
+++ b/net/44bsd-rdist/pkg-descr
@@ -0,0 +1,2 @@
+This is the the traditional 4.4BSD /usr/bin/rdist, with additional
+FreeBSD fixes and updates since 4.4BSD Lite was released.
diff --git a/net/44bsd-rdist/pkg-plist b/net/44bsd-rdist/pkg-plist
new file mode 100644
index 000000000000..c7871526fc91
--- /dev/null
+++ b/net/44bsd-rdist/pkg-plist
@@ -0,0 +1 @@
+bin/44bsd-rdist
diff --git a/net/Makefile b/net/Makefile
index f95a164d6020..8fd9673ab0e1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
#
+ SUBDIR += 44bsd-rdist
SUBDIR += SSLtelnet
SUBDIR += adasockets
SUBDIR += adns