aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/openssl/Makefile4
-rw-r--r--security/openssl/distinfo9
-rw-r--r--security/openssl/files/patch-Configure22
-rw-r--r--security/openssl/files/patch-c_rehash.in19
4 files changed, 50 insertions, 4 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 088801b4f59d..852ce76ed66c 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
@@ -1122,6 +1123,9 @@ BROKEN= Patches do not merge, please change options
PATCHFILES+= dtls-replay-bug-1.0.0.patch
PATCHFILES+= dtls-buffer-bug-1.0.0.patch
PATCHFILES+= dtls-timeout-bug-1.0.0.patch
+PATCHFILES+= dtls-badmac-bug-1.0.0.patch
+PATCHFILES+= dtls-badmsg-alert-bug-1.0.0.patch
+PATCHFILES+= dtls-reassembly-bug-1.0.0.patch
.endif
.if defined(WITH_DTLS_RENEGOTIATION) || make(makesum)
PATCHFILES+= abbreviated-renegotiation.patch
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 33b5fac96a44..a26a39a02c8e 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -10,6 +10,15 @@ SIZE (openssl-1.0.0/dtls-buffer-bug-1.0.0.patch) = 388
MD5 (openssl-1.0.0/dtls-timeout-bug-1.0.0.patch) = 4ea76473161328ac84e17606b80ef202
SHA256 (openssl-1.0.0/dtls-timeout-bug-1.0.0.patch) = 069ba0e8b4137f7754b50e173d50a9f7748f424b003690fc9c7d34b46ac17403
SIZE (openssl-1.0.0/dtls-timeout-bug-1.0.0.patch) = 442
+MD5 (openssl-1.0.0/dtls-badmac-bug-1.0.0.patch) = 3c83737cd831caa9d059ddc5ac72478a
+SHA256 (openssl-1.0.0/dtls-badmac-bug-1.0.0.patch) = cbdf4594fe4c1e8a02207f1adbee6ad8ea1a68d0f975e072305b5d6dcb96ef1f
+SIZE (openssl-1.0.0/dtls-badmac-bug-1.0.0.patch) = 444
+MD5 (openssl-1.0.0/dtls-badmsg-alert-bug-1.0.0.patch) = a37855ac4977717d6ae2c81b9e9346bf
+SHA256 (openssl-1.0.0/dtls-badmsg-alert-bug-1.0.0.patch) = d666bf237df50a6130a68bce74d6281f75d11f855e78622965199f14a72628bc
+SIZE (openssl-1.0.0/dtls-badmsg-alert-bug-1.0.0.patch) = 2192
+MD5 (openssl-1.0.0/dtls-reassembly-bug-1.0.0.patch) = 4eb20cb6c8cf014942435b4f63197b66
+SHA256 (openssl-1.0.0/dtls-reassembly-bug-1.0.0.patch) = 808011b2d84631aa6f04652b48fdfb1c79778ae95cb5b1d3371be8dc7bb376f3
+SIZE (openssl-1.0.0/dtls-reassembly-bug-1.0.0.patch) = 13328
MD5 (openssl-1.0.0/abbreviated-renegotiation.patch) = 2409eb80e65effb928032ee18f690dd7
SHA256 (openssl-1.0.0/abbreviated-renegotiation.patch) = ddbc0683461d364af25b3cd7481d73c6476bfcfb945b3b3c9883f72eabb6367f
SIZE (openssl-1.0.0/abbreviated-renegotiation.patch) = 6578
diff --git a/security/openssl/files/patch-Configure b/security/openssl/files/patch-Configure
index defb17c137d2..f13eef1d8358 100644
--- a/security/openssl/files/patch-Configure
+++ b/security/openssl/files/patch-Configure
@@ -1,6 +1,6 @@
---- Configure.orig 2009-07-08 10:50:52.000000000 +0200
-+++ Configure 2009-09-11 14:02:22.000000000 +0200
-@@ -144,7 +144,7 @@
+--- Configure.orig 2010-05-05 10:43:11.000000000 +0200
++++ Configure 2010-05-05 10:43:12.000000000 +0200
+@@ -147,7 +147,7 @@
# which has to be accompanied by explicit -D_THREAD_SAFE and
# sometimes -D_REENTRANT. FreeBSD 5.x expands it as -lc_r, which
# seems to be sufficient?
@@ -9,7 +9,7 @@
#config-string $cc : $cflags : $unistd : $thread_cflag : $sys_id : $lflags : $bn_ops : $cpuid_obj : $bn_obj : $des_obj : $aes_obj : $bf_obj : $md5_obj : $sha1_obj : $cast_obj : $rc4_obj : $rmd160_obj : $rc5_obj : $wp_obj : $cmll_obj : $dso_scheme : $shared_target : $shared_cflag : $shared_ldflag : $shared_extension : $ranlib : $arflags : $multilib
-@@ -376,19 +376,20 @@
+@@ -382,19 +382,20 @@
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
#### *BSD [do see comment about ${BSDthreads} above!]
@@ -39,3 +39,17 @@
"bsdi-elf-gcc", "gcc:-DPERL5 -DL_ENDIAN -fomit-frame-pointer -O3 -march=i486 -Wall::(unknown)::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+@@ -1816,11 +1817,11 @@
+ (system $make_command.$make_targets) == 0 or exit $?
+ if $make_targets ne "";
+ if ( $perl =~ m@^/@) {
+- &dofile("tools/c_rehash",$perl,'^#!/', '#!%s','^my \$dir;$', 'my $dir = "' . $openssldir . '";');
++ &dofile("tools/c_rehash",$perl,'^#!/', '#!%s','^my \$dir;$', 'my $dir = "' . $openssldir . '";', '^my \$prefix;$', 'my $prefix = "' . $prefix . '";');
+ &dofile("apps/CA.pl",$perl,'^#!/', '#!%s');
+ } else {
+ # No path for Perl known ...
+- &dofile("tools/c_rehash",'/usr/local/bin/perl','^#!/', '#!%s','^my \$dir;$', 'my $dir = "' . $openssldir . '";');
++ &dofile("tools/c_rehash",'/usr/local/bin/perl','^#!/', '#!%s','^my \$dir;$', 'my $dir = "' . $openssldir . '";', '^my \$prefix;$', 'my $prefix = "' . $prefix . '";');
+ &dofile("apps/CA.pl",'/usr/local/bin/perl','^#!/', '#!%s');
+ }
+ if ($depflags ne $default_depflags && !$make_depend) {
diff --git a/security/openssl/files/patch-c_rehash.in b/security/openssl/files/patch-c_rehash.in
new file mode 100644
index 000000000000..4ab267b625c5
--- /dev/null
+++ b/security/openssl/files/patch-c_rehash.in
@@ -0,0 +1,19 @@
+--- tools/c_rehash.in.orig 2009-04-22 18:50:42.000000000 +0200
++++ tools/c_rehash.in 2010-05-05 10:43:12.000000000 +0200
+@@ -7,6 +7,7 @@
+ my $openssl;
+
+ my $dir;
++my $prefix;
+
+ if(defined $ENV{OPENSSL}) {
+ $openssl = $ENV{OPENSSL};
+@@ -24,7 +25,7 @@
+ }
+ my $path_delim = ($pwd =~ /^[a-z]\:/i) ? ';' : ':'; # DOS/Win32 or Unix delimiter?
+
+-$ENV{PATH} .= "$path_delim$dir/bin";
++$ENV{PATH} = "$prefix/bin" . ($ENV{PATH} ? $path_delim . $ENV{PATH} : ""); # prefix our path
+
+ if(! -x $openssl) {
+ my $found = 0;