aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/kdepim3/Makefile4
-rw-r--r--deskutils/kdepim4/Makefile4
-rw-r--r--deskutils/kdepim44/Makefile4
-rw-r--r--x11/kde4-baseapps/Makefile5
-rw-r--r--x11/kde4-runtime/Makefile5
-rw-r--r--x11/kde4-workspace/Makefile5
-rw-r--r--x11/kdebase3/Makefile5
-rw-r--r--x11/kdebase4-runtime/Makefile5
-rw-r--r--x11/kdebase4-workspace/Makefile5
-rw-r--r--x11/kdebase4/Makefile5
10 files changed, 37 insertions, 10 deletions
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 770af852164e..df1d67abdb03 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -27,6 +27,7 @@ PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_BISON= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -34,7 +35,8 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ARGS= --with-gpg=${LOCALBASE}/bin/gpg \
- --with-gpgsm=${LOCALBASE}/bin/gpgsm
+ --with-gpgsm=${LOCALBASE}/bin/gpgsm \
+ --with-ssl-dir=/
OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 770af852164e..df1d67abdb03 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -27,6 +27,7 @@ PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_BISON= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -34,7 +35,8 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ARGS= --with-gpg=${LOCALBASE}/bin/gpg \
- --with-gpgsm=${LOCALBASE}/bin/gpgsm
+ --with-gpgsm=${LOCALBASE}/bin/gpgsm \
+ --with-ssl-dir=/
OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 770af852164e..df1d67abdb03 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -27,6 +27,7 @@ PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_BISON= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -34,7 +35,8 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ARGS= --with-gpg=${LOCALBASE}/bin/gpg \
- --with-gpgsm=${LOCALBASE}/bin/gpgsm
+ --with-gpgsm=${LOCALBASE}/bin/gpgsm \
+ --with-ssl-dir=/
OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 8c5c85f83337..61a78c1eb313 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -29,6 +29,8 @@ PREFIX= ${KDE_PREFIX}
USE_GETOPT_LONG=yes
USE_OPENLDAP= yes
+USE_OPENSSL= yes
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
@@ -45,7 +47,8 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
CONFIGURE_ENV+= RUN_KAPPFINDER=no kde_cv_utmp_file=/var/run/utmp
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
- --with-xdmdir=${X11BASE}/lib/X11/xdm
+ --with-xdmdir=${X11BASE}/lib/X11/xdm \
+ --with-ssl-dir=/
OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on