aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-dateutil/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/py-dateutil/Makefile b/devel/py-dateutil/Makefile
index f39efff2ee6f..1d2af38e3b6a 100644
--- a/devel/py-dateutil/Makefile
+++ b/devel/py-dateutil/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dateutil
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,6 +21,10 @@ USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= python-dateutil
+# Fix incorrect permissions
+post-patch:
+ @${FIND} ${WRKSRC}/python_dateutil.egg-info -type f -exec ${CHMOD} ${SHAREMODE} {} ";"
+
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} test.py