aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/cl-stumpwm/Makefile46
-rw-r--r--x11-wm/cl-stumpwm/distinfo9
-rw-r--r--x11-wm/stumpwm/Makefile46
-rw-r--r--x11-wm/stumpwm/distinfo9
4 files changed, 82 insertions, 28 deletions
diff --git a/x11-wm/cl-stumpwm/Makefile b/x11-wm/cl-stumpwm/Makefile
index df9db3954aad..ffbf396bb912 100644
--- a/x11-wm/cl-stumpwm/Makefile
+++ b/x11-wm/cl-stumpwm/Makefile
@@ -6,31 +6,55 @@
#
PORTNAME= stumpwm
-PORTVERSION= 0.9.6
+PORTVERSION= 0.9.7
CATEGORIES= x11-wm
MASTER_SITES= SAVANNAH
-EXTRACT_SUFX= .tgz
+DISTFILES= ${DISTNAME}.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A tiling, keyboard driven Window Manager written in Common Lisp
-BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-lisp=clisp
+MAKE_JOBS_UNSAFE=yes
PLIST_FILES= bin/${PORTNAME}
INFO= ${PORTNAME}
-.include <bsd.port.pre.mk>
+OPTIONS= SBCL "Build with lang/sbcl (otherwise with lang/clisp)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SBCL) || make(makesum) || defined(FETCH_ALL)
+MASTER_SITES+= http://common-lisp.net/~abridgewater/dist/clx/:clx
+DISTFILES+= clx-0.7.4.tgz:clx
+.endif
+
+.if defined(WITH_SBCL)
+CONFIGURE_ARGS= --with-lisp=sbcl
+BUILD_DEPENDS+= sbcl:${PORTSDIR}/lang/sbcl
+.else
+CONFIGURE_ARGS= --with-lisp=clisp
+BUILD_DEPENDS+= clisp:${PORTSDIR}/lang/clisp
+.endif
-.if !exists(${LOCALBASE}/bin/clisp) || \
+.if !defined(WITH_SBCL)
+.if exists(${LOCALBASE}/bin/clisp) && \
!exists(${LOCALBASE}/lib/clisp/full/clx.o)
IGNORE= requires lang/clisp built with CLX_NEW option ON
.endif
+.endif
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.info ${PREFIX}/${INFO_PATH}
+.if defined(WITH_SBCL)
+post-extract: .SILENT
+ ${LN} -sf ${WRKDIR}/clx*/*.asd ${WRKSRC}/cl-ppcre/*.asd ${WRKSRC}
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} 's|sbcl_.*OPTS=|&--disable-debugger --no-userinit \
+ --eval "(require :asdf)" \
+ --eval "(pop asdf:*central-registry*)" |' \
+ ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} 's/\(sb-introspect:function-\)arglist/\1lambda-list/' \
+ ${WRKSRC}/manual.lisp
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/cl-stumpwm/distinfo b/x11-wm/cl-stumpwm/distinfo
index 5c73359c70fd..aa03dda96ff2 100644
--- a/x11-wm/cl-stumpwm/distinfo
+++ b/x11-wm/cl-stumpwm/distinfo
@@ -1,3 +1,6 @@
-MD5 (stumpwm-0.9.6.tgz) = 36b6cf74d680ed6d0ba1cde4b5e063ec
-SHA256 (stumpwm-0.9.6.tgz) = 5ff75361148bbfe9425e4a53b96dd5461ef65717299de97753da51116368fe77
-SIZE (stumpwm-0.9.6.tgz) = 487015
+MD5 (stumpwm-0.9.7.tgz) = cfdf39945908802f59b70e6c4675d27a
+SHA256 (stumpwm-0.9.7.tgz) = a0793d22ef90731d34f84e51deafb4bc2095a357c70b9505dc57516f481cdf78
+SIZE (stumpwm-0.9.7.tgz) = 497663
+MD5 (clx-0.7.4.tgz) = d18b9fcc3a5d085e1a73c59a6ecc9413
+SHA256 (clx-0.7.4.tgz) = 4a80f80255ace26eb8df214957dda3d7b7e51955537405ec893a34b18e569028
+SIZE (clx-0.7.4.tgz) = 444490
diff --git a/x11-wm/stumpwm/Makefile b/x11-wm/stumpwm/Makefile
index df9db3954aad..ffbf396bb912 100644
--- a/x11-wm/stumpwm/Makefile
+++ b/x11-wm/stumpwm/Makefile
@@ -6,31 +6,55 @@
#
PORTNAME= stumpwm
-PORTVERSION= 0.9.6
+PORTVERSION= 0.9.7
CATEGORIES= x11-wm
MASTER_SITES= SAVANNAH
-EXTRACT_SUFX= .tgz
+DISTFILES= ${DISTNAME}.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A tiling, keyboard driven Window Manager written in Common Lisp
-BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-lisp=clisp
+MAKE_JOBS_UNSAFE=yes
PLIST_FILES= bin/${PORTNAME}
INFO= ${PORTNAME}
-.include <bsd.port.pre.mk>
+OPTIONS= SBCL "Build with lang/sbcl (otherwise with lang/clisp)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SBCL) || make(makesum) || defined(FETCH_ALL)
+MASTER_SITES+= http://common-lisp.net/~abridgewater/dist/clx/:clx
+DISTFILES+= clx-0.7.4.tgz:clx
+.endif
+
+.if defined(WITH_SBCL)
+CONFIGURE_ARGS= --with-lisp=sbcl
+BUILD_DEPENDS+= sbcl:${PORTSDIR}/lang/sbcl
+.else
+CONFIGURE_ARGS= --with-lisp=clisp
+BUILD_DEPENDS+= clisp:${PORTSDIR}/lang/clisp
+.endif
-.if !exists(${LOCALBASE}/bin/clisp) || \
+.if !defined(WITH_SBCL)
+.if exists(${LOCALBASE}/bin/clisp) && \
!exists(${LOCALBASE}/lib/clisp/full/clx.o)
IGNORE= requires lang/clisp built with CLX_NEW option ON
.endif
+.endif
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.info ${PREFIX}/${INFO_PATH}
+.if defined(WITH_SBCL)
+post-extract: .SILENT
+ ${LN} -sf ${WRKDIR}/clx*/*.asd ${WRKSRC}/cl-ppcre/*.asd ${WRKSRC}
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} 's|sbcl_.*OPTS=|&--disable-debugger --no-userinit \
+ --eval "(require :asdf)" \
+ --eval "(pop asdf:*central-registry*)" |' \
+ ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} 's/\(sb-introspect:function-\)arglist/\1lambda-list/' \
+ ${WRKSRC}/manual.lisp
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/stumpwm/distinfo b/x11-wm/stumpwm/distinfo
index 5c73359c70fd..aa03dda96ff2 100644
--- a/x11-wm/stumpwm/distinfo
+++ b/x11-wm/stumpwm/distinfo
@@ -1,3 +1,6 @@
-MD5 (stumpwm-0.9.6.tgz) = 36b6cf74d680ed6d0ba1cde4b5e063ec
-SHA256 (stumpwm-0.9.6.tgz) = 5ff75361148bbfe9425e4a53b96dd5461ef65717299de97753da51116368fe77
-SIZE (stumpwm-0.9.6.tgz) = 487015
+MD5 (stumpwm-0.9.7.tgz) = cfdf39945908802f59b70e6c4675d27a
+SHA256 (stumpwm-0.9.7.tgz) = a0793d22ef90731d34f84e51deafb4bc2095a357c70b9505dc57516f481cdf78
+SIZE (stumpwm-0.9.7.tgz) = 497663
+MD5 (clx-0.7.4.tgz) = d18b9fcc3a5d085e1a73c59a6ecc9413
+SHA256 (clx-0.7.4.tgz) = 4a80f80255ace26eb8df214957dda3d7b7e51955537405ec893a34b18e569028
+SIZE (clx-0.7.4.tgz) = 444490