aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/scons.mk2
-rw-r--r--audio/csound/Makefile1
2 files changed, 3 insertions, 0 deletions
diff --git a/Mk/Uses/scons.mk b/Mk/Uses/scons.mk
index 3866cb823bdf..59a9201ad387 100644
--- a/Mk/Uses/scons.mk
+++ b/Mk/Uses/scons.mk
@@ -17,6 +17,8 @@ IGNORE= Incorrect 'USES+= scons:${scons_ARGS}' scons takes no arguments
MAKEFILE= #
MAKE_FLAGS= #
ALL_TARGET= #
+CCFLAGS?= ${CFLAGS}
+LINKFLAGS?= ${LDFLAGS}
LIBPATH?= ${LOCALBASE}/lib
CPPPATH?= ${LOCALBASE}/include
SCONS= ${LOCALBASE}/bin/scons
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 5f2c94d3760c..da696bdbec9d 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -52,6 +52,7 @@ SSP_UNSAFE= yes
CFLAGS+= -fPIC -fopenmp -DUSE_OPENMP
LDFLAGS+= -pthread -Wl,-export-dynamic
+LINKFLAGS= # empty
SUB_FILES= pkg-message