aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/armagetron/Makefile4
-rw-r--r--games/battleball/Makefile4
-rw-r--r--games/blobwars/Makefile8
3 files changed, 15 insertions, 1 deletions
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index 2cec6d68ab4c..ac21b8759dce 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -30,6 +30,10 @@ OPTIONS= MUSIC "Compile in support for background music" on
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if !defined(WITHOUT_MUSIC)
USE_SDL+= mixer
CONFIGURE_ARGS+=--enable-music
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index e6eaa488793e..a7c5c1429820 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -32,6 +32,10 @@ PORTDOCS= CHANGELOG README
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= "Does not compile on ia64 or sparc64"
.endif
diff --git a/games/blobwars/Makefile b/games/blobwars/Makefile
index ce8429f2932c..5b55864a6091 100644
--- a/games/blobwars/Makefile
+++ b/games/blobwars/Makefile
@@ -36,4 +36,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>