aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/pianobar/Makefile1
-rw-r--r--databases/postgis20/Makefile2
-rw-r--r--databases/postgis21/Makefile1
-rw-r--r--devel/json-c/Makefile14
-rw-r--r--devel/json-c/distinfo4
-rw-r--r--devel/json-c/pkg-descr4
-rw-r--r--devel/json-c/pkg-plist35
-rw-r--r--graphics/mypaint/Makefile2
-rw-r--r--net/grive/Makefile1
-rw-r--r--security/razorback-api/Makefile4
-rw-r--r--security/razorback-virusTotal/Makefile1
-rw-r--r--sysutils/rsyslog6-gnutls/Makefile2
-rw-r--r--sysutils/rsyslog6-relp/Makefile2
-rw-r--r--sysutils/rsyslog6/Makefile4
-rw-r--r--sysutils/rsyslog7-devel/Makefile3
-rw-r--r--sysutils/rsyslog7/Makefile3
-rw-r--r--www/newsbeuter/Makefile3
17 files changed, 56 insertions, 30 deletions
diff --git a/audio/pianobar/Makefile b/audio/pianobar/Makefile
index 2f8714040489..83cf09578c31 100644
--- a/audio/pianobar/Makefile
+++ b/audio/pianobar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pianobar
PORTVERSION= 2013.09.15
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://6xq.net/projects/${PORTNAME}/
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 80e59f3c39bd..743f54bdae38 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -2,7 +2,7 @@
PORTNAME= postgis
PORTVERSION= 2.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases geography
MASTER_SITES= http://download.osgeo.org/postgis/source/
diff --git a/databases/postgis21/Makefile b/databases/postgis21/Makefile
index 0a53e86a3ad2..55e86007c2af 100644
--- a/databases/postgis21/Makefile
+++ b/databases/postgis21/Makefile
@@ -2,6 +2,7 @@
PORTNAME= postgis
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= http://download.osgeo.org/postgis/source/
diff --git a/devel/json-c/Makefile b/devel/json-c/Makefile
index bb63a76b8c82..d0caf6e6e6e9 100644
--- a/devel/json-c/Makefile
+++ b/devel/json-c/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= json-c
-PORTVERSION= 0.9
+PORTVERSION= 0.11
CATEGORIES= devel
-MASTER_SITES= http://oss.metaparadigm.com/json-c/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/
MAINTAINER= gno@yahoo-inc.com
COMMENT= JSON (JavaScript Object Notation) implementation in C
@@ -12,8 +12,16 @@ COMMENT= JSON (JavaScript Object Notation) implementation in C
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USES= gmake pathfix pkgconfig
+USE_GITHUB= yes
+USE_ZIP= yes
+MAKE_JOBS_UNSAFE= yes
+
+GH_ACCOUNT= ${PORTNAME}
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= 20130402
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}
CONFLICTS= cocaine-core-[0-9]*
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/json-c/distinfo b/devel/json-c/distinfo
index 6c2a03aba154..99597aa507e3 100644
--- a/devel/json-c/distinfo
+++ b/devel/json-c/distinfo
@@ -1,2 +1,2 @@
-SHA256 (json-c-0.9.tar.gz) = 702a486c9bf8e19137d484ab5c49b4ad314eb5e1fe37062a72c0a0fa39439475
-SIZE (json-c-0.9.tar.gz) = 340953
+SHA256 (json-c-0.11.zip) = b32bedb692ab0ab8205df7837e806082ec459b55693730238ca03238cf896e95
+SIZE (json-c-0.11.zip) = 550947
diff --git a/devel/json-c/pkg-descr b/devel/json-c/pkg-descr
index e9d89056c617..2f20aa1fc010 100644
--- a/devel/json-c/pkg-descr
+++ b/devel/json-c/pkg-descr
@@ -1,5 +1,5 @@
This is a port of json-c, an implementation of json in C. Json, JavaScript
Object Notation is a lightweight data exchange format and a subset of the
-JavaScript programming language.
+JavaScript programming language.
-WWW: http://oss.metaparadigm.com/json-c/
+WWW: https://github.com/json-c/json-c/wiki
diff --git a/devel/json-c/pkg-plist b/devel/json-c/pkg-plist
index de93c220760b..e6db1e7922cc 100644
--- a/devel/json-c/pkg-plist
+++ b/devel/json-c/pkg-plist
@@ -1,16 +1,27 @@
lib/libjson.a
lib/libjson.la
lib/libjson.so
-lib/libjson.so.0
-include/json/arraylist.h
-include/json/bits.h
-include/json/debug.h
-include/json/json.h
-include/json/json_object.h
-include/json/json_object_private.h
-include/json/json_tokener.h
-include/json/json_util.h
-include/json/linkhash.h
-include/json/printbuf.h
+lib/libjson.so.1
+lib/libjson-c.a
+lib/libjson-c.la
+lib/libjson-c.so
+lib/libjson-c.so.2
+include/json-c/arraylist.h
+include/json-c/bits.h
+include/json-c/debug.h
+include/json-c/json.h
+include/json-c/json_c_version.h
+include/json-c/json_config.h
+include/json-c/json_inttypes.h
+include/json-c/json_object.h
+include/json-c/json_object_iterator.h
+include/json-c/json_object_private.h
+include/json-c/json_tokener.h
+include/json-c/json_util.h
+include/json-c/linkhash.h
+include/json-c/printbuf.h
+include/json
libdata/pkgconfig/json.pc
-@dirrm include/json
+libdata/pkgconfig/json-c.pc
+@dirrmtry include/json
+@dirrm include/json-c
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index 85c2accc63b3..91f55ee8df06 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mypaint
PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://download.gna.org/mypaint/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/net/grive/Makefile b/net/grive/Makefile
index 14cc49ff5c0c..61f1271998af 100644
--- a/net/grive/Makefile
+++ b/net/grive/Makefile
@@ -3,6 +3,7 @@
PORTNAME= grive
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= net
MAINTAINER= ktsin@acm.org
diff --git a/security/razorback-api/Makefile b/security/razorback-api/Makefile
index 444b1a8e32aa..d4dcbf4156a2 100644
--- a/security/razorback-api/Makefile
+++ b/security/razorback-api/Makefile
@@ -2,7 +2,7 @@
PORTNAME= api
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/API
PKGNAMEPREFIX= razorback-
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= config.10:${PORTSDIR}/devel/libconfig \
uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
curl:${PORTSDIR}/ftp/curl \
- json.0:${PORTSDIR}/devel/json-c
+ libjson.so:${PORTSDIR}/devel/json-c
OPTIONS_DEFINE= DEBUG ASSERT CNC_DEBUG STOMP_DEBUG
diff --git a/security/razorback-virusTotal/Makefile b/security/razorback-virusTotal/Makefile
index 72a2b575705e..929c71b0de1c 100644
--- a/security/razorback-virusTotal/Makefile
+++ b/security/razorback-virusTotal/Makefile
@@ -3,6 +3,7 @@
PORTNAME= virusTotal
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Nuggets
PKGNAMEPREFIX= razorback-
diff --git a/sysutils/rsyslog6-gnutls/Makefile b/sysutils/rsyslog6-gnutls/Makefile
index 8848bb3f94c5..3f49acbe4d57 100644
--- a/sysutils/rsyslog6-gnutls/Makefile
+++ b/sysutils/rsyslog6-gnutls/Makefile
@@ -1,7 +1,7 @@
# Created by: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 3
COMMENT= GNUTLS module for rsyslog
MASTERDIR= ${.CURDIR}/../rsyslog6
diff --git a/sysutils/rsyslog6-relp/Makefile b/sysutils/rsyslog6-relp/Makefile
index df5b159bed7a..a447753c11a9 100644
--- a/sysutils/rsyslog6-relp/Makefile
+++ b/sysutils/rsyslog6-relp/Makefile
@@ -1,7 +1,7 @@
# Created by: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= RELP input/output module for rsyslog
MASTERDIR= ${.CURDIR}/../rsyslog6
diff --git a/sysutils/rsyslog6/Makefile b/sysutils/rsyslog6/Makefile
index b813490210aa..8f751d0f5837 100644
--- a/sysutils/rsyslog6/Makefile
+++ b/sysutils/rsyslog6/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rsyslog
PORTVERSION= 6.6.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
PKGNAMESUFFIX= 6${EXTRASUFFIX}
@@ -18,7 +18,7 @@ USE_LDCONFIG= yes
LIB_DEPENDS+= ee:${PORTSDIR}/devel/libee \
estr:${PORTSDIR}/devel/libestr \
sysinfo:${PORTSDIR}/devel/libsysinfo \
- json.0:${PORTSDIR}/devel/json-c \
+ libjson.so:${PORTSDIR}/devel/json-c \
uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
USES= pkgconfig
diff --git a/sysutils/rsyslog7-devel/Makefile b/sysutils/rsyslog7-devel/Makefile
index 30a50cc5c651..564344bae633 100644
--- a/sysutils/rsyslog7-devel/Makefile
+++ b/sysutils/rsyslog7-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rsyslog
PORTVERSION= 7.5.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
@@ -13,7 +14,7 @@ USE_LDCONFIG= yes
LIB_DEPENDS= ee:${PORTSDIR}/devel/libee \
estr:${PORTSDIR}/devel/libestr \
- json.0:${PORTSDIR}/devel/json-c \
+ libjson.so:${PORTSDIR}/devel/json-c \
uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
BUILD_DEPENDS= libgcrypt-config:${PORTSDIR}/security/libgcrypt
diff --git a/sysutils/rsyslog7/Makefile b/sysutils/rsyslog7/Makefile
index e6b4fdf69196..2739f91dff3d 100644
--- a/sysutils/rsyslog7/Makefile
+++ b/sysutils/rsyslog7/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rsyslog
PORTVERSION= 7.4.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
@@ -12,7 +13,7 @@ BUILD_DEPENDS= libgcrypt-config:${PORTSDIR}/security/libgcrypt
LIB_DEPENDS= ee:${PORTSDIR}/devel/libee \
estr:${PORTSDIR}/devel/libestr \
- json.0:${PORTSDIR}/devel/json-c
+ libjson.so:${PORTSDIR}/devel/json-c
USE_LDCONFIG= yes
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index 3a645210e63b..13187a6c9ad7 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -3,6 +3,7 @@
PORTNAME= newsbeuter
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://newsbeuter.org/downloads/
@@ -11,7 +12,7 @@ COMMENT= An RSS feed reader for the text console
LIB_DEPENDS= stfl.1:${PORTSDIR}/devel/stfl \
curl:${PORTSDIR}/ftp/curl \
- json.0:${PORTSDIR}/devel/json-c
+ libjson.so:${PORTSDIR}/devel/json-c
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE