aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/raop_play/files/patch-aexcl-Makefile.in3
-rw-r--r--dns/fastresolve/files/patch-dns-terror_getline.c24
-rw-r--r--graphics/pecomato/files/patch-Makefile.unix15
-rw-r--r--graphics/pecomato/files/patch-util.h24
-rw-r--r--security/vpnc/files/patch-sysdep.h13
5 files changed, 72 insertions, 7 deletions
diff --git a/audio/raop_play/files/patch-aexcl-Makefile.in b/audio/raop_play/files/patch-aexcl-Makefile.in
index 65bca60e729a..490b896b5975 100644
--- a/audio/raop_play/files/patch-aexcl-Makefile.in
+++ b/audio/raop_play/files/patch-aexcl-Makefile.in
@@ -15,7 +15,8 @@
-GLIB_SUBST=1 # remove this line, if you want to use libglib-2.0
DESTDIR =
- CXXFLAGS += -Wall -D_GNU_SOURCE -I../raop_play -I../rendezvous
+-CXXFLAGS += -Wall -D_GNU_SOURCE -I../raop_play -I../rendezvous
++CXXFLAGS += -Wall -I../raop_play -I../rendezvous
GLIB = glib-2.0
-CXXFLAGS += -I/usr/include/$(GLIB) -I/usr/lib/$(GLIB)/include
-CFLAGS += -Wall -I/usr/include/$(GLIB) -I/usr/lib/$(GLIB)/include -I../raop_play
diff --git a/dns/fastresolve/files/patch-dns-terror_getline.c b/dns/fastresolve/files/patch-dns-terror_getline.c
new file mode 100644
index 000000000000..fa273a133c32
--- /dev/null
+++ b/dns/fastresolve/files/patch-dns-terror_getline.c
@@ -0,0 +1,24 @@
+--- dns-terror/getline.c.orig 2009-03-25 02:34:45.000000000 -0400
++++ dns-terror/getline.c 2009-03-25 02:38:48.000000000 -0400
+@@ -26,6 +26,7 @@
+ is defined. */
+ #define _GNU_SOURCE 1
+ #include <stdio.h>
++#include <sys/param.h>
+ #include <sys/types.h>
+
+ #if defined __GNU_LIBRARY__ && HAVE_GETDELIM
+@@ -134,6 +135,7 @@
+ return ret;
+ }
+
++#if __FreeBSD_version < 800067
+ int
+ getline (lineptr, n, stream)
+ char **lineptr;
+@@ -152,4 +154,5 @@
+ {
+ return getstr (lineptr, n, stream, delimiter, 0);
+ }
++#endif /* __FreeBSD_version < 800067 */
+ #endif
diff --git a/graphics/pecomato/files/patch-Makefile.unix b/graphics/pecomato/files/patch-Makefile.unix
new file mode 100644
index 000000000000..2bc36b1146bf
--- /dev/null
+++ b/graphics/pecomato/files/patch-Makefile.unix
@@ -0,0 +1,15 @@
+--- Makefile.unix.orig 2009-03-25 03:04:17.000000000 -0400
++++ Makefile.unix 2009-03-25 03:15:45.000000000 -0400
+@@ -27,7 +27,11 @@
+ SRC_PREFIX = $(shell pwd)/dist-src
+
+ TARGET = $(PRODUCT)
+-OBJECTS = main.o gnu-strndup.o gnu-getline.o util.o exif.o iptc.o jfif.o adobe.o tiff.o
++OBJECTS = main.o util.o exif.o iptc.o jfif.o adobe.o tiff.o
++NEEDEXT = $(shell expr $(OSVERSION) \< 800067)
++ifeq ($(NEEDEXT),1)
++OBJECTS += gnu-strndup.o gnu-getline.o
++endif
+ DOC_DEFS = doc/Makefile.defs
+
+
diff --git a/graphics/pecomato/files/patch-util.h b/graphics/pecomato/files/patch-util.h
index cc78007ca30b..864049fd075a 100644
--- a/graphics/pecomato/files/patch-util.h
+++ b/graphics/pecomato/files/patch-util.h
@@ -1,10 +1,22 @@
---- util.h.orig Mon Dec 18 20:22:56 2006
-+++ util.h Mon Dec 18 20:23:03 2006
-@@ -8,6 +8,7 @@
-
- #ifndef _util_h_
+--- util.h.orig 2007-09-28 12:04:57.000000000 -0400
++++ util.h 2009-03-25 03:18:26.000000000 -0400
+@@ -10,6 +10,7 @@
#define _util_h_
-+#define _SSIZE_T_DECLARED
++#include <sys/param.h>
#include <stdio.h>
+ #include <stdarg.h>
+
+@@ -67,9 +68,11 @@
+ #define _SSIZE_T_DECLARED
+ #endif
+ #endif
++#if __FreeBSD_version < 800067
+ #include "gnu-getline.h"
+ #include "gnu-strndup.h"
+ #endif
++#endif
+
+ /* Microsoft Windows specific defines */
+ #ifdef OS_WIN32
diff --git a/security/vpnc/files/patch-sysdep.h b/security/vpnc/files/patch-sysdep.h
new file mode 100644
index 000000000000..7817f3dcdd77
--- /dev/null
+++ b/security/vpnc/files/patch-sysdep.h
@@ -0,0 +1,13 @@
+--- sysdep.h.orig 2009-03-25 03:28:26.000000000 -0400
++++ sysdep.h 2009-03-25 03:29:18.000000000 -0400
+@@ -86,6 +86,10 @@
+ #define HAVE_FGETLN 1
+ #define HAVE_UNSETENV 1
+ #define HAVE_SETENV 1
++#include <sys/param.h>
++#if __FreeBSD_version >= 800067
++#define HAVE_GETLINE 1
++#endif
+ #endif
+
+ /***************************************************************************/