aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/colorer/Makefile77
-rw-r--r--devel/colorer/distinfo2
-rw-r--r--devel/colorer/files/patch-build_properties45
-rw-r--r--devel/colorer/files/patch-catalog.xml11
-rw-r--r--devel/colorer/files/patch-doc:hrc-ref:build.xml11
-rw-r--r--devel/colorer/pkg-descr8
7 files changed, 155 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eff919b2c7bb..0124d48a64ed 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -128,6 +128,7 @@
SUBDIR += cmake
SUBDIR += codecrusader
SUBDIR += codeworker
+ SUBDIR += colorer
SUBDIR += commoncpp
SUBDIR += cons
SUBDIR += cons-test
diff --git a/devel/colorer/Makefile b/devel/colorer/Makefile
new file mode 100644
index 000000000000..4c303395ca5e
--- /dev/null
+++ b/devel/colorer/Makefile
@@ -0,0 +1,77 @@
+# ex:ts=8
+# Ports collection Makefile for: colorer
+# Date created: Feb 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= colorer
+PORTVERSION= 0.b2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+DISTNAME= Colorer-take5.beta2
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A syntax highlighting and text parsing library
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant \
+ fop:${PORTSDIR}/textproc/fop \
+ ${LOCALBASE}/share/xsl/docbook/catalog:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/share/docbook-xsd/docbook.xsd:${PORTSDIR}/textproc/docbook-xsd \
+ ${LOCALBASE}/share/mathml-xsd/mathml2.xsd:${PORTSDIR}/textproc/mathml-xsd \
+ ${LOCALBASE}/share/xhtml1-xsd/xhtml1-strict.xsd:${PORTSDIR}/textproc/xhtml1-xsd
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_JAVA= 1.4+
+NEED_JAVAC= yes
+ANT?= ${LOCALBASE}/bin/ant
+ANT_TARGET?= library-linux
+USE_GMAKE= yes
+PLIST_FILES= bin/colorer lib/libcolorer.so
+
+do-build:
+ @(cd ${WRKSRC} && ${ANT} ${ANT_TARGET} ; \
+ cd distr/Colorer-take5-linux.beta2 ; \
+ ${REINPLACE_CMD} -e "s|make -C|${GMAKE} -C|" Makefile.in ; \
+ ${CHMOD} +x configure && ${SETENV} ${CONFIGURE_ENV} ./configure ; \
+ ${GMAKE} ${PORTNAME} \
+ )
+
+do-install:
+ @(cd ${WRKSRC}/distr/Colorer-take5-linux.beta2 ; \
+ ${INSTALL_PROGRAM} src/colorer/colorer ${PREFIX}/bin ; \
+ ${INSTALL_DATA} src/libcolorer/libcolorer.so ${PREFIX}/lib ; \
+ ${MKDIR} ${DATADIR}/bin ; \
+ ${CP} -R hrc hrd ${DATADIR} ; \
+ ${CP} -R bin/4ever2take5 bin/apache bin/doclinks bin/xsd2hrc \
+ bin/ue2hrc ${DATADIR}/bin ; \
+ ${MKDIR} ${PREFIX}/include/colorer ; \
+ ${INSTALL_DATA} catalog.xml LICENSE README ${DATADIR} ; \
+ cd src/shared ; \
+ ${TAR} cf - `${FIND} * -name "*.h"` | \
+ ${TAR} xfBp - -C ${PREFIX}/include/colorer \
+ )
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/distr/Colorer-take5-linux.beta2/doc/* ${DOCSDIR}
+.endif
+# generate plist
+ @${FIND} ${DATADIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/colorer -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/colorer -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${FIND} ${DOCSDIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/colorer/distinfo b/devel/colorer/distinfo
new file mode 100644
index 000000000000..37d3d6fdacab
--- /dev/null
+++ b/devel/colorer/distinfo
@@ -0,0 +1,2 @@
+MD5 (Colorer-take5.beta2.tar.bz2) = 4ac2fd868c2ced27cc8f3833143a067b
+SIZE (Colorer-take5.beta2.tar.bz2) = 1649789
diff --git a/devel/colorer/files/patch-build_properties b/devel/colorer/files/patch-build_properties
new file mode 100644
index 000000000000..446269eeddb1
--- /dev/null
+++ b/devel/colorer/files/patch-build_properties
@@ -0,0 +1,45 @@
+--- build.properties.orig Sat Sep 13 04:46:11 2003
++++ build.properties Tue Feb 10 17:15:47 2004
+@@ -6,7 +6,7 @@
+ # gcc - *nix
+ # macos - MacOSX
+ #
+-platform=cygwin
++platform=gcc
+
+ #
+ # Target version of Colorer
+@@ -37,19 +37,19 @@
+ # Paths for the documentation generation process
+ #
+ doxygen=e:/programs/devel/doxygen/bin/doxygen.exe
+-docbook-dir=e:/programs/xml/docbook-xsl
+-fop-dir=e:/programs/xml/fop-0.20.5rc2
++docbook-dir=/usr/local/share/xsl/docbook
++fop-dir=/usr/local/share/fop
+
+ #
+ # Paths for the XSD2HRC working process
+ #
+-docbook-xsd=e:/programs/xml/docbook-xsd-1.0b1/docbook.xsd
++docbook-xsd=/usr/local/share/docbook-xsd/docbook.xsd
+ #
+-mathml-xsd=g:/install/devel/documentation/other/w3.org/REC/MathML/mathml2/mathml2.xsd
++mathml-xsd=/usr/local/share/mathml-xsd/mathml2.xsd
+ #
+ # directory with xhtml1-strict.xsd, xhtml1-transitional.xsd, xhtml1-frameset.xsd
+ #
+-xhtml-xsd-dir=g:/install/devel/documentation/other/w3.org/src
++xhtml-xsd-dir=/usr/local/share/xhtml1-xsd
+
+
+ #
+@@ -73,7 +73,7 @@
+ cygwin.makefile=-f makefile.cygwin
+
+ # GNU GCC Compiler (*nix)
+-gcc.make=make
++gcc.make=gmake
+ gcc.makefile=-f makefile.gcc
+
+ # GCC (macos)
diff --git a/devel/colorer/files/patch-catalog.xml b/devel/colorer/files/patch-catalog.xml
new file mode 100644
index 000000000000..397067512fcb
--- /dev/null
+++ b/devel/colorer/files/patch-catalog.xml
@@ -0,0 +1,11 @@
+--- catalog.xml.orig Wed Feb 11 10:11:34 2004
++++ catalog.xml Wed Feb 11 10:11:39 2004
+@@ -7,7 +7,7 @@
+ xsi:schemaLocation="http://colorer.sf.net/2003/catalog
+ http://colorer.sf.net/2003/catalog.xsd">
+
+- <hrc-sets log-location="colorer.log">
++ <hrc-sets log-location="/tmp/colorer.log">
+ <location link="hrc/colorer.hrc"/>
+ <location link="hrc/auto"/>
+ <!--
diff --git a/devel/colorer/files/patch-doc:hrc-ref:build.xml b/devel/colorer/files/patch-doc:hrc-ref:build.xml
new file mode 100644
index 000000000000..c52f92299ae8
--- /dev/null
+++ b/devel/colorer/files/patch-doc:hrc-ref:build.xml
@@ -0,0 +1,11 @@
+--- doc/hrc-ref/build.xml.orig Tue Feb 10 15:25:37 2004
++++ doc/hrc-ref/build.xml Tue Feb 10 15:25:44 2004
+@@ -14,7 +14,7 @@
+ location="../2003/catalog.dtd"/>
+ </xmlcatalog>
+
+- <property name='docbook-dir-url' value='file:/${docbook-dir}'/>
++ <property name='docbook-dir-url' value='file://${docbook-dir}'/>
+
+ <target name="init">
+ <uptodate property="pdf.required" srcfile='hrc-ref.docbook' targetfile="hrc-ref.pdf"/>
diff --git a/devel/colorer/pkg-descr b/devel/colorer/pkg-descr
new file mode 100644
index 000000000000..73e9052b4235
--- /dev/null
+++ b/devel/colorer/pkg-descr
@@ -0,0 +1,8 @@
+Colorer take5 is a syntax highlighting and text parsing library, that provides
+services of text parsing in host editor systems in real-time and transforming
+results into colored text. Result information allows to search and build
+outlined lists of functions, structures, and to search and indent programming
+language constructions (brackets, paired tags). Colorer uses pure C++, XML, it
+is fully portable and works on either win32/unix/mac platforms.
+
+WWW: http://colorer.sourceforge.net/