aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Brannigan/Makefile20
-rw-r--r--devel/p5-Brannigan/distinfo2
-rw-r--r--devel/p5-Brannigan/pkg-descr13
-rw-r--r--devel/p5-Brannigan/pkg-plist8
-rw-r--r--www/Makefile2
-rw-r--r--www/p5-McBain-WithPSGI/Makefile24
-rw-r--r--www/p5-McBain-WithPSGI/distinfo2
-rw-r--r--www/p5-McBain-WithPSGI/pkg-descr9
-rw-r--r--www/p5-McBain-WithPSGI/pkg-plist2
-rw-r--r--www/p5-McBain/Makefile24
-rw-r--r--www/p5-McBain/distinfo2
-rw-r--r--www/p5-McBain/pkg-descr10
-rw-r--r--www/p5-McBain/pkg-plist6
14 files changed, 125 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 11def3c6be1e..e4fd43c99ed6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1525,6 +1525,7 @@
SUBDIR += p5-Badger
SUBDIR += p5-Benchmark-Timer
SUBDIR += p5-Best
+ SUBDIR += p5-Brannigan
SUBDIR += p5-Bread-Board
SUBDIR += p5-Bread-Board-Declare
SUBDIR += p5-Bundle-Perl6
diff --git a/devel/p5-Brannigan/Makefile b/devel/p5-Brannigan/Makefile
new file mode 100644
index 000000000000..a7499b43bce7
--- /dev/null
+++ b/devel/p5-Brannigan/Makefile
@@ -0,0 +1,20 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Brannigan
+PORTVERSION= 1.1
+CATEGORIES= devel www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:IDOPEREL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Comprehensive, flexible system for validating and parsing input
+
+LICENSE= GPLv1 ART20
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Brannigan/distinfo b/devel/p5-Brannigan/distinfo
new file mode 100644
index 000000000000..a1878c16b94f
--- /dev/null
+++ b/devel/p5-Brannigan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Brannigan-1.1.tar.gz) = 3902ae7f7de0a46efe45fa9134067e09da135c2700a143ddac9aaaf5561ee409
+SIZE (Brannigan-1.1.tar.gz) = 49365
diff --git a/devel/p5-Brannigan/pkg-descr b/devel/p5-Brannigan/pkg-descr
new file mode 100644
index 000000000000..f7825dbd9b0a
--- /dev/null
+++ b/devel/p5-Brannigan/pkg-descr
@@ -0,0 +1,13 @@
+Brannigan is an attempt to ease the pain of collecting, validating and parsing
+input parameters in web applications. It's designed to answer both of the main
+problems that web applications face:
+
+* Simple user input
+ Brannigan can validate and parse simple, "flat", user input, possibly
+ coming from web forms.
+
+Complex data structures
+ Brannigan can validate and parse complex data structures, possibly
+ deserialized from JSON or XML data sent to web services and APIs.
+
+WWW: https://metacpan.org/pod/Brannigan
diff --git a/devel/p5-Brannigan/pkg-plist b/devel/p5-Brannigan/pkg-plist
new file mode 100644
index 000000000000..ea130fcf29d0
--- /dev/null
+++ b/devel/p5-Brannigan/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Brannigan.pm
+%%SITE_PERL%%/Brannigan/Examples.pod
+%%SITE_PERL%%/Brannigan/Tree.pm
+%%SITE_PERL%%/Brannigan/Validations.pm
+%%PERL5_MAN3%%/Brannigan.3.gz
+%%PERL5_MAN3%%/Brannigan::Examples.3.gz
+%%PERL5_MAN3%%/Brannigan::Tree.3.gz
+%%PERL5_MAN3%%/Brannigan::Validations.3.gz
diff --git a/www/Makefile b/www/Makefile
index 09113facde36..1bbfbc2c89da 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1035,6 +1035,8 @@
SUBDIR += p5-Maypole
SUBDIR += p5-Maypole-Authentication-UserSessionCookie
SUBDIR += p5-Maypole-Component
+ SUBDIR += p5-McBain
+ SUBDIR += p5-McBain-WithPSGI
SUBDIR += p5-MediaWiki
SUBDIR += p5-MediaWiki-API
SUBDIR += p5-Mobile-UserAgent
diff --git a/www/p5-McBain-WithPSGI/Makefile b/www/p5-McBain-WithPSGI/Makefile
new file mode 100644
index 000000000000..732317afcccc
--- /dev/null
+++ b/www/p5-McBain-WithPSGI/Makefile
@@ -0,0 +1,24 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= McBain-WithPSGI
+PORTVERSION= 2.001001
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:IDOPEREL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Load a McBain API as a RESTful PSGI web service
+
+LICENSE= GPLv1 PERLART10
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-McBain>=0:${PORTSDIR}/www/p5-McBain \
+ p5-JSON-MaybeXS>=0:${PORTSDIR}/converters/p5-JSON-MaybeXS \
+ p5-Plack>=1.0029:${PORTSDIR}/www/p5-Plack
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-McBain-WithPSGI/distinfo b/www/p5-McBain-WithPSGI/distinfo
new file mode 100644
index 000000000000..8bd0bfb48ed7
--- /dev/null
+++ b/www/p5-McBain-WithPSGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (McBain-WithPSGI-2.001001.tar.gz) = f128996da4f86a71732ed3db22a91be7a7a1fb395650d80660cec9b1f167b5da
+SIZE (McBain-WithPSGI-2.001001.tar.gz) = 17440
diff --git a/www/p5-McBain-WithPSGI/pkg-descr b/www/p5-McBain-WithPSGI/pkg-descr
new file mode 100644
index 000000000000..12c5b2236524
--- /dev/null
+++ b/www/p5-McBain-WithPSGI/pkg-descr
@@ -0,0 +1,9 @@
+McBain::WithPSGI turns your McBain API into a RESTful PSGI web service based on
+Plack, thus making McBain a web application framework.
+
+The created web service will be a JSON-in JSON-out service. Requests to your
+application are expected to have a Content-Type of application/json;
+charset=UTF-8. The JSON body of a request will be the payload. The results of
+the API will be formatted into JSON as well.
+
+WWW: https://metacpan.org/pod/McBain::WithPSGI
diff --git a/www/p5-McBain-WithPSGI/pkg-plist b/www/p5-McBain-WithPSGI/pkg-plist
new file mode 100644
index 000000000000..7fbf81ba1690
--- /dev/null
+++ b/www/p5-McBain-WithPSGI/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/McBain/WithPSGI.pm
+%%PERL5_MAN3%%/McBain::WithPSGI.3.gz
diff --git a/www/p5-McBain/Makefile b/www/p5-McBain/Makefile
new file mode 100644
index 000000000000..e1a31c5bb683
--- /dev/null
+++ b/www/p5-McBain/Makefile
@@ -0,0 +1,24 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= McBain
+PORTVERSION= 2.001000
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:IDOPEREL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Lightweight auto-validating, self-documenting web framework
+
+LICENSE= GPLv1 PERLART10
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Brannigan>=0:${PORTSDIR}/devel/p5-Brannigan \
+ p5-Getopt-Compact>=0:${PORTSDIR}/devel/p5-Getopt-Compact \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-McBain/distinfo b/www/p5-McBain/distinfo
new file mode 100644
index 000000000000..5f16eeb7ab5f
--- /dev/null
+++ b/www/p5-McBain/distinfo
@@ -0,0 +1,2 @@
+SHA256 (McBain-2.001000.tar.gz) = ebc7d2cc5a30f1856bfafe60addf46a39c5372dc9acac244ae602e3f39a93bc6
+SIZE (McBain-2.001000.tar.gz) = 37495
diff --git a/www/p5-McBain/pkg-descr b/www/p5-McBain/pkg-descr
new file mode 100644
index 000000000000..82de648c6e6f
--- /dev/null
+++ b/www/p5-McBain/pkg-descr
@@ -0,0 +1,10 @@
+McBain is a framework for building powerful APIs and applications. Writing an
+API with McBain provides the following benefits:
+
+* Lightweight-ness
+* Portability
+* Auto-validation
+* Self-documentation
+* Modularity and flexibility
+
+WWW: https://metacpan.org/pod/McBain
diff --git a/www/p5-McBain/pkg-plist b/www/p5-McBain/pkg-plist
new file mode 100644
index 000000000000..090f226cc854
--- /dev/null
+++ b/www/p5-McBain/pkg-plist
@@ -0,0 +1,6 @@
+bin/mcbain2pod
+%%SITE_PERL%%/McBain.pm
+%%SITE_PERL%%/McBain/Directly.pm
+%%PERL5_MAN3%%/McBain.3.gz
+%%PERL5_MAN3%%/McBain::Directly.3.gz
+man/man1/mcbain2pod.1.gz