aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/smokeping/Makefile4
-rw-r--r--net-mgmt/smokeping/pkg-install3
-rw-r--r--net-mgmt/smokeping/pkg-message1
-rw-r--r--net-mgmt/smokeping/pkg-plist18
4 files changed, 23 insertions, 3 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 78949198d56c..9273e529cbb4 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -7,7 +7,7 @@
PORTNAME= smokeping
PORTVERSION= 2.2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
MASTER_SITES= http://oss.oetiker.ch/smokeping/pub/ \
http://smokeping.cs.pu.edu.tw/pub/
@@ -264,7 +264,7 @@ do-install:
fi
.endfor
${MKDIR} ${PREFIX}/smokeping/htdocs
- ${INSTALL_SCRIPT} ${WRKSRC}/htdocs/smokeping.cgi ${PREFIX}/smokeping/htdocs/smokeping.cgi
+ ${CP} -R ${WRKSRC}/htdocs ${PREFIX}/smokeping/
${CP} -R ${WRKSRC}/lib ${PREFIX}/smokeping/
${MKDIR} ${PREFIX}/var/smokeping
${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/var/smokeping
diff --git a/net-mgmt/smokeping/pkg-install b/net-mgmt/smokeping/pkg-install
index 593c79f0135e..9068c833eab0 100644
--- a/net-mgmt/smokeping/pkg-install
+++ b/net-mgmt/smokeping/pkg-install
@@ -16,7 +16,8 @@ PRE-INSTALL)
if ! pw usershow %%USER%% 2>/dev/null 1>&2; then
if pw useradd %%USER%% -u %%UID%% -g %%GROUP%% -h - \
- -s /nonexistent -c "SmokePing Daemon"; \
+ -s "/sbin/nologin" -d "/nonexistent" \
+ -c "SmokePing Daemon"; \
then
echo 'Added user "%%USER%%".'
else
diff --git a/net-mgmt/smokeping/pkg-message b/net-mgmt/smokeping/pkg-message
index a1fe2a445c28..2581a8c6c985 100644
--- a/net-mgmt/smokeping/pkg-message
+++ b/net-mgmt/smokeping/pkg-message
@@ -29,6 +29,7 @@ To enable Apache web access, add the following to your
ScriptAlias /smokeping.cgi %%PREFIX%%/smokeping/htdocs/smokeping.cgi
Alias /smokeimg/ %%PREFIX%%/smokeping/htdocs/img/
+ Alias /cropper/ %%PREFIX%%/smokeping/htdocs/cropper/
Enjoy!
diff --git a/net-mgmt/smokeping/pkg-plist b/net-mgmt/smokeping/pkg-plist
index c3fb37d16606..a5cebf3314bc 100644
--- a/net-mgmt/smokeping/pkg-plist
+++ b/net-mgmt/smokeping/pkg-plist
@@ -108,6 +108,22 @@ etc/smokeping/tmail.dist
%%PORTDOCS%%%%EXAMPLESDIR%%/config.simple
%%PORTDOCS%%%%EXAMPLESDIR%%/config.targetvars-with-Curl
%%PORTDOCS%%%%EXAMPLESDIR%%/config.template
+smokeping/htdocs/cropper/cropper.css
+smokeping/htdocs/cropper/cropper.js
+smokeping/htdocs/cropper/cropper.uncompressed.js
+smokeping/htdocs/cropper/lib/builder.js
+smokeping/htdocs/cropper/lib/controls.js
+smokeping/htdocs/cropper/lib/dragdrop.js
+smokeping/htdocs/cropper/lib/effects.js
+smokeping/htdocs/cropper/lib/prototype.js
+smokeping/htdocs/cropper/lib/prototype.js.LICENSE
+smokeping/htdocs/cropper/lib/scriptaculous.js
+smokeping/htdocs/cropper/lib/slider.js
+smokeping/htdocs/cropper/lib/unittest.js
+smokeping/htdocs/cropper/licence.txt
+smokeping/htdocs/cropper/marqueeHoriz.gif
+smokeping/htdocs/cropper/marqueeVert.gif
+smokeping/htdocs/cropper/smokeping-zoom.js
smokeping/htdocs/smokeping.cgi
smokeping/lib/Config/Grammar.pm
smokeping/lib/Config/Grammar/Document.pm
@@ -182,6 +198,8 @@ smokeping/lib/Smokeping/sorters/base.pm
@dirrm smokeping/lib/Config/Grammar
@dirrm smokeping/lib/Config
@dirrm smokeping/lib
+@dirrm smokeping/htdocs/cropper/lib
+@dirrm smokeping/htdocs/cropper
@dirrm smokeping/htdocs
%%PORTDOCS%%@dirrm %%DOCSDIR%%/Config
%%PORTDOCS%%@dirrm %%DOCSDIR%%/Smokeping/matchers