aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/quake-reaper/Makefile37
-rw-r--r--games/quake-reaper/distinfo2
-rw-r--r--games/quake-reaper/pkg-descr3
-rw-r--r--games/quake-reaper/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 20740559dbb5..8eed40fbce91 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -464,6 +464,7 @@
SUBDIR += qonk
SUBDIR += qstat
SUBDIR += quake-data
+ SUBDIR += quake-reaper
SUBDIR += quake2forge
SUBDIR += quake2lnx
SUBDIR += quakeforge
diff --git a/games/quake-reaper/Makefile b/games/quake-reaper/Makefile
new file mode 100644
index 000000000000..ceaaf2ef9d5d
--- /dev/null
+++ b/games/quake-reaper/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: quake-reaper
+# Date created: 15 Sep 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reaper
+PORTVERSION= 0.81
+CATEGORIES= games
+MASTER_SITES= http://www.mindspring.com/~win32ch/
+DISTNAME= reaprb81
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Quake 1 bots
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in Autoexec.cfg PROGS.DAT
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}/${f:L}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in B08chg.txt Dedserv.txt Reaprb80.txt Skinspec.txt
+ @${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" ${WRKSRC}/${f}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/${f:L}
+. endfor
+.endif
+
+.include "${.CURDIR}/../quake-data/Makefile.include"
+
+.include <bsd.port.mk>
diff --git a/games/quake-reaper/distinfo b/games/quake-reaper/distinfo
new file mode 100644
index 000000000000..2a872371ad66
--- /dev/null
+++ b/games/quake-reaper/distinfo
@@ -0,0 +1,2 @@
+MD5 (reaprb81.zip) = a911d8af9fa48440d8a9eea4cd886bf6
+SIZE (reaprb81.zip) = 167024
diff --git a/games/quake-reaper/pkg-descr b/games/quake-reaper/pkg-descr
new file mode 100644
index 000000000000..a149249520e4
--- /dev/null
+++ b/games/quake-reaper/pkg-descr
@@ -0,0 +1,3 @@
+Reaper Bot is a Quake 1 modification that adds bot support to the game.
+
+WWW: http://www.mindspring.com/~win32ch/Reaper.htm
diff --git a/games/quake-reaper/pkg-plist b/games/quake-reaper/pkg-plist
new file mode 100644
index 000000000000..27e93b2a4918
--- /dev/null
+++ b/games/quake-reaper/pkg-plist
@@ -0,0 +1,8 @@
+%%PORTDOCS%%%%DOCSDIR%%/b08chg.txt
+%%PORTDOCS%%%%DOCSDIR%%/dedserv.txt
+%%PORTDOCS%%%%DOCSDIR%%/reaprb80.txt
+%%PORTDOCS%%%%DOCSDIR%%/skinspec.txt
+%%DATADIR%%/autoexec.cfg
+%%DATADIR%%/progs.dat
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%