aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/hiawatha/Makefile3
-rw-r--r--www/hiawatha/distinfo4
-rw-r--r--www/hiawatha/files/patch-hiawatha.c19
3 files changed, 3 insertions, 23 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index deb5cc5c553a..f3dd8b280eff 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hiawatha
-PORTVERSION= 7.4
-PORTREVISION= 1
+PORTVERSION= 7.4.1
CATEGORIES= www
MASTER_SITES= http://www.hiawatha-webserver.org/files/ \
http://www.c-s.li/ports/
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
index 34e84a76558c..99d56c58ca05 100644
--- a/www/hiawatha/distinfo
+++ b/www/hiawatha/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hiawatha-7.4.tar.gz) = 71e8935926e91632c0e601520f1b60c20dc961e085c692454018c6ac86ab58d2
-SIZE (hiawatha-7.4.tar.gz) = 274169
+SHA256 (hiawatha-7.4.1.tar.gz) = d541447c9d8cfec5f306772a8f67449cd456d8a34243b8e0a7a8efc6f3975d35
+SIZE (hiawatha-7.4.1.tar.gz) = 275573
diff --git a/www/hiawatha/files/patch-hiawatha.c b/www/hiawatha/files/patch-hiawatha.c
deleted file mode 100644
index c6c00ed61877..000000000000
--- a/www/hiawatha/files/patch-hiawatha.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./hiawatha.c.orig 2010-11-02 17:03:24.000000000 -0400
-+++ ./hiawatha.c 2011-02-25 16:41:31.000000000 -0500
-@@ -34,6 +34,7 @@
- #include <sys/wait.h>
- #include <sys/socket.h>
- #include <sys/time.h>
-+#include <limits.h>
- #include "alternative.h"
- #include "mimetype.h"
- #include "serverconfig.h"
-@@ -418,7 +419,7 @@
- *strend = '\0';
- content_length = str2int(strstart);
- *strend = '\r';
-- if (content_length < 0) {
-+ if ((content_length < 0) || (INT_MAX - content_length - 2 <= header_length)) {
- result = 400;
- break;
- }