aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/fspanel/Makefile29
-rw-r--r--x11/fspanel/distinfo1
-rw-r--r--x11/fspanel/pkg-comment1
-rw-r--r--x11/fspanel/pkg-descr10
-rw-r--r--x11/fspanel/pkg-plist1
6 files changed, 43 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 1e21c83aa363..002322e89287 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -29,6 +29,7 @@
SUBDIR += eweather
SUBDIR += fbsd-icons
SUBDIR += finder
+ SUBDIR += fspanel
SUBDIR += gbackground
SUBDIR += gdkxft
SUBDIR += gdm
diff --git a/x11/fspanel/Makefile b/x11/fspanel/Makefile
new file mode 100644
index 000000000000..21eefb89e868
--- /dev/null
+++ b/x11/fspanel/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: fspanel
+# Date created: 17 jan 2001
+# Whom: The Anarcat <anarcat@anarcat.dyndns.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fspanel
+PORTVERSION= 0.7.6
+CATEGORIES= x11
+MASTER_SITES= http://sapphire.sourceforge.net/
+
+# patched version is from sapphire project (0.7.6)
+# the original version (0.7) is there
+#MASTER_SITES= http://www.chatjunkies.org/${PORTNAME}/
+
+MAINTAINER= anarcat@anarcat.dyndns.org
+
+USE_X_PREFIX= yes
+MAKEFILE= Makefile.freebsd
+ALL_TARGET= ${PORTNAME}
+
+pre-patch:
+ @${PERL} -pi.orig -e "s#/usr/local#${PREFIX}#g" ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/fspanel/distinfo b/x11/fspanel/distinfo
new file mode 100644
index 000000000000..243fa543d224
--- /dev/null
+++ b/x11/fspanel/distinfo
@@ -0,0 +1 @@
+MD5 (fspanel-0.7.6.tar.gz) = ee8bc3407d5861ead66cc0e4eb4d2dc5
diff --git a/x11/fspanel/pkg-comment b/x11/fspanel/pkg-comment
new file mode 100644
index 000000000000..f00d0b2fe7de
--- /dev/null
+++ b/x11/fspanel/pkg-comment
@@ -0,0 +1 @@
+Tiny panel listing opened windows for gnome-compliant WM
diff --git a/x11/fspanel/pkg-descr b/x11/fspanel/pkg-descr
new file mode 100644
index 000000000000..f255b8c0e8e3
--- /dev/null
+++ b/x11/fspanel/pkg-descr
@@ -0,0 +1,10 @@
+FSPanel is a panel for Linux/Unix that lists all your open windows. It
+lets you iconify and bring windows to front. FSPanel is tiny, less than
+10k on i386-linux. It does require a gnome compliant window manager
+though (eg. Enlightenment, SawFish, WindowMaker, IceWM). Basically it's
+a tiny, lame, featureless panel.
+
+FSPanel does NOT and probably will never have any:
+ * program launchers
+ * menus
+ * applets
diff --git a/x11/fspanel/pkg-plist b/x11/fspanel/pkg-plist
new file mode 100644
index 000000000000..ea68c82d6eae
--- /dev/null
+++ b/x11/fspanel/pkg-plist
@@ -0,0 +1 @@
+bin/fspanel