aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--java/eclipse-pmd/Makefile50
-rw-r--r--java/eclipse-pmd/distinfo4
-rw-r--r--java/eclipse-pmd/pkg-plist93
3 files changed, 95 insertions, 52 deletions
diff --git a/java/eclipse-pmd/Makefile b/java/eclipse-pmd/Makefile
index f1dd6709b46d..f99bd89eef2f 100644
--- a/java/eclipse-pmd/Makefile
+++ b/java/eclipse-pmd/Makefile
@@ -1,40 +1,72 @@
# New ports collection makefile for: eclipse-pmd
# Date created: October 3, 2003
-# Whom: Bruno Van Den Bossche <bruno.van.den.bossche@pandora.be>
+# Whom: Bruno Van Den Bossche <brvdboss@spymac.com>
#
# $FreeBSD$
#
PORTNAME= pmd
-PORTVERSION= 1.1.2
+PORTVERSION= 2.0.5.v3
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pmd
PKGNAMEPREFIX= eclipse-
-DISTNAME= pmd-eclipse-bin-${PORTVERSION}
+DISTNAME= pmd-eclipse3-site-2.0.5
DIST_SUBDIR= eclipse
MAINTAINER= java@FreeBSD.org
COMMENT= Scan Java source code and look for potential problems
-IGNORE= is too hard to adopt Eclipse 3.0
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_ZIP= yes
+USE_JAVA= yes
CPIO?= cpio --quiet -pdmu -R
-PLUGIN_DIR= "net.sourceforge.pmd.eclipse_${PORTVERSION}"
+PMDVERSION= 1.8.0.v3
-PLIST_SUB+= PLUGIN_DIR="${PLUGIN_DIR}"
+PLUGIN_CORE_DIR="net.sourceforge.pmd.core_${PMDVERSION}"
+PLUGIN_PMD_DIR= "net.sourceforge.pmd.eclipse_${PORTVERSION}"
+
+PLIST_SUB+= PLUGIN_PMD_DIR="${PLUGIN_PMD_DIR}" \
+ PLUGIN_CORE_DIR="${PLUGIN_CORE_DIR}"
+
+post-extract:
+ cd ${WRKDIR}/features && ${MKDIR} ${PLUGIN_PMD_DIR} \
+ && ${CP} ${PLUGIN_PMD_DIR}.jar ${PLUGIN_PMD_DIR} \
+ && cd ${PLUGIN_PMD_DIR} \
+ && ${JAR} xvf ${PLUGIN_PMD_DIR}.jar \
+ && ${RM} ${PLUGIN_PMD_DIR}.jar
+
+ cd ${WRKDIR}/plugins && ${MKDIR} ${PLUGIN_PMD_DIR} \
+ && ${CP} ${PLUGIN_PMD_DIR}.jar ${PLUGIN_PMD_DIR} \
+ && cd ${PLUGIN_PMD_DIR} \
+ && ${JAR} xvf ${PLUGIN_PMD_DIR}.jar \
+ && ${RM} ${PLUGIN_PMD_DIR}.jar
+
+ cd ${WRKDIR}/plugins && ${MKDIR} ${PLUGIN_CORE_DIR} \
+ && ${CP} ${PLUGIN_CORE_DIR}.jar ${PLUGIN_CORE_DIR} \
+ && cd ${PLUGIN_CORE_DIR} \
+ && ${JAR} xvf ${PLUGIN_CORE_DIR}.jar \
+ && ${RM} ${PLUGIN_CORE_DIR}.jar
do-install:
@${MKDIR} ${PREFIX}/eclipse
@${MKDIR} ${PREFIX}/eclipse/plugins
- @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_DIR}
- cd ${WRKSRC}/${PLUGIN_DIR} && ${FIND} . \
+ @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_PMD_DIR}
+ @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_CORE_DIR}
+ @${MKDIR} ${PREFIX}/eclipse/features/${PLUGIN_PMD_DIR}
+ cd ${WRKDIR}/features/${PLUGIN_PMD_DIR} && ${FIND} . \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} \
+ ${PREFIX}/eclipse/features/${PLUGIN_PMD_DIR}
+ cd ${WRKDIR}/plugins/${PLUGIN_PMD_DIR} && ${FIND} . \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} \
+ ${PREFIX}/eclipse/plugins/${PLUGIN_PMD_DIR}
+ cd ${WRKDIR}/plugins/${PLUGIN_CORE_DIR} && ${FIND} . \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} \
- ${PREFIX}/eclipse/plugins/${PLUGIN_DIR}
+ ${PREFIX}/eclipse/plugins/${PLUGIN_CORE_DIR}
.include <bsd.port.mk>
diff --git a/java/eclipse-pmd/distinfo b/java/eclipse-pmd/distinfo
index 49e686bf8d84..55f5521fd87c 100644
--- a/java/eclipse-pmd/distinfo
+++ b/java/eclipse-pmd/distinfo
@@ -1,2 +1,2 @@
-MD5 (eclipse/pmd-eclipse-bin-1.1.2.zip) = cd46079fc6c98e4bc6ff2586eb654353
-SIZE (eclipse/pmd-eclipse-bin-1.1.2.zip) = 3808789
+MD5 (eclipse/pmd-eclipse3-site-2.0.5.zip) = 2031c18c9e3875809064df1eb192058e
+SIZE (eclipse/pmd-eclipse3-site-2.0.5.zip) = 4267395
diff --git a/java/eclipse-pmd/pkg-plist b/java/eclipse-pmd/pkg-plist
index 12d98f57b98f..d723a8a929ad 100644
--- a/java/eclipse-pmd/pkg-plist
+++ b/java/eclipse-pmd/pkg-plist
@@ -1,41 +1,52 @@
-eclipse/plugins/%%PLUGIN_DIR%%/CHANGELOG.txt
-eclipse/plugins/%%PLUGIN_DIR%%/LICENSE.txt
-eclipse/plugins/%%PLUGIN_DIR%%/README.txt
-eclipse/plugins/%%PLUGIN_DIR%%/RELNOTES.txt
-eclipse/plugins/%%PLUGIN_DIR%%/TODO.txt
-eclipse/plugins/%%PLUGIN_DIR%%/build.properties
-eclipse/plugins/%%PLUGIN_DIR%%/doc.zip
-eclipse/plugins/%%PLUGIN_DIR%%/icons/error.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/file.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/info.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/pmd-icon-16.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/pmd-icon-32.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/prio_1.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/prio_2.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/prio_3.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/prio_4.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/prio_5.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/prj.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/remvio.gif
-eclipse/plugins/%%PLUGIN_DIR%%/icons/warn.gif
-eclipse/plugins/%%PLUGIN_DIR%%/lib/commons-logging.jar
-eclipse/plugins/%%PLUGIN_DIR%%/lib/jaxen-core-1.0-fcs.jar
-eclipse/plugins/%%PLUGIN_DIR%%/lib/log4j-1.2.8.jar
-eclipse/plugins/%%PLUGIN_DIR%%/lib/pmd-1.2.1.jar
-eclipse/plugins/%%PLUGIN_DIR%%/lib/saxpath-1.0-fcs.jar
-eclipse/plugins/%%PLUGIN_DIR%%/log4j.xml
-eclipse/plugins/%%PLUGIN_DIR%%/messages.properties
-eclipse/plugins/%%PLUGIN_DIR%%/nl/fr/messages.properties
-eclipse/plugins/%%PLUGIN_DIR%%/plugin.properties
-eclipse/plugins/%%PLUGIN_DIR%%/plugin.xml
-eclipse/plugins/%%PLUGIN_DIR%%/plugin_fr.properties
-eclipse/plugins/%%PLUGIN_DIR%%/pmd-eclipse.jar
-eclipse/plugins/%%PLUGIN_DIR%%/toc.xml
-@dirrm eclipse/plugins/%%PLUGIN_DIR%%/nl/fr
-@dirrm eclipse/plugins/%%PLUGIN_DIR%%/nl
-@dirrm eclipse/plugins/%%PLUGIN_DIR%%/lib
-@dirrm eclipse/plugins/%%PLUGIN_DIR%%/icons
-@dirrm eclipse/plugins/%%PLUGIN_DIR%%
-@unexec rmdir %D/eclipse/plugins 2>/dev/null || true
-@unexec rmdir %D/eclipse/features 2>/dev/null || true
-@unexec rmdir %D/eclipse 2>/dev/null || true
+eclipse/features/%%PLUGIN_PMD_DIR%%/feature.properties
+eclipse/features/%%PLUGIN_PMD_DIR%%/feature.xml
+eclipse/features/%%PLUGIN_PMD_DIR%%/pmd_logo_small.jpg
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/doc.zip
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/lib/jaxen-core-1.0-fcs.jar
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/lib/pmd-1.8.jar
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/lib/saxpath-1.0-fcs.jar
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/plugin.properties
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/plugin.xml
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/plugin_fr.properties
+eclipse/plugins/%%PLUGIN_CORE_DIR%%/toc.xml
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/CHANGELOG.txt
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/LICENSE.txt
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/README.txt
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/RELNOTES.txt
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/TODO.txt
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/about.ini
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/doc.zip
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/error.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/file.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/info.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/pmd-icon-16.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/pmd-icon-32.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/prio_1.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/prio_2.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/prio_3.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/prio_4.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/prio_5.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/prj.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/remvio.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons/warn.gif
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/lib/commons-logging.jar
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/lib/log4j-1.2.8.jar
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/log4j.dtd
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/log4j.xml
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/messages.properties
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/nl/fr/messages.properties
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/nl/fr/welcome.xml
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/plugin.properties
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/plugin.xml
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/plugin_fr.properties
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/pmd-eclipse.jar
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/toc.xml
+eclipse/plugins/%%PLUGIN_PMD_DIR%%/welcome.xml
+@dirrm eclipse/plugins/%%PLUGIN_PMD_DIR%%/nl/fr
+@dirrm eclipse/plugins/%%PLUGIN_PMD_DIR%%/nl
+@dirrm eclipse/plugins/%%PLUGIN_PMD_DIR%%/lib
+@dirrm eclipse/plugins/%%PLUGIN_PMD_DIR%%/icons
+@dirrm eclipse/plugins/%%PLUGIN_PMD_DIR%%
+@dirrm eclipse/plugins/%%PLUGIN_CORE_DIR%%/lib
+@dirrm eclipse/plugins/%%PLUGIN_CORE_DIR%%
+@dirrm eclipse/features/%%PLUGIN_PMD_DIR%%