aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/cagibi/Makefile27
-rw-r--r--net/cagibi/distinfo3
-rw-r--r--net/cagibi/pkg-descr10
-rw-r--r--net/cagibi/pkg-plist3
4 files changed, 43 insertions, 0 deletions
diff --git a/net/cagibi/Makefile b/net/cagibi/Makefile
new file mode 100644
index 000000000000..6b5cdf910935
--- /dev/null
+++ b/net/cagibi/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cogibi
+# Date created: 2010-08-14
+# Whom: Dima Panov <fluffy@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= cagibi
+PORTVERSION= 0.1.1
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/cagibi
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE SSDP/uPNP proxy
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= automoc4
+USE_QT_VER= 4
+QT_COMPONENTS= corelib network xml dbus \
+ qmake_build moc_build rcc_build uic_build
+
+post-patch:
+ @${REINPLACE_CMD} -e '/pkgconfig/ s/$${LIB_SUFFIX}/data/' \
+ ${WRKSRC}/daemon/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/net/cagibi/distinfo b/net/cagibi/distinfo
new file mode 100644
index 000000000000..6a2d0e777cf7
--- /dev/null
+++ b/net/cagibi/distinfo
@@ -0,0 +1,3 @@
+MD5 (cagibi-0.1.1.tar.bz2) = 2db2424dc436bc436011185de09be9da
+SHA256 (cagibi-0.1.1.tar.bz2) = dc7db00b22ef42a6d4ab073f505199d6951744b9f1a354da951ea7cd6ffc2696
+SIZE (cagibi-0.1.1.tar.bz2) = 26260
diff --git a/net/cagibi/pkg-descr b/net/cagibi/pkg-descr
new file mode 100644
index 000000000000..c7ec46632d99
--- /dev/null
+++ b/net/cagibi/pkg-descr
@@ -0,0 +1,10 @@
+Cagibi is an experimental cache/proxy system for the SSDP* (Simple
+Service Discovery Protocol) part of UPnP.
+
+Cagibi aims to be to SSDP what Avahi is to DNS-SD/Zeroconf: a cache
+caching all service/device announcements on the network in a local
+process as well as being a broker serving local announcements to
+the network. Both should be done by a single daemon process,
+accessable via D-Bus on the system bus. The cache should offer
+active queries, so another process is only informed about changes
+about UPnP devices it is interested in.
diff --git a/net/cagibi/pkg-plist b/net/cagibi/pkg-plist
new file mode 100644
index 000000000000..ebdf4df976d3
--- /dev/null
+++ b/net/cagibi/pkg-plist
@@ -0,0 +1,3 @@
+bin/cagibid
+libdata/pkgconfig/cagibi.pc
+share/dbus-1/services/org.kde.Cagibi.service