aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/drizzle/Makefile3
-rw-r--r--databases/libmemcached/Makefile29
-rw-r--r--databases/mysqldumper/Makefile2
-rw-r--r--databases/p5-Class-DBI-Plugin-Senna/Makefile9
-rw-r--r--databases/p5-DBIx-QueryLog/Makefile3
-rw-r--r--databases/p5-DBIx-Simple/Makefile3
-rw-r--r--databases/postgis20/Makefile5
-rw-r--r--databases/postgis21/Makefile4
-rw-r--r--databases/pxlib/Makefile3
-rw-r--r--databases/rrdtool/Makefile3
-rw-r--r--databases/rrdtool12/Makefile9
-rw-r--r--databases/slony1/Makefile2
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/mousepad/Makefile5
-rw-r--r--editors/setedit/Makefile4
-rw-r--r--editors/vim/Makefile6
-rw-r--r--editors/yzis/Makefile2
-rw-r--r--net-mgmt/net-snmp/Makefile16
-rw-r--r--textproc/groff/Makefile3
-rw-r--r--textproc/openjade/Makefile10
-rw-r--r--textproc/opensp/Makefile4
-rw-r--r--textproc/p5-HTML-HTML5-Parser/Makefile3
-rw-r--r--textproc/p5-Hailo/Makefile3
-rw-r--r--textproc/p5-Text-TestBase/Makefile3
-rw-r--r--textproc/p5-XML-Feed-Deduper/Makefile4
-rw-r--r--textproc/rasqal/Makefile7
-rw-r--r--textproc/redland-bindings/Makefile2
-rw-r--r--textproc/redland/Makefile7
-rw-r--r--textproc/refdb/Makefile4
-rw-r--r--textproc/sgmlformat/Makefile9
30 files changed, 70 insertions, 100 deletions
diff --git a/databases/drizzle/Makefile b/databases/drizzle/Makefile
index 1f77b25fe216..bb1f8440658c 100644
--- a/databases/drizzle/Makefile
+++ b/databases/drizzle/Makefile
@@ -12,10 +12,9 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= A database optimized for Cloud and Net applications
USE_GCC= 4.2+
-USE_PERL5= yes
+USES= gmake perl5
USE_PYTHON= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/drizzle
BROKEN= fails to build
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index 9179adf7d342..e0c431101839 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= databases
MASTER_SITES= http://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
MAINTAINER= m.tsatsenko@gmail.com
-COMMENT= A C and C++ client library to the memcached server
+COMMENT= C and C++ client library to the memcached server
LIB_DEPENDS?= execinfo.1:${PORTSDIR}/devel/libexecinfo \
event-1.4.4:${PORTSDIR}/devel/libevent
@@ -21,26 +21,15 @@ CONFIGURE_ARGS= --without-memcached
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lexecinfo"
CXXFLAGS+= -D__STDC_CONSTANT_MACROS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libsasl.so.3)
LIB_DEPENDS+= sasl2.3:${PORTSDIR}/security/cyrus-sasl2
.endif
-.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.x
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|^pkgconfigdir.*|pkgconfigdir = $${PREFIX}/libdata/pkgconfig|' \
- -e '/^LDFLAGS *=/ s/$$/ $${LTLIBSASL2}/' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/support/include.am
-.if defined(NO_INSTALL_MANPAGES)
- @${REINPLACE_CMD} -e 's|^SUBDIRS = docs |SUBDIRS = |' ${WRKSRC}/Makefile.in
-.endif
-
.if !defined(NO_INSTALL_MANPAGES)
-USE_PERL5_BUILD=yes # pod2man
+USES= perl5
+USE_PERL5= build
MAN1= memaslap.1 \
memcapable.1 \
memcat.1 \
@@ -156,4 +145,12 @@ MAN3= hashkit_clone.3 \
memcached_version.3
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|^pkgconfigdir.*|pkgconfigdir = $${PREFIX}/libdata/pkgconfig|' \
+ -e '/^LDFLAGS *=/ s/$$/ $${LTLIBSASL2}/' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/support/include.am
+.if defined(NO_INSTALL_MANPAGES)
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = docs |SUBDIRS = |' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/mysqldumper/Makefile b/databases/mysqldumper/Makefile
index 8016a61d6fe8..2c073c4f933a 100644
--- a/databases/mysqldumper/Makefile
+++ b/databases/mysqldumper/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-DBI>=1.48:${PORTSDIR}/databases/p5-DBI
USE_ZIP= yes
USE_MYSQL= yes
-USE_PERL5= yes
+USES= perl5
USE_PHP= session mysql zlib ftp
NO_BUILD= yes
diff --git a/databases/p5-Class-DBI-Plugin-Senna/Makefile b/databases/p5-Class-DBI-Plugin-Senna/Makefile
index 055a79f17bbb..839a6b97ddd2 100644
--- a/databases/p5-Class-DBI-Plugin-Senna/Makefile
+++ b/databases/p5-Class-DBI-Plugin-Senna/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-DBI-Plugin-Senna
-# Date created: 18 Feb 2006
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
+# Created by: Jun Kuriyama <kuriyama@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Class-DBI-Plugin-Senna
PORTVERSION= 0.01
@@ -17,7 +13,8 @@ COMMENT= Add Instant Fulltext Search Capability With Senna to Class::DBI
BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
p5-Senna>=0:${PORTSDIR}/textproc/p5-Senna
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::DBI::Plugin::Senna.3
.include <bsd.port.pre.mk>
diff --git a/databases/p5-DBIx-QueryLog/Makefile b/databases/p5-DBIx-QueryLog/Makefile
index ca8d0ed5204d..62f29698d02f 100644
--- a/databases/p5-DBIx-QueryLog/Makefile
+++ b/databases/p5-DBIx-QueryLog/Makefile
@@ -17,7 +17,8 @@ TEST_DEPENDS= \
p5-Class-Method-Modifiers>0:${PORTSDIR}/devel/p5-Class-Method-Modifiers \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= DBIx::QueryLog.3
diff --git a/databases/p5-DBIx-Simple/Makefile b/databases/p5-DBIx-Simple/Makefile
index 6de07deb771c..db82aa9bde17 100644
--- a/databases/p5-DBIx-Simple/Makefile
+++ b/databases/p5-DBIx-Simple/Makefile
@@ -18,7 +18,8 @@ SQL_ABSTRACT_DESC= Generate SQL from Perl data structures
DBIX_XHTML_TABLE_DESC= Create XHTML tables from SQL queries
TEXT_TABLE_DESC= Create plain text table from data
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Simple.3 \
DBIx::Simple::Examples.3 \
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 87c9a40aa856..dbdb13103f4e 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -19,11 +19,10 @@ LATEST_LINK= postgis20
USE_GNOME= libxml2
USE_PGSQL= yes
-USE_GMAKE= yes
-USES= iconv
+USES= gmake iconv perl5
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
OPTIONS_DEFINE= LOADERGUI RASTER TOPOLOGY
OPTIONS_DEFAULT= TOPOLOGY
diff --git a/databases/postgis21/Makefile b/databases/postgis21/Makefile
index b9a61f76bae7..1641bfcc39a2 100644
--- a/databases/postgis21/Makefile
+++ b/databases/postgis21/Makefile
@@ -18,10 +18,10 @@ LATEST_LINK= postgis21
USE_GNOME= libxml2
USE_PGSQL= yes
-USES= gmake iconv pkgconfig
+USES= gmake iconv perl5 pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
OPTIONS_DEFINE= LOADERGUI RASTER TOPOLOGY
OPTIONS_DEFAULT= TOPOLOGY
diff --git a/databases/pxlib/Makefile b/databases/pxlib/Makefile
index b12ed5b1e65e..e7188d4da70c 100644
--- a/databases/pxlib/Makefile
+++ b/databases/pxlib/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USES= gettext iconv
-USE_PERL5= yes
+USES= gettext iconv perl5
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index f5449d19e7bc..d45403666098 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -25,7 +25,6 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USES= gmake pkgconfig
-WANT_PERL= yes
USE_GNOME= gnomehack intltool
CONFIGURE_ARGS= --disable-tcl
@@ -68,7 +67,7 @@ PLIST_SUB+= WITH_RUBY="@comment "
.endif
.if ${PORT_OPTIONS:MPERL_MODULE}
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+= --enable-perl --enable-perl-site-install
PLIST_SUB+= WITH_PERL=""
.else
diff --git a/databases/rrdtool12/Makefile b/databases/rrdtool12/Makefile
index f03878efb2b7..9174d434054c 100644
--- a/databases/rrdtool12/Makefile
+++ b/databases/rrdtool12/Makefile
@@ -21,15 +21,14 @@ CONFLICTS= rrdtool-1.0* rrdtool-1.3*
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-WANT_PERL= yes
+USES= gmake
CONFIGURE_ARGS= --disable-tcl
OPTIONS_DEFINE= PYTHON RUBY PERL DOCS EXAMPLES
OPTIONS_DEFAULT= PERL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
@@ -54,7 +53,7 @@ PLIST_SUB+= WITH_RUBY="@comment "
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+= --enable-perl --enable-perl-site-install
PLIST_SUB+= WITH_PERL=""
.else
@@ -97,4 +96,4 @@ post-install:
@${ECHO_MSG} "############################################################################"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/slony1/Makefile b/databases/slony1/Makefile
index dc62c6471e96..bcfe2f8faf46 100644
--- a/databases/slony1/Makefile
+++ b/databases/slony1/Makefile
@@ -31,7 +31,7 @@ CONFLICTS?= slony1v2-2*
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPERLTOOLS}
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
BUILD_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index b845f318e7b2..821977165550 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -40,13 +40,12 @@ USE_GL= glew
USE_GNOME= glib20 libxml2 libxslt
USE_KDE4= kactivities kdehier kdelibs kdeprefix libkdcraw nepomuk-core \
okular pimlibs attica automoc4 sharedmime soprano
-USE_PERL5= yes
USE_QT4= dbus designer_build gui opengl phonon porting_build qt3support \
qtestlib_build script sql svg webkit xml xmlpatterns \
moc_build qmake_build rcc_build uic_build uic3_build
USE_SQLITE= 3
USE_BZIP2= yes
-USES= cmake:outsource pkgconfig iconv
+USES= cmake:outsource pkgconfig iconv perl5
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DIHAVEPATCHEDQT:BOOL=TRUE # To be removed with Qt 4.8.2.
USE_LDCONFIG= yes
diff --git a/editors/mousepad/Makefile b/editors/mousepad/Makefile
index 2aa8e31704f0..e5c089ede27e 100644
--- a/editors/mousepad/Makefile
+++ b/editors/mousepad/Makefile
@@ -1,6 +1,5 @@
# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mousepad
PORTVERSION= 0.3.0
@@ -14,11 +13,9 @@ COMMENT= Simple text editor for the Xfce Desktop
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= desktop-file-utils gettext pathfix pkgconfig
+USES= desktop-file-utils gettext gmake pathfix pkgconfig perl5
USE_GNOME= glib20 gtk20 intltool intlhack gtksourceview2
USE_XFCE= configenv
-USE_PERL5= yes
OPTIONS_DEFINE= DBUS
OPTIONS_DEFAULT= DBUS
diff --git a/editors/setedit/Makefile b/editors/setedit/Makefile
index 7d0b4ab6cdab..648edab35c22 100644
--- a/editors/setedit/Makefile
+++ b/editors/setedit/Makefile
@@ -16,8 +16,8 @@ MAKE_JOBS_UNSAFE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
CFLAGS+= -Wno-write-strings -I${LOCALBASE}/include
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index bc6ccea2e5f0..e940a5698717 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -1,6 +1,4 @@
-# ex:ts=8
-# Created by: David O'Brien <obrien@cs.ucdavis.edu>
-# Created: Sat June 29, 1996
+# Created by: David O'Brien <obrien@cs.ucdavis.edu>
# $FreeBSD$
PORTNAME?= vim
@@ -109,7 +107,7 @@ MAKE_ARGS+= CONF_OPT_LUA_PREFIX="--with-lua-prefix=${LOCALBASE}"
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES= perl5
MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp"
.endif
diff --git a/editors/yzis/Makefile b/editors/yzis/Makefile
index d389bd742c09..8f0141f93d43 100644
--- a/editors/yzis/Makefile
+++ b/editors/yzis/Makefile
@@ -20,7 +20,7 @@ USE_XORG= x11 xext ice
USE_LUA= 5.1
LUA_COMPS= lua
USE_QT4= qtestlib qmake_build rcc_build uic_build moc_build gui xml
-USE_PERL5= yes
+USES= perl5
USES= cmake gettext
CMAKE_ARGS+= -DLOCALBASE:STRING="${LOCALBASE}" \
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index b833b73bde65..9d5d807c429d 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -28,15 +28,13 @@ AX_SOCKONLY_DESC= Disable UDP/TCP transports for agentx
UNPRIVILEGED_DESC= Allow unprivileged users to execute net-snmp
SMUX_DESC= Build with SNMP multiplexing (SMUX) support
-.include <bsd.port.options.mk>
-
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
USE_RC_SUBR= snmpd snmptrapd
USE_OPENSSL= yes
USE_LDCONFIG= yes
-WANT_PERL= yes
+USES= perl5
CONFIGURE_ENV+= PERLPROG="${PERL}" PSPROG="${PS_CMD}" SED="${SED}"
CONFIGURE_ARGS+=--enable-shared --enable-internal-md5 \
@@ -52,6 +50,8 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--with-defaults
.endif
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MPYTHON}
# borrowed from bsd.python.mk and adapted for our needs
PYEASYINSTALL_CMD?= ${LOCALBASE}/bin/easy_install-${PYTHON_VER}
@@ -79,14 +79,13 @@ PLIST_SUB+= PYUNINSTALL="@unexec ${PYEASYINSTALL_CMD} ${PYEASYUNINSTALL_UNINSTAL
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --with-openssl="${OPENSSLBASE}"
.if ${PORT_OPTIONS:MDUMMY}
CONFIGURE_ARGS+=--with-dummy-values
.endif
-.if empty(PORT_OPTIONS:MTKMIB)
+.if ! ${PORT_OPTIONS:MTKMIB}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-local:Makefile.in
PLIST_SUB+= WITH_TKMIB="@comment "
.else
@@ -95,9 +94,8 @@ PLIST_SUB+= WITH_TKMIB=""
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
CONFIGURE_ARGS+=--with-perl-modules
-.if empty(PORT_OPTIONS:MPERL_EMBEDDED)
+.if ! ${PORT_OPTIONS:MPERL_EMBEDDED}
CONFIGURE_ARGS+=--disable-embedded-perl
PLIST_SUB+= WITH_PERL_EMBEDDED="@comment "
.else
@@ -106,7 +104,7 @@ PLIST_SUB+= WITH_PERL_EMBEDDED=""
.endif
PLIST_SUB+= WITH_PERL=""
.else
-USE_PERL5_BUILD=yes
+USE_PERL5= build
CONFIGURE_ARGS+=--disable-embedded-perl --without-perl-modules
PLIST_SUB+= WITH_PERL_EMBEDDED="@comment "
PLIST_SUB+= WITH_PERL="@comment "
@@ -345,4 +343,4 @@ display-message:
# Don't forget to bump library version in these ports.
# french/plgrenouille,graphics/hpoj,lang/php4,lang/php5,mail/cyrus-imapd22,mail/cyrus-imapd23,misc/kdeutils3,net-mgmt/braa,net-mgmt/docsis,net-mgmt/mbrowse,net-mgmt/nagios-snmp-plugins,net-mgmt/p5-SNMP-Info,net-mgmt/py-yapsnmp,net-mgmt/sdig,net-mgmt/zabbix,net/cactid,net/wireshark,net/ifstat,net/quagga,net/rtg,print/hplip,security/libfwbuilder,sysutils/apcupsd,sysutils/jailadmin,sysutils/nut
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/groff/Makefile b/textproc/groff/Makefile
index a99b53f84126..55b9fa9d7073 100644
--- a/textproc/groff/Makefile
+++ b/textproc/groff/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript8 \
${LOCALBASE}/bin/psselect:${PORTSDIR}/print/psutils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-awk=/usr/bin/awk
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
index f9ddf0aec66b..6bcef1977cd6 100644
--- a/textproc/openjade/Makefile
+++ b/textproc/openjade/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OpenJade
-# Date created: May 19, 2000
-# Whom: kuriyama
-#
+# Created by: kuriyama
# $FreeBSD$
-#
PORTNAME= openjade
PORTVERSION= 1.3.3p1
@@ -19,10 +15,8 @@ LIB_DEPENDS= osp.5:${PORTSDIR}/textproc/opensp
RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
USE_GCC= any
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
-USES= gettext
+USES= gettext gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${DATADIR}
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index 6ac5bac274d3..5b468c82b24d 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -10,11 +10,9 @@ MASTER_SITES= SF/openjade/${PORTNAME:L}/${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= This package is a collection of SGML/XML tools called OpenSP
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= iconv
+USES= gmake iconv perl5
GNU_CONFIGURE= yes
-USE_PERL5= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade \
--disable-doc-build
diff --git a/textproc/p5-HTML-HTML5-Parser/Makefile b/textproc/p5-HTML-HTML5-Parser/Makefile
index 446dce1d964b..363f9b25bfbf 100644
--- a/textproc/p5-HTML-HTML5-Parser/Makefile
+++ b/textproc/p5-HTML-HTML5-Parser/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-HTML-HTML5-Entities>=0.002:${PORTSDIR}/textproc/p5-HTML-HTML5-
p5-XML-LibXML>=1.94:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::HTML5::Parser.3 \
HTML::HTML5::Parser::Error.3 \
diff --git a/textproc/p5-Hailo/Makefile b/textproc/p5-Hailo/Makefile
index 507023171072..001a80d07155 100644
--- a/textproc/p5-Hailo/Makefile
+++ b/textproc/p5-Hailo/Makefile
@@ -43,7 +43,8 @@ TEST_DEPENDS= p5-DBD-SQLite>=1.29:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Test-Script-Run>=0.04:${PORTSDIR}/devel/p5-Test-Script-Run \
p5-Test-Synopsis>=0.06:${PORTSDIR}/devel/p5-Test-Synopsis
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= hailo.1
diff --git a/textproc/p5-Text-TestBase/Makefile b/textproc/p5-Text-TestBase/Makefile
index 45f25fc6883c..1474ce606d4c 100644
--- a/textproc/p5-Text-TestBase/Makefile
+++ b/textproc/p5-Text-TestBase/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Data::Section::TestBase.3 \
Test::Base::Less.3 \
diff --git a/textproc/p5-XML-Feed-Deduper/Makefile b/textproc/p5-XML-Feed-Deduper/Makefile
index 3807ced85c1e..2121a7454226 100644
--- a/textproc/p5-XML-Feed-Deduper/Makefile
+++ b/textproc/p5-XML-Feed-Deduper/Makefile
@@ -1,6 +1,5 @@
# Created by: TERAMOTO Masahiro <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= XML-Feed-Deduper
PORTVERSION= 0.06
@@ -19,7 +18,8 @@ BUILD_DEPENDS= p5-Mouse>=1.08:${PORTSDIR}/devel/p5-Any-Moose \
RUN_DEPENDS= p5-Mouse>=1.08:${PORTSDIR}/devel/p5-Any-Moose \
p5-XML-Feed>=0.41:${PORTSDIR}/textproc/p5-XML-Feed
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= XML::Feed::Deduper.3
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
index 27d5867b2814..5642386de44e 100644
--- a/textproc/rasqal/Makefile
+++ b/textproc/rasqal/Makefile
@@ -13,12 +13,11 @@ COMMENT= High-level interface for RDF
LIB_DEPENDS= raptor2:${PORTSDIR}/textproc/raptor2 \
pcre:${PORTSDIR}/devel/pcre
-USE_GNOME= gnomehack lthack
+USE_GNOME= lthack
USE_OPENSSL= yes
-USE_PERL5_BUILD=yes
-USES= pkgconfig
+USE_PERL5= build
+USES= gmake pathfix pkgconfig perl5
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
MAN1= rasqal-config.1 roqet.1
diff --git a/textproc/redland-bindings/Makefile b/textproc/redland-bindings/Makefile
index c080649d07fd..fb5f623e5d74 100644
--- a/textproc/redland-bindings/Makefile
+++ b/textproc/redland-bindings/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFAULT=PYTHON
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+=--with-perl
PLIST_SUB+= WITH_PERL=""
MANPREFIX= ${LOCALBASE}/lib/perl5/${PERL_VER}
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index a67ed3b89304..2773065b80b9 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -13,14 +13,13 @@ LIB_DEPENDS= raptor2:${PORTSDIR}/textproc/raptor2 \
rasqal:${PORTSDIR}/textproc/rasqal
USE_AUTOTOOLS= libltdl
-USE_GNOME= gnomehack libxml2 lthack
+USE_GNOME= libxml2 lthack
USE_OPENSSL= yes
-USE_PERL5_BUILD= yes
-USES= pkgconfig:both
+USE_PERL5= build
+USES= gmake pathfix perl5 pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-raptor=system \
--with-threestore=no
-USE_GMAKE= yes
USE_LDCONFIG= yes
MAN1= rdfproc.1 redland-config.1 \
diff --git a/textproc/refdb/Makefile b/textproc/refdb/Makefile
index c9d57d311276..22393974ca77 100644
--- a/textproc/refdb/Makefile
+++ b/textproc/refdb/Makefile
@@ -15,9 +15,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
btparse.0:${PORTSDIR}/textproc/btparse \
dbi.1:${PORTSDIR}/databases/libdbi
-USE_GMAKE= yes
-USES= iconv
-USE_PERL5= yes
+USES= gmake iconv perl5
HAS_CONFIGURE= yes
ALL_TARGET=
diff --git a/textproc/sgmlformat/Makefile b/textproc/sgmlformat/Makefile
index f422d2911270..492184c04747 100644
--- a/textproc/sgmlformat/Makefile
+++ b/textproc/sgmlformat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sgmlformat
-# Date created: July 16, 1997
-# Whom: jfieber
-#
+# Created by: jfieber
# $FreeBSD$
-#
PORTNAME= sgmlformat
PORTVERSION= 1.7
@@ -15,7 +11,8 @@ MASTER_SITE_SUBDIR= kuriyama
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Generates groff and HTML from linuxdoc and docbook SGML documents
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAN1= instant.1 sgmlfmt.1
MAN5= transpec.5