aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/alexandria/Makefile47
-rw-r--r--deskutils/alexandria/distinfo2
-rw-r--r--deskutils/alexandria/pkg-descr3
-rw-r--r--deskutils/alexandria/pkg-plist75
5 files changed, 128 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 1992bf83d654..eed717f264d1 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -4,6 +4,7 @@
COMMENT = Things that used to be on the desktop before computers were invented
SUBDIR += abacus
+ SUBDIR += alexandria
SUBDIR += aspostit
SUBDIR += autocutsel
SUBDIR += babytrans
diff --git a/deskutils/alexandria/Makefile b/deskutils/alexandria/Makefile
new file mode 100644
index 000000000000..f1700f2c3847
--- /dev/null
+++ b/deskutils/alexandria/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Alexandria
+# Date created: 18 March 2005
+# Whom: Mitsuru YOSHIDA <mitsuru@riken.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alexandria
+PORTVERSION= 0.5.0
+CATEGORIES= deskutils ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/3445/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= mitsuru@riken.jp
+COMMENT= A GNOME application to help you manage your book collection
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/amazon.rb:${PORTSDIR}/www/ruby-amazon \
+ ${RUBY_SITEARCHLIBDIR}/gettext/_locale.so:${PORTSDIR}/devel/ruby-gettext \
+ ${RUBY_SITEARCHLIBDIR}/libglade2.so:${PORTSDIR}/devel/ruby-libglade2 \
+ ${RUBY_SITEARCHLIBDIR}/gnome2.so:${PORTSDIR}/x11/ruby-gnome2 \
+ ${RUBY_SITEARCHLIBDIR}/gdk_pixbuf2.so:${PORTSDIR}/graphics/ruby-gdk_pixbuf2 \
+ ${RUBY_SITEARCHLIBDIR}/gconf2.so:${PORTSDIR}/devel/ruby-gconf2
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS= NEWS README TODO
+
+RUBY_REQUIRE= Ruby > 180
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= only works with Ruby 1.8.0 or later
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/alexandria/distinfo b/deskutils/alexandria/distinfo
new file mode 100644
index 000000000000..e57d3d2ca9ed
--- /dev/null
+++ b/deskutils/alexandria/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/alexandria-0.5.0.tar.gz) = d5a7bf954560faefb9b9556051e1ffda
+SIZE (ruby/alexandria-0.5.0.tar.gz) = 123506
diff --git a/deskutils/alexandria/pkg-descr b/deskutils/alexandria/pkg-descr
new file mode 100644
index 000000000000..69eea48f6c93
--- /dev/null
+++ b/deskutils/alexandria/pkg-descr
@@ -0,0 +1,3 @@
+Alexandria is a GNOME application to help you manage your book collection.
+
+WWW: http://alexandria.rubyforge.org/
diff --git a/deskutils/alexandria/pkg-plist b/deskutils/alexandria/pkg-plist
new file mode 100644
index 000000000000..92a7b4f87ec9
--- /dev/null
+++ b/deskutils/alexandria/pkg-plist
@@ -0,0 +1,75 @@
+bin/alexandria
+%%RUBY_SITELIBDIR%%/alexandria.rb
+%%RUBY_SITELIBDIR%%/alexandria/book.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/amazon.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/bn.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/mcu.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/proxis.rb
+%%RUBY_SITELIBDIR%%/alexandria/config.rb
+%%RUBY_SITELIBDIR%%/alexandria/execution_queue.rb
+%%RUBY_SITELIBDIR%%/alexandria/export_library.rb
+%%RUBY_SITELIBDIR%%/alexandria/import_library.rb
+%%RUBY_SITELIBDIR%%/alexandria/web_themes.rb
+%%RUBY_SITELIBDIR%%/alexandria/library.rb
+%%RUBY_SITELIBDIR%%/alexandria/preferences.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/about_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/alert_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/book_properties_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/book_properties_dialog_base.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/export_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/glade_base.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/icons.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/import_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/main_app.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/new_book_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/new_book_dialog_manual.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/preferences_dialog.rb
+%%RUBY_SITELIBDIR%%/alexandria/version.rb
+%%DATADIR%%/COPYING
+%%DATADIR%%/glade/book_properties_dialog.glade
+%%DATADIR%%/glade/main_app.glade
+%%DATADIR%%/glade/new_book_dialog.glade
+%%DATADIR%%/glade/preferences_dialog.glade
+%%DATADIR%%/icons/alexandria.png
+%%DATADIR%%/icons/alexandria_small.png
+%%DATADIR%%/icons/book.png
+%%DATADIR%%/icons/cuecat.png
+%%DATADIR%%/icons/cuecat_inactive.png
+%%DATADIR%%/icons/library.png
+%%DATADIR%%/icons/library_small.png
+%%DATADIR%%/icons/star_set.png
+%%DATADIR%%/icons/star_unset.png
+%%DATADIR%%/ui/menus.xml
+%%DATADIR%%/ui/popups.xml
+%%DATADIR%%/web-themes/clean/clean.css
+%%DATADIR%%/web-themes/clean/preview.jpg
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/NEWS
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TODO
+share/locale/cy/LC_MESSAGES/alexandria.mo
+share/locale/de/LC_MESSAGES/alexandria.mo
+share/locale/es/LC_MESSAGES/alexandria.mo
+share/locale/fr/LC_MESSAGES/alexandria.mo
+share/locale/ja/LC_MESSAGES/alexandria.mo
+share/locale/sv/LC_MESSAGES/alexandria.mo
+@dirrm %%RUBY_SITELIBDIR%%/alexandria/book_providers
+@dirrm %%RUBY_SITELIBDIR%%/alexandria/ui
+@dirrm %%RUBY_SITELIBDIR%%/alexandria
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/web-themes/clean
+@dirrm %%DATADIR%%/web-themes
+@dirrm %%DATADIR%%
+@dirrm %%PORTDOCS%%%%RUBY_MODDOCDIR%%
+@cwd %%X11BASE%%
+etc/gconf/gconf.xml.defaults/schemas/apps/alexandria/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/alexandria/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/%gconf.xml
+@dirrm etc/gconf/gconf.xml.defaults/apps/alexandria
+@dirrm etc/gconf/gconf.xml.defaults/apps
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/alexandria
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps