aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libghthash/Makefile20
-rw-r--r--devel/libghthash/distinfo1
-rw-r--r--devel/libghthash/pkg-comment1
-rw-r--r--devel/libghthash/pkg-descr5
-rw-r--r--devel/libghthash/pkg-plist4
6 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 871e20c55170..05f398467c82 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -266,6 +266,7 @@
SUBDIR += libformat
SUBDIR += libg++
SUBDIR += libgetline
+ SUBDIR += libghthash
SUBDIR += libgii
SUBDIR += libglade
SUBDIR += libglade2
diff --git a/devel/libghthash/Makefile b/devel/libghthash/Makefile
new file mode 100644
index 000000000000..71321e320cd8
--- /dev/null
+++ b/devel/libghthash/Makefile
@@ -0,0 +1,20 @@
+# ex:ts=8
+# Ports collection makefile for: libghthash
+# Date created: Jul 2, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libghthash
+PORTVERSION= 0.5.0
+CATEGORIES= devel
+MASTER_SITES= http://www.student.lu.se/~etn97ksi/sim_home/filer/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libghthash/distinfo b/devel/libghthash/distinfo
new file mode 100644
index 000000000000..41b306b13645
--- /dev/null
+++ b/devel/libghthash/distinfo
@@ -0,0 +1 @@
+MD5 (libghthash-0.5.0.tar.gz) = b57c9c63ebc35ec29477a919d07314ab
diff --git a/devel/libghthash/pkg-comment b/devel/libghthash/pkg-comment
new file mode 100644
index 000000000000..1c90b710bdad
--- /dev/null
+++ b/devel/libghthash/pkg-comment
@@ -0,0 +1 @@
+Generic Hash Table
diff --git a/devel/libghthash/pkg-descr b/devel/libghthash/pkg-descr
new file mode 100644
index 000000000000..881c69983cb5
--- /dev/null
+++ b/devel/libghthash/pkg-descr
@@ -0,0 +1,5 @@
+libghthash is a Generic Hash Table which is meant to be easy to extend,
+portable, clear in its code and easy to use. You can store any kind of
+data in it, regardless of size etc.
+
+WWW: http://www.student.lu.se/~etn97ksi/sim_home/libghthash.html
diff --git a/devel/libghthash/pkg-plist b/devel/libghthash/pkg-plist
new file mode 100644
index 000000000000..34ea005d047e
--- /dev/null
+++ b/devel/libghthash/pkg-plist
@@ -0,0 +1,4 @@
+include/ght_hash_table.h
+lib/libghthash.a
+lib/libghthash.so
+lib/libghthash.so.0