aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Date-Pcalc/Makefile23
-rw-r--r--devel/p5-Date-Pcalc/distinfo1
-rw-r--r--devel/p5-Date-Pcalc/pkg-comment1
-rw-r--r--devel/p5-Date-Pcalc/pkg-descr9
-rw-r--r--devel/p5-Date-Pcalc/pkg-plist5
6 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 208598181bed..ed21bb102681 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -308,6 +308,7 @@
SUBDIR += p5-Date-DayOfWeek
SUBDIR += p5-Date-Leapyear
SUBDIR += p5-Date-Manip
+ SUBDIR += p5-Date-Pcalc
SUBDIR += p5-DateConvert
SUBDIR += p5-Devel-DProf
SUBDIR += p5-Devel-Modlist
diff --git a/devel/p5-Date-Pcalc/Makefile b/devel/p5-Date-Pcalc/Makefile
new file mode 100644
index 000000000000..8f81fb92e7e2
--- /dev/null
+++ b/devel/p5-Date-Pcalc/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Date-Pcalc
+# Date created: 5 July 2001
+# Whom: Gregory Shapiro <gshapiro@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date-Pcalc
+PORTVERSION= 1.2
+CATEGORIES= devel perl5
+MASTER_SITES= ftp://catcode.com/pub/date/ \
+ http://www.engelschall.com/u/sb/download/pkg/ \
+ ${MASTER_SITE_PERL_CPAN}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Pcalc.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Pcalc/distinfo b/devel/p5-Date-Pcalc/distinfo
new file mode 100644
index 000000000000..e3a22873ac50
--- /dev/null
+++ b/devel/p5-Date-Pcalc/distinfo
@@ -0,0 +1 @@
+MD5 (Date-Pcalc-1.2.tar.gz) = 1c09a09337c7d2e18a17898ca577c644
diff --git a/devel/p5-Date-Pcalc/pkg-comment b/devel/p5-Date-Pcalc/pkg-comment
new file mode 100644
index 000000000000..67e34d4b27d9
--- /dev/null
+++ b/devel/p5-Date-Pcalc/pkg-comment
@@ -0,0 +1 @@
+Gregorian calendar date calculations
diff --git a/devel/p5-Date-Pcalc/pkg-descr b/devel/p5-Date-Pcalc/pkg-descr
new file mode 100644
index 000000000000..768ee772eede
--- /dev/null
+++ b/devel/p5-Date-Pcalc/pkg-descr
@@ -0,0 +1,9 @@
+This Perl module is a direct translation of Steffen Beyer's excellent
+Date::Calc module to use Perl only instead of a combination of Perl and C.
+
+This package consists of a Perl module for all kinds of date calculations
+based on the Gregorian calendar (the one used in all western countries
+today), thereby complying with all relevant norms and standards:
+ISO/R 2015-1971, DIN 1355 and, to some extent, ISO 8601 (where applicable).
+
+WWW: http://catcode.com/date/pcalc.html
diff --git a/devel/p5-Date-Pcalc/pkg-plist b/devel/p5-Date-Pcalc/pkg-plist
new file mode 100644
index 000000000000..b3088dd09985
--- /dev/null
+++ b/devel/p5-Date-Pcalc/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Date/Pcalc.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Pcalc/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Pcalc
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Date 2>/dev/null || true