aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-DMAC/Makefile27
-rw-r--r--security/p5-Digest-DMAC/distinfo3
-rw-r--r--security/p5-Digest-DMAC/pkg-descr23
-rw-r--r--security/p5-Digest-DMAC/pkg-plist5
5 files changed, 59 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a4f79ea73dbb..ab953ffcea34 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -334,6 +334,7 @@
SUBDIR += p5-Digest-CRC
SUBDIR += p5-Digest-Crc32
SUBDIR += p5-Digest-DJB
+ SUBDIR += p5-Digest-DMAC
SUBDIR += p5-Digest-HMAC
SUBDIR += p5-Digest-Hashcash
SUBDIR += p5-Digest-Haval256
diff --git a/security/p5-Digest-DMAC/Makefile b/security/p5-Digest-DMAC/Makefile
new file mode 100644
index 000000000000..0ee6b117d981
--- /dev/null
+++ b/security/p5-Digest-DMAC/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: p5-Digest-DMAC
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-DMAC
+PORTVERSION= 1.1.4
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl5 interface to DMAC Double Message-Digest Algorithms
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::DMAC.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-DMAC/distinfo b/security/p5-Digest-DMAC/distinfo
new file mode 100644
index 000000000000..7e57f3fb04ac
--- /dev/null
+++ b/security/p5-Digest-DMAC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-DMAC-1.1.4.tar.gz) = 78ccdeb5377962d86d852d14c5b23ab3
+SHA256 (Digest-DMAC-1.1.4.tar.gz) = 7e491b738d2e7c299367ab42789aebb312e42cfda55dc673440dbf613eec0b48
+SIZE (Digest-DMAC-1.1.4.tar.gz) = 10210
diff --git a/security/p5-Digest-DMAC/pkg-descr b/security/p5-Digest-DMAC/pkg-descr
new file mode 100644
index 000000000000..d0176e43ebaf
--- /dev/null
+++ b/security/p5-Digest-DMAC/pkg-descr
@@ -0,0 +1,23 @@
+This is Encrypted MAC (EMAC), formerly known as Double MAC (DMAC).
+Unlike HMAC, which reuses an existing one-way hash function, such as
+MD5, SHA-1 or RIPEMD-160, EMAC reuses an existing block cipher to
+produce a secure message authentication code (MAC).
+
+Using the block cipher, a message is encrypted in CBC mode. The last
+block is taken as the MAC of the message. For fixed-length messages,
+this method is provably secure. In reality, however, messages have
+arbitrary lengths, and this method is not secure. To make secure MACs
+for variable length messages, the last block is encrypted once again
+with a different key. The security of this construction has been proved
+in the paper, ``CBC MAC for Real-Time Data Sources'' by Erez Petrank
+and Charles Rackoff. The security can be proved on the assumption that
+the underlying block cipher is pseudo-random.
+
+The performance and key-agility of EMAC are reasonable. EMAC is
+preferable for short messages because the block length is smaller
+compared to the schemes based on a hash function. EMAC is also chosen
+as one of the NESSIE winners for Message Authentication Codes, along
+with UMAC, TTMAC and HMAC. The current NESSIE specification chooses the
+AES as block cipher.
+
+WWW: http://search.cpan.org/dist/Digest-DMAC
diff --git a/security/p5-Digest-DMAC/pkg-plist b/security/p5-Digest-DMAC/pkg-plist
new file mode 100644
index 000000000000..565537d144a2
--- /dev/null
+++ b/security/p5-Digest-DMAC/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Digest/DMAC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/DMAC/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/DMAC/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Digest/ 2>/dev/null || true