aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/opal/Makefile30
-rw-r--r--net/opal/distinfo2
-rw-r--r--net/opal/pkg-comment1
-rw-r--r--net/opal/pkg-descr15
-rw-r--r--net/opal/pkg-plist1
-rw-r--r--net/opal3/Makefile30
-rw-r--r--net/opal3/distinfo2
-rw-r--r--net/opal3/pkg-comment1
-rw-r--r--net/opal3/pkg-descr15
-rw-r--r--net/opal3/pkg-plist1
-rw-r--r--net/openh323-112/Makefile30
-rw-r--r--net/openh323-112/distinfo2
-rw-r--r--net/openh323-112/pkg-comment1
-rw-r--r--net/openh323-112/pkg-descr15
-rw-r--r--net/openh323-112/pkg-plist1
-rw-r--r--net/openh323/Makefile30
-rw-r--r--net/openh323/distinfo2
-rw-r--r--net/openh323/pkg-comment1
-rw-r--r--net/openh323/pkg-descr15
-rw-r--r--net/openh323/pkg-plist1
20 files changed, 196 insertions, 0 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
new file mode 100644
index 000000000000..eae4519938e1
--- /dev/null
+++ b/net/opal/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: openh323
+# Version required: 1.1alpha1
+# Date created: Thu Feb 17 15:00:48 GMT 2000
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= openh323_1.1alpha1
+PKGNAME= openh323-1.1.a1
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pwlib_min_1.14.tar.gz
+
+MAINTAINER= roger@freebsd.org
+
+WRKSRC= ${WRKDIR}/openh323
+
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
+ OPENH323DIR=${WRKDIR}/openh323
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/test/obj_FreeBSD_x86_r/voxilla ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/test/voxilla.1 ${PREFIX}/man/man1/voxilla.1
+
+MAN1= voxilla.1
+
+.include <bsd.port.mk>
diff --git a/net/opal/distinfo b/net/opal/distinfo
new file mode 100644
index 000000000000..9633e7478024
--- /dev/null
+++ b/net/opal/distinfo
@@ -0,0 +1,2 @@
+MD5 (openh323_1.1alpha1.tar.gz) = 62856e29e923b4215a2ba9bf1bfc5aad
+MD5 (pwlib_min_1.14.tar.gz) = 26afe224c2264ac5ea54535abafebf2d
diff --git a/net/opal/pkg-comment b/net/opal/pkg-comment
new file mode 100644
index 000000000000..ab7b3369c3f5
--- /dev/null
+++ b/net/opal/pkg-comment
@@ -0,0 +1 @@
+A H323 Video Conferencing package. Can connect to MS NetMeeting.
diff --git a/net/opal/pkg-descr b/net/opal/pkg-descr
new file mode 100644
index 000000000000..62f60e782dce
--- /dev/null
+++ b/net/opal/pkg-descr
@@ -0,0 +1,15 @@
+OpenH323 is a multi-platform H323 Video Conferencing program.
+It can exchange full duplex audio and video with other H323
+compliant video conferencing programs including Microsoft NetMeeting
+It requires a sound card for audio support and a Bt848/878 based
+video card (using the bktr driver) for video capture.
+
+It makes use of PWLib.
+
+PWLib is a multi-platform code library that can be used to write
+applications that will compile and run on Windows, Linux and a few other
+Unix variants. It was developed by Equivalence Ltd Pty
+
+For more information see
+http://www.openh323.org
+http://www.equival.com
diff --git a/net/opal/pkg-plist b/net/opal/pkg-plist
new file mode 100644
index 000000000000..b901edf75c04
--- /dev/null
+++ b/net/opal/pkg-plist
@@ -0,0 +1 @@
+bin/voxilla
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
new file mode 100644
index 000000000000..eae4519938e1
--- /dev/null
+++ b/net/opal3/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: openh323
+# Version required: 1.1alpha1
+# Date created: Thu Feb 17 15:00:48 GMT 2000
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= openh323_1.1alpha1
+PKGNAME= openh323-1.1.a1
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pwlib_min_1.14.tar.gz
+
+MAINTAINER= roger@freebsd.org
+
+WRKSRC= ${WRKDIR}/openh323
+
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
+ OPENH323DIR=${WRKDIR}/openh323
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/test/obj_FreeBSD_x86_r/voxilla ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/test/voxilla.1 ${PREFIX}/man/man1/voxilla.1
+
+MAN1= voxilla.1
+
+.include <bsd.port.mk>
diff --git a/net/opal3/distinfo b/net/opal3/distinfo
new file mode 100644
index 000000000000..9633e7478024
--- /dev/null
+++ b/net/opal3/distinfo
@@ -0,0 +1,2 @@
+MD5 (openh323_1.1alpha1.tar.gz) = 62856e29e923b4215a2ba9bf1bfc5aad
+MD5 (pwlib_min_1.14.tar.gz) = 26afe224c2264ac5ea54535abafebf2d
diff --git a/net/opal3/pkg-comment b/net/opal3/pkg-comment
new file mode 100644
index 000000000000..ab7b3369c3f5
--- /dev/null
+++ b/net/opal3/pkg-comment
@@ -0,0 +1 @@
+A H323 Video Conferencing package. Can connect to MS NetMeeting.
diff --git a/net/opal3/pkg-descr b/net/opal3/pkg-descr
new file mode 100644
index 000000000000..62f60e782dce
--- /dev/null
+++ b/net/opal3/pkg-descr
@@ -0,0 +1,15 @@
+OpenH323 is a multi-platform H323 Video Conferencing program.
+It can exchange full duplex audio and video with other H323
+compliant video conferencing programs including Microsoft NetMeeting
+It requires a sound card for audio support and a Bt848/878 based
+video card (using the bktr driver) for video capture.
+
+It makes use of PWLib.
+
+PWLib is a multi-platform code library that can be used to write
+applications that will compile and run on Windows, Linux and a few other
+Unix variants. It was developed by Equivalence Ltd Pty
+
+For more information see
+http://www.openh323.org
+http://www.equival.com
diff --git a/net/opal3/pkg-plist b/net/opal3/pkg-plist
new file mode 100644
index 000000000000..b901edf75c04
--- /dev/null
+++ b/net/opal3/pkg-plist
@@ -0,0 +1 @@
+bin/voxilla
diff --git a/net/openh323-112/Makefile b/net/openh323-112/Makefile
new file mode 100644
index 000000000000..eae4519938e1
--- /dev/null
+++ b/net/openh323-112/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: openh323
+# Version required: 1.1alpha1
+# Date created: Thu Feb 17 15:00:48 GMT 2000
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= openh323_1.1alpha1
+PKGNAME= openh323-1.1.a1
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pwlib_min_1.14.tar.gz
+
+MAINTAINER= roger@freebsd.org
+
+WRKSRC= ${WRKDIR}/openh323
+
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
+ OPENH323DIR=${WRKDIR}/openh323
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/test/obj_FreeBSD_x86_r/voxilla ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/test/voxilla.1 ${PREFIX}/man/man1/voxilla.1
+
+MAN1= voxilla.1
+
+.include <bsd.port.mk>
diff --git a/net/openh323-112/distinfo b/net/openh323-112/distinfo
new file mode 100644
index 000000000000..9633e7478024
--- /dev/null
+++ b/net/openh323-112/distinfo
@@ -0,0 +1,2 @@
+MD5 (openh323_1.1alpha1.tar.gz) = 62856e29e923b4215a2ba9bf1bfc5aad
+MD5 (pwlib_min_1.14.tar.gz) = 26afe224c2264ac5ea54535abafebf2d
diff --git a/net/openh323-112/pkg-comment b/net/openh323-112/pkg-comment
new file mode 100644
index 000000000000..ab7b3369c3f5
--- /dev/null
+++ b/net/openh323-112/pkg-comment
@@ -0,0 +1 @@
+A H323 Video Conferencing package. Can connect to MS NetMeeting.
diff --git a/net/openh323-112/pkg-descr b/net/openh323-112/pkg-descr
new file mode 100644
index 000000000000..62f60e782dce
--- /dev/null
+++ b/net/openh323-112/pkg-descr
@@ -0,0 +1,15 @@
+OpenH323 is a multi-platform H323 Video Conferencing program.
+It can exchange full duplex audio and video with other H323
+compliant video conferencing programs including Microsoft NetMeeting
+It requires a sound card for audio support and a Bt848/878 based
+video card (using the bktr driver) for video capture.
+
+It makes use of PWLib.
+
+PWLib is a multi-platform code library that can be used to write
+applications that will compile and run on Windows, Linux and a few other
+Unix variants. It was developed by Equivalence Ltd Pty
+
+For more information see
+http://www.openh323.org
+http://www.equival.com
diff --git a/net/openh323-112/pkg-plist b/net/openh323-112/pkg-plist
new file mode 100644
index 000000000000..b901edf75c04
--- /dev/null
+++ b/net/openh323-112/pkg-plist
@@ -0,0 +1 @@
+bin/voxilla
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
new file mode 100644
index 000000000000..eae4519938e1
--- /dev/null
+++ b/net/openh323/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: openh323
+# Version required: 1.1alpha1
+# Date created: Thu Feb 17 15:00:48 GMT 2000
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= openh323_1.1alpha1
+PKGNAME= openh323-1.1.a1
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pwlib_min_1.14.tar.gz
+
+MAINTAINER= roger@freebsd.org
+
+WRKSRC= ${WRKDIR}/openh323
+
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
+ OPENH323DIR=${WRKDIR}/openh323
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/test/obj_FreeBSD_x86_r/voxilla ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/test/voxilla.1 ${PREFIX}/man/man1/voxilla.1
+
+MAN1= voxilla.1
+
+.include <bsd.port.mk>
diff --git a/net/openh323/distinfo b/net/openh323/distinfo
new file mode 100644
index 000000000000..9633e7478024
--- /dev/null
+++ b/net/openh323/distinfo
@@ -0,0 +1,2 @@
+MD5 (openh323_1.1alpha1.tar.gz) = 62856e29e923b4215a2ba9bf1bfc5aad
+MD5 (pwlib_min_1.14.tar.gz) = 26afe224c2264ac5ea54535abafebf2d
diff --git a/net/openh323/pkg-comment b/net/openh323/pkg-comment
new file mode 100644
index 000000000000..ab7b3369c3f5
--- /dev/null
+++ b/net/openh323/pkg-comment
@@ -0,0 +1 @@
+A H323 Video Conferencing package. Can connect to MS NetMeeting.
diff --git a/net/openh323/pkg-descr b/net/openh323/pkg-descr
new file mode 100644
index 000000000000..62f60e782dce
--- /dev/null
+++ b/net/openh323/pkg-descr
@@ -0,0 +1,15 @@
+OpenH323 is a multi-platform H323 Video Conferencing program.
+It can exchange full duplex audio and video with other H323
+compliant video conferencing programs including Microsoft NetMeeting
+It requires a sound card for audio support and a Bt848/878 based
+video card (using the bktr driver) for video capture.
+
+It makes use of PWLib.
+
+PWLib is a multi-platform code library that can be used to write
+applications that will compile and run on Windows, Linux and a few other
+Unix variants. It was developed by Equivalence Ltd Pty
+
+For more information see
+http://www.openh323.org
+http://www.equival.com
diff --git a/net/openh323/pkg-plist b/net/openh323/pkg-plist
new file mode 100644
index 000000000000..b901edf75c04
--- /dev/null
+++ b/net/openh323/pkg-plist
@@ -0,0 +1 @@
+bin/voxilla