aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/lastfm-desktop/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/audio/lastfm-desktop/Makefile b/audio/lastfm-desktop/Makefile
index bcc435d0d00d..f43f1f35d94b 100644
--- a/audio/lastfm-desktop/Makefile
+++ b/audio/lastfm-desktop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lastfm-desktop
PORTVERSION= 2.1.36
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= audio
MAINTAINER= ports@FreeBSD.org
@@ -12,7 +12,6 @@ COMMENT= Official Last.fm desktop application suite
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= Requires vlc-qt4 which was deprecated on 2018-12-31
DEPRECATED= Qt4 has been EOL since december 2015
EXPIRATION_DATE= 2019-03-15
@@ -22,12 +21,13 @@ LIB_DEPENDS= liblastfm.so:audio/liblastfm \
libimobiledevice.so:comms/libimobiledevice \
libplist.so:devel/libplist
+USES= gettext pkgconfig qmake gmake qt:4
+USE_QT= corelib dbus gui linguist_build moc_build network phonon \
+ phonon-gst_run rcc_build sql uic_build webkit xml
+
USE_GITHUB= yes
GH_ACCOUNT= lastfm
-USES= gettext pkgconfig qmake gmake qt:4
-USE_QT= corelib dbus gui linguist_build moc_build network phonon \
- rcc_build sql uic_build webkit xml
SUB_FILES= lastfm-desktop.sh
DESKTOP_ENTRIES="Last.fm Scrobbler" \
@@ -37,16 +37,6 @@ DESKTOP_ENTRIES="Last.fm Scrobbler" \
"AudioVideo;Audio;Qt;" \
true
-OPTIONS_SINGLE= PHONON
-OPTIONS_SINGLE_PHONON= GSTREAMER VLC
-OPTIONS_DEFAULT= VLC
-GSTREAMER_DESC= Multimedia via Phonon-GStreamer
-GSTREAMER_USES= qt:4
-GSTREAMER_USE= QT=phonon-gst_run
-VLC_DESC= Multimedia via Phonon-VLC
-#multimedia/phonon-vlc@qt4 flavor was removed due to depreciation of vlc-qt4
-#VLC_RUN_DEPENDS= phonon-vlc-qt4>=0.6.1:multimedia/phonon-vlc@qt4
-
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/lastfm-desktop.sh ${STAGEDIR}${PREFIX}/bin/lastfm-desktop