aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/zfstools/Makefile22
-rw-r--r--sysutils/zfstools/distinfo2
-rw-r--r--sysutils/zfstools/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3ffab8f5ce41..c25689a40033 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1030,6 +1030,7 @@
SUBDIR += zfs-snapshot-mgmt
SUBDIR += zfs-stats
SUBDIR += zfsnap
+ SUBDIR += zfstools
SUBDIR += zidrav
SUBDIR += zisofs-tools
SUBDIR += zxfer
diff --git a/sysutils/zfstools/Makefile b/sysutils/zfstools/Makefile
new file mode 100644
index 000000000000..140d9ec8c856
--- /dev/null
+++ b/sysutils/zfstools/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: zfstools
+# Date created: 26 April 2012
+# Whom: Bryan Drewery <bryan@shatow.net>
+#
+# $FreeBSD$
+
+PORTNAME= zfstools
+PORTVERSION= 0.2.1
+CATEGORIES= sysutils rubygems
+MASTER_SITES= RG
+
+MAINTAINER= bryan@shatow.net
+COMMENT= OpenSolaris-compatible auto snapshotting
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/zfs-auto-snapshot \
+ bin/zfs-cleanup-snapshots \
+ bin/zfs-snapshot-mysql
+
+.include <bsd.port.mk>
diff --git a/sysutils/zfstools/distinfo b/sysutils/zfstools/distinfo
new file mode 100644
index 000000000000..31bda33a5013
--- /dev/null
+++ b/sysutils/zfstools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/zfstools-0.2.1.gem) = dce9bdce62da661ff6bed42061b8263c909cc27294dc73e4b2a423d9ba5045ec
+SIZE (rubygem/zfstools-0.2.1.gem) = 13312
diff --git a/sysutils/zfstools/pkg-descr b/sysutils/zfstools/pkg-descr
new file mode 100644
index 000000000000..927b62479d97
--- /dev/null
+++ b/sysutils/zfstools/pkg-descr
@@ -0,0 +1,4 @@
+ZFSTools is an OpenSolaris-like and compatible auto snapshotting
+script, which also supports auto snapshotting mysql databases.
+
+WWW: http://github.com/bdrewery/zfstools