aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/xephem/Makefile11
-rw-r--r--audio/baudline/Makefile1
-rw-r--r--audio/ventrilo-server/Makefile2
-rw-r--r--comms/java-commapi/Makefile2
-rw-r--r--emulators/ski/Makefile4
-rw-r--r--java/infobus/Makefile2
-rw-r--r--java/jaf/Makefile2
-rw-r--r--java/jai-imageio/Makefile2
-rw-r--r--java/jdk16-doc/Makefile2
-rw-r--r--java/jdk7-doc/Makefile4
-rw-r--r--java/jta/Makefile2
-rw-r--r--java/linux-sun-jdk16/Makefile4
-rw-r--r--java/linux-sun-jdk17/Makefile6
-rw-r--r--java/linux-sun-jre16/Makefile2
-rw-r--r--java/linux-sun-jre17/Makefile2
-rw-r--r--java/netbeans55/Makefile2
-rw-r--r--java/netcomponents/Makefile8
-rw-r--r--lang/gnat/Makefile8
-rw-r--r--net/rsmb/Makefile17
-rw-r--r--science/vmd/Makefile2
-rw-r--r--security/bdc/Makefile8
21 files changed, 31 insertions, 62 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 5e3fd9eed5ee..1aa7f7ced281 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -29,18 +29,13 @@ XEPHEMSRC= ${PORTNAME}-${PORTVERSION}.tar.gz
.include <bsd.port.pre.mk>
.for file in ${XEPHEMSRC}
-.if !exists(${DISTDIR}/${file}) && !defined(PACKAGE_BUILDING)#{
-DISTFILE_INSTRUCTIONS=\n\
+.if !exists(${DISTDIR}/${file})
+ECHO_MSG= ${PRINTF}
+IGNORE=\n\
Because of licensing restrictions, you must manually fetch \n\ ${file} from http://www.clearskyinstitute.com/xephem/, \n\ place it in ${DISTDIR} and then run make again.\n\n
.endif
.endfor
-pre-fetch:
-.if defined(DISTFILE_INSTRUCTIONS)
- @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
- @exit 1
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|/usr/X11R6|${LOCALBASE}|g' \
diff --git a/audio/baudline/Makefile b/audio/baudline/Makefile
index ef6532788f88..ca37ba3236ec 100644
--- a/audio/baudline/Makefile
+++ b/audio/baudline/Makefile
@@ -1,6 +1,5 @@
# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= baudline
PORTVERSION= 1.08
diff --git a/audio/ventrilo-server/Makefile b/audio/ventrilo-server/Makefile
index befa35d16f45..9ce3e3d661b3 100644
--- a/audio/ventrilo-server/Makefile
+++ b/audio/ventrilo-server/Makefile
@@ -28,7 +28,7 @@ GROUPS= ${USERS}
WRKSRC= ${WRKDIR}/ventsrv
SUB_FILES= pkg-message
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= distfile can only be fetched if you accept the license. Go to http://www.ventrilo.com/dlprod.php?id=105 and put ${DISTFILES} into ${DISTDIR}
.endif
diff --git a/comms/java-commapi/Makefile b/comms/java-commapi/Makefile
index 28d7da10f290..ea1e7697543e 100644
--- a/comms/java-commapi/Makefile
+++ b/comms/java-commapi/Makefile
@@ -1,7 +1,5 @@
# Created by: Ari Suutari <ari.suutari@syncrontech.com>
-#
# $FreeBSD$
-#
PORTNAME= java-commapi
PORTVERSION= 2.0.3
diff --git a/emulators/ski/Makefile b/emulators/ski/Makefile
index b838a1d19798..cf9068360d18 100644
--- a/emulators/ski/Makefile
+++ b/emulators/ski/Makefile
@@ -1,4 +1,4 @@
-# Created by: David O'Brien (obrien@NUXI.com)
+# Created by: David O'Brien (obrien@NUXI.com)
# $FreeBSD$
PORTNAME= ski
@@ -46,7 +46,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= ${NOTICE}
.endif
diff --git a/java/infobus/Makefile b/java/infobus/Makefile
index 067e02a6240a..fcdd00481d55 100644
--- a/java/infobus/Makefile
+++ b/java/infobus/Makefile
@@ -23,7 +23,7 @@ PORTDOCS= *
.endif
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= You must manually fetch the distribution from http://java.sun.com/products/archive/javabeans/infobus/downloads.html and place it in ${DISTDIR} then run make again
.endif
diff --git a/java/jaf/Makefile b/java/jaf/Makefile
index d6c4b0081a09..170004cc3adb 100644
--- a/java/jaf/Makefile
+++ b/java/jaf/Makefile
@@ -28,7 +28,7 @@ PORTDOCS= ${DOCFILES1} ${DOCFILES2}
PLIST_FILES= %%JAVAJARDIR%%/activation.jar
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= you must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again
.endif
diff --git a/java/jai-imageio/Makefile b/java/jai-imageio/Makefile
index 4307543a6efe..d37be7a77694 100644
--- a/java/jai-imageio/Makefile
+++ b/java/jai-imageio/Makefile
@@ -27,7 +27,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= you must manually fetch the "Linux Install" distribution (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/jdk16-doc/Makefile b/java/jdk16-doc/Makefile
index 8a07da5d85cf..b8a93acbe68e 100644
--- a/java/jdk16-doc/Makefile
+++ b/java/jdk16-doc/Makefile
@@ -31,7 +31,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= you must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL} by selecting the "Download" link for the "Java SE 6 Documentation", place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/jdk7-doc/Makefile b/java/jdk7-doc/Makefile
index 435a6fef72d5..8d6f64d9caa3 100644
--- a/java/jdk7-doc/Makefile
+++ b/java/jdk7-doc/Makefile
@@ -28,8 +28,8 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
-IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL} by selecting the \"Download\" link for the \"Java SE 7 Documentation\", place it in ${DISTDIR} and then run make again
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL} by selecting the "Download" link for the "Java SE 7 Documentation", place it in ${DISTDIR} and then run make again
.endif
do-install:
diff --git a/java/jta/Makefile b/java/jta/Makefile
index 736b3a1c6bce..321bbcb535d6 100644
--- a/java/jta/Makefile
+++ b/java/jta/Makefile
@@ -23,7 +23,7 @@ PORTDOCS= ${DISTNAME}.pdf javadocs
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= you must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again
.endif
diff --git a/java/linux-sun-jdk16/Makefile b/java/linux-sun-jdk16/Makefile
index 8b68a7ae9197..a5c8f3e3ace4 100644
--- a/java/linux-sun-jdk16/Makefile
+++ b/java/linux-sun-jdk16/Makefile
@@ -40,7 +40,7 @@ UNPACK_CMD= ${WRKSRC}/bin/unpack200
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE?=You must manually fetch the J2SE SDK self-extracting file for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
@@ -55,7 +55,7 @@ DEMO_WRKSRC= ${WRKDIR}/jdk${JDK_VERSION}_${DEMO_UPDATE_VERSION}
DEMO_DISTNAME= ${DISTNAME}-demos
DEMO_WRKSRC= ${WRKSRC}
.endif
-.if !exists(${DISTDIR}/${DEMO_DISTNAME}.tar.gz) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DEMO_DISTNAME}.tar.gz)
IGNORE?=You must manually fetch the J2SE demos and samples for the Linux platform (${DEMO_DISTNAME}.tar.gz) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DEMO_DISTNAME}.tar.gz
diff --git a/java/linux-sun-jdk17/Makefile b/java/linux-sun-jdk17/Makefile
index 862d2e6d10bc..2a1cc2a8adeb 100644
--- a/java/linux-sun-jdk17/Makefile
+++ b/java/linux-sun-jdk17/Makefile
@@ -1,4 +1,4 @@
-# Created by: Greg Lewis <glewis@FreeBSD.org>
+# Created by: Greg Lewis <glewis@FreeBSD.org>
# $FreeBSD$
PORTNAME= jdk
@@ -41,7 +41,7 @@ BIN_DIRS= bin jre/bin
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE?=You must manually fetch the J2SE SDK download for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
@@ -56,7 +56,7 @@ DEMO_WRKSRC= ${WRKDIR}/jdk${JDK_INTERNAL_VERSION}_${DEMO_UPDATE_VERSION}
DEMO_DISTNAME= ${DISTNAME}-demos
DEMO_WRKSRC= ${WRKSRC}
.endif
-.if !exists(${DISTDIR}/${DEMO_DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DEMO_DISTNAME}${EXTRACT_SUFX})
IGNORE?=You must manually fetch the J2SE demos and samples for the Linux platform (${DEMO_DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DEMO_DISTNAME}${EXTRACT_SUFX}
diff --git a/java/linux-sun-jre16/Makefile b/java/linux-sun-jre16/Makefile
index 59085705584f..c833bae10ae0 100644
--- a/java/linux-sun-jre16/Makefile
+++ b/java/linux-sun-jre16/Makefile
@@ -36,7 +36,7 @@ UNPACK_CMD= ${WRKSRC}/bin/unpack200
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE?=You must manually fetch the JRE self-extracting file for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/linux-sun-jre17/Makefile b/java/linux-sun-jre17/Makefile
index 419e593a4113..260a11d8759a 100644
--- a/java/linux-sun-jre17/Makefile
+++ b/java/linux-sun-jre17/Makefile
@@ -37,7 +37,7 @@ BIN_DIRS= bin
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE?=You must manually fetch the J2SE RE download for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/netbeans55/Makefile b/java/netbeans55/Makefile
index ff98c1917de7..92b6bfbfb797 100644
--- a/java/netbeans55/Makefile
+++ b/java/netbeans55/Makefile
@@ -25,7 +25,7 @@ SUB_FILES= pkg-install pkg-deinstall
.include <bsd.port.pre.mk>
-#.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+#.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
#IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
#.endif
diff --git a/java/netcomponents/Makefile b/java/netcomponents/Makefile
index 752deb097c26..90b6b27fd429 100644
--- a/java/netcomponents/Makefile
+++ b/java/netcomponents/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: NetComponents
-# Date created: November 9, 2002
-# Whom: Ernst de Haan <znerd@FreeBSD.org>
-#
+# Created by: Ernst de Haan <znerd@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= netcomponents
PORTVERSION= 1.3.8
@@ -27,7 +23,7 @@ JARFILE= NetComponents.jar
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= must be manually fetched from ${MASTER_SITES}. Download\
${DISTFILES}, place it in ${DISTDIR} and restart this build
.endif
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index 63ecbfe64448..e2429122eb22 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -1,11 +1,5 @@
# Created by: hsu, nils@guru.ims.uni-stuttgart.de, maurice@serc.rmit.edu.au
# $FreeBSD$
-#
-# Note:
-# - FreeBSD tasking libraries are included in the stock source.
-# - The default names of a number of binaries have been altered to avoid
-# conflict with other gcc based products. Standard names can be provided
-# using symbolic links.
PORTNAME= gnat
PORTVERSION= 2010
@@ -124,7 +118,7 @@ PLIST_SUB+= SHAREDLIB="@comment "
.endif
# Check for GNAT sources.
-.if !exists(${DISTDIR}/${gnat_srcfile}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${gnat_srcfile})
IGNORE= you must fetch the source distribution manually. Please access http://libre.adacore.com/ with a web browser and download the source files: ${gnat_srcfile} ${gcc_srcfile} placing them in ${DISTDIR}
.endif
diff --git a/net/rsmb/Makefile b/net/rsmb/Makefile
index 44890e6ae14b..66fadea254a1 100644
--- a/net/rsmb/Makefile
+++ b/net/rsmb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rsmb
-# Date created: 9 Nov 2009
-# Whom: Andrew Stevenson <andrew@ugh.net.au>
-#
+# Created by: Andrew Stevenson <andrew@ugh.net.au>
# $FreeBSD$
-#
PORTNAME= rsmb
PORTVERSION= 1.1.0
@@ -29,14 +25,9 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
-DISTFILE_INSTRUCTIONS= ${RESTRICTED}
-.endif
-
-pre-fetch:
-.if defined(DISTFILE_INSTRUCTIONS)
- @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
- @${FALSE}
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ECHO_MSG= ${PRINTF}
+IGNORE= ${RESTRICTED}
.endif
do-install:
diff --git a/science/vmd/Makefile b/science/vmd/Makefile
index d3d33ef66668..b9171f40e747 100644
--- a/science/vmd/Makefile
+++ b/science/vmd/Makefile
@@ -52,7 +52,7 @@ VMD_TARGET= freebsd.opengl
PLIST_SUB+= VMD_ARCH=${VMD_ARCH}
# Check for VMD sources
-.if !exists(${DISTDIR}/${VMD_DIST}) # && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${VMD_DIST})
IGNORE= Because of licensing restrictions, you must fetch the source distribution manually. Please access http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD with a web browser. You will be required to log in and register, but you can create an account on this page. After registration and accepting the University of Illinois agreement, download the source file, ${VMD_DIST}. Please place this file in ${DISTDIR}, and re-run make
.endif
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
index 942eab53650f..fe23eba0b53d 100644
--- a/security/bdc/Makefile
+++ b/security/bdc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bdc
-# Date created: 4 December 2004
-# Whom: Adi Pircalabu <apircalabu@bitdefender.com>
-#
+# Created by: Adi Pircalabu <apircalabu@bitdefender.com>
# $FreeBSD$
-#
PORTNAME= bdc
PORTVERSION= 7.0.1
@@ -29,7 +25,7 @@ BDREL= 5
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= you have to fetch ${DISTNAME}${EXTRACT_SUFX} manually after reading\
and agreeing to the license at:\
http://download.bitdefender.com/SMB/Workstation_Security_and_Management/BitDefender_Antivirus_Scanner_for_Unices/Unix/Old/EN/freebsd/Ver_${BDREL}/.\