aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/gretools/Makefile8
-rw-r--r--games/gretools/pkg-plist2
2 files changed, 7 insertions, 3 deletions
diff --git a/games/gretools/Makefile b/games/gretools/Makefile
index 737dff869590..62c1f2dbe1dc 100644
--- a/games/gretools/Makefile
+++ b/games/gretools/Makefile
@@ -15,18 +15,20 @@ MASTER_SITE_SUBDIR= ${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME vocabulary builder
-BROKEN= Incomplete pkg-plist
-
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget pygnome2
USE_PYTHON= yes
-INSTALLS_OMF= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|g ; \
s|@prefix@/share/|@datadir@/|g' ${WRKSRC}/gretools.in
+ @${REINPLACE_CMD} -e 's|gtk\.TRUE|True|g ; \
+ s|gtk\.FALSE|False|g ; \
+ s|"/share/"|"/share/gnome/"|g ; \
+ s|gtk\.idle_add|gobject\.idle_add|g' ${WRKSRC}/gretools.py
.include <bsd.port.mk>
diff --git a/games/gretools/pkg-plist b/games/gretools/pkg-plist
index 35eddc0bee48..7e1772d340d4 100644
--- a/games/gretools/pkg-plist
+++ b/games/gretools/pkg-plist
@@ -19,3 +19,5 @@ share/gnome/pixmaps/gretools.png
@dirrm share/gnome/gretools/glade
@dirrm share/gnome/gretools
@dirrm %%PYTHON_SITELIBDIR%%/gretools
+@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2>/dev/null || true
+@unexec rmdir %D/%%PYTHON_LIBDIR%% 2>/dev/null || true