aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/smpeg/Makefile3
-rw-r--r--graphics/smpeg/files/patch-configure13
-rw-r--r--multimedia/smpeg/Makefile3
-rw-r--r--multimedia/smpeg/files/patch-configure13
4 files changed, 30 insertions, 2 deletions
diff --git a/graphics/smpeg/Makefile b/graphics/smpeg/Makefile
index 75393ef17aac..931ff2345d89 100644
--- a/graphics/smpeg/Makefile
+++ b/graphics/smpeg/Makefile
@@ -26,7 +26,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
GLBASE="${X11BASE}" \
- CPPFLAGS="-I${X11BASE}/include"
+ CPPFLAGS="-I${X11BASE}/include" \
+ CC="${CXX}" REAL_CC="${CC}"
#If you want to try the opengl player (which doesn't seem to work)
#comment out the following line.
diff --git a/graphics/smpeg/files/patch-configure b/graphics/smpeg/files/patch-configure
new file mode 100644
index 000000000000..8eddcc730596
--- /dev/null
+++ b/graphics/smpeg/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/07/02 12:33:37 1.1
++++ configure 2002/07/02 12:34:01
+@@ -2335,6 +2335,7 @@
+
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
++CC="$REAL_CC"
+
+ echo $ac_n "checking for sqrt in -lm""... $ac_c" 1>&6
+ echo "configure:2341: checking for sqrt in -lm" >&5
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
index 75393ef17aac..931ff2345d89 100644
--- a/multimedia/smpeg/Makefile
+++ b/multimedia/smpeg/Makefile
@@ -26,7 +26,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
GLBASE="${X11BASE}" \
- CPPFLAGS="-I${X11BASE}/include"
+ CPPFLAGS="-I${X11BASE}/include" \
+ CC="${CXX}" REAL_CC="${CC}"
#If you want to try the opengl player (which doesn't seem to work)
#comment out the following line.
diff --git a/multimedia/smpeg/files/patch-configure b/multimedia/smpeg/files/patch-configure
new file mode 100644
index 000000000000..8eddcc730596
--- /dev/null
+++ b/multimedia/smpeg/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/07/02 12:33:37 1.1
++++ configure 2002/07/02 12:34:01
+@@ -2335,6 +2335,7 @@
+
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
++CC="$REAL_CC"
+
+ echo $ac_n "checking for sqrt in -lm""... $ac_c" 1>&6
+ echo "configure:2341: checking for sqrt in -lm" >&5