aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/sipxtacklib/Makefile43
-rw-r--r--net/sipxtacklib/distinfo3
-rw-r--r--net/sipxtacklib/files/patch-doc-Makefile.am11
-rw-r--r--net/sipxtacklib/files/patch-doc-Makefile.in11
-rw-r--r--net/sipxtacklib/files/patch-src_Makefile.am12
-rw-r--r--net/sipxtacklib/files/patch-src_Makefile.in11
-rw-r--r--net/sipxtacklib/files/patch-src_net_SipUserAgent.cpp11
-rw-r--r--net/sipxtacklib/pkg-descr5
-rw-r--r--net/sipxtacklib/pkg-plist129
10 files changed, 237 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8834b42f1042..8c7970551b34 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -745,6 +745,7 @@
SUBDIR += siproxd
SUBDIR += sipsak
SUBDIR += sipxportlib
+ SUBDIR += sipxtacklib
SUBDIR += sixxs-aiccu
SUBDIR += sixxs-heartbeatd
SUBDIR += skstream
diff --git a/net/sipxtacklib/Makefile b/net/sipxtacklib/Makefile
new file mode 100644
index 000000000000..633cdff271e0
--- /dev/null
+++ b/net/sipxtacklib/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: sipxtacklib
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxtacklib
+PORTVERSION= 3.6.0
+CATEGORIES= net java
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX library of utilities and SIP stack info processing
+
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= ant:${PORTSDIR}/devel/apache-ant \
+ cppunit-config:${PORTSDIR}/devel/cppunit \
+ ginstall:${PORTSDIR}/sysutils/coreutils \
+ cppunit-config:${PORTSDIR}/devel/cppunit
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PERL5_RUN= yes
+USE_JAVA= 1.4+
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME} \
+ wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/siptest/src/siptest/subscribe-dialog-test
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/syslog2siptrace/merge-logs
+
+.include <bsd.port.mk>
diff --git a/net/sipxtacklib/distinfo b/net/sipxtacklib/distinfo
new file mode 100644
index 000000000000..d7938d9f9ab3
--- /dev/null
+++ b/net/sipxtacklib/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxtacklib-3.6.0.tar.bz2) = 586f80ced03960d1eab5ed8c1f84578c
+SHA256 (sipxtacklib-3.6.0.tar.bz2) = 9877bc2f46960d4fc6d747cb07d84fcee642aab78bdf1b3eb1302d6ab506f4a6
+SIZE (sipxtacklib-3.6.0.tar.bz2) = 1059845
diff --git a/net/sipxtacklib/files/patch-doc-Makefile.am b/net/sipxtacklib/files/patch-doc-Makefile.am
new file mode 100644
index 000000000000..e8bc77b5966d
--- /dev/null
+++ b/net/sipxtacklib/files/patch-doc-Makefile.am
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orgi Mon Jan 29 12:10:45 2007
++++ doc/Makefile.am Mon Jan 29 12:11:05 2007
+@@ -31,7 +31,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxtacklib/files/patch-doc-Makefile.in b/net/sipxtacklib/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..642873349762
--- /dev/null
+++ b/net/sipxtacklib/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orgi Mon Jan 29 12:10:55 2007
++++ doc/Makefile.in Mon Jan 29 12:11:15 2007
+@@ -481,7 +481,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxtacklib/files/patch-src_Makefile.am b/net/sipxtacklib/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..9b556c155fd3
--- /dev/null
+++ b/net/sipxtacklib/files/patch-src_Makefile.am
@@ -0,0 +1,12 @@
+--- ./src/Makefile.am.orig Thu Dec 28 18:02:19 2006
++++ ./src/Makefile.am Thu Dec 28 18:02:39 2006
+@@ -38,8 +38,7 @@
+ libsipXtack_la_LIBADD = \
+ @SIPXPORT_LIBS@ \
+ @SSL_LIBS@ \
+- @PCRE_LIBS@ \
+- -lresolv
++ @PCRE_LIBS@
+ if ISGCC
+ libsipXtack_la_LIBADD += -lstdc++
+ endif
diff --git a/net/sipxtacklib/files/patch-src_Makefile.in b/net/sipxtacklib/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..3e31dfd349e5
--- /dev/null
+++ b/net/sipxtacklib/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig Thu Dec 28 18:02:25 2006
++++ ./src/Makefile.in Thu Dec 28 18:02:45 2006
+@@ -352,7 +352,7 @@
+ -DSIPX_CONFDIR=\"@SIPX_CONFDIR@\"
+
+ libsipXtack_la_LIBADD = @SIPXPORT_LIBS@ @SSL_LIBS@ @PCRE_LIBS@ \
+- -lresolv $(am__append_1)
++ $(am__append_1)
+ libsipXtack_la_SOURCES = \
+ $(top_builddir)/config/sipxtacklib-buildstamp.h \
+ $(top_builddir)/config/sipxtacklib-buildstamp.cpp \
diff --git a/net/sipxtacklib/files/patch-src_net_SipUserAgent.cpp b/net/sipxtacklib/files/patch-src_net_SipUserAgent.cpp
new file mode 100644
index 000000000000..285fae08016e
--- /dev/null
+++ b/net/sipxtacklib/files/patch-src_net_SipUserAgent.cpp
@@ -0,0 +1,11 @@
+--- ./src/net/SipUserAgent.cpp.orig Thu Dec 28 17:59:14 2006
++++ ./src/net/SipUserAgent.cpp Thu Dec 28 18:00:20 2006
+@@ -83,6 +83,8 @@
+ # define PLATFORM_UA_PARAM " (Linux)"
+ #elif defined(sun)
+ # define PLATFORM_UA_PARAM " (Solaris)"
++#elif defined(__FreeBSD__)
++# define PLATFORM_UA_PARAM " (FreeBSD)"
+ #endif
+ #endif /* PLATFORM_UA_PARAM */
+
diff --git a/net/sipxtacklib/pkg-descr b/net/sipxtacklib/pkg-descr
new file mode 100644
index 000000000000..ac6037512705
--- /dev/null
+++ b/net/sipxtacklib/pkg-descr
@@ -0,0 +1,5 @@
+sipXportLib is a library of SIP related functions and information
+processing utilities. It is a necessary dependancy of the sipX
+project.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxtacklib/pkg-plist b/net/sipxtacklib/pkg-plist
new file mode 100644
index 000000000000..59b6d82bd3bb
--- /dev/null
+++ b/net/sipxtacklib/pkg-plist
@@ -0,0 +1,129 @@
+bin/merge-logs
+bin/siplog2siptrace
+bin/siptest
+bin/siptrace-merge
+bin/sipviewer
+bin/sipxtacklib-config
+bin/subscribe-dialog-test
+bin/syslog2siptrace
+include/net/HttpBody.h
+include/net/HttpConnection.h
+include/net/HttpConnectionMap.h
+include/net/HttpMessage.h
+include/net/HttpRequestContext.h
+include/net/HttpServer.h
+include/net/HttpService.h
+include/net/MailAttachment.h
+include/net/MailMessage.h
+include/net/MimeBodyPart.h
+include/net/NameValuePair.h
+include/net/NameValuePairInsensitive.h
+include/net/NameValueTokenizer.h
+include/net/NetAttributeTokenizer.h
+include/net/NetBase64Codec.h
+include/net/NetMd5Codec.h
+include/net/PidfBody.h
+include/net/ProvisioningAgent.h
+include/net/ProvisioningAgentXmlRpcAdapter.h
+include/net/ProvisioningAttrList.h
+include/net/ProvisioningClass.h
+include/net/QoS.h
+include/net/SdpBody.h
+include/net/SdpCodec.h
+include/net/SdpCodecFactory.h
+include/net/SipClient.h
+include/net/SipConfigServerAgent.h
+include/net/SipContactDb.h
+include/net/SipDialog.h
+include/net/SipDialogEvent.h
+include/net/SipDialogMgr.h
+include/net/SipDialogMonitor.h
+include/net/SipLine.h
+include/net/SipLineCredentials.h
+include/net/SipLineEvent.h
+include/net/SipLineList.h
+include/net/SipLineMgr.h
+include/net/SipMessage.h
+include/net/SipMessageEvent.h
+include/net/SipMessageList.h
+include/net/SipNonceDb.h
+include/net/SipNotifyStateTask.h
+include/net/SipObserverCriteria.h
+include/net/SipPimClient.h
+include/net/SipPresenceEvent.h
+include/net/SipProtocolServerBase.h
+include/net/SipPublishContentMgr.h
+include/net/SipPublishServer.h
+include/net/SipPublishServerEventStateCompositor.h
+include/net/SipPublishServerEventStateMgr.h
+include/net/SipRefreshManager.h
+include/net/SipRefreshMgr.h
+include/net/SipRequestContext.h
+include/net/SipResourceList.h
+include/net/SipServerBase.h
+include/net/SipServerBroker.h
+include/net/SipSession.h
+include/net/SipSrvLookup.h
+include/net/SipSubscribeClient.h
+include/net/SipSubscribeServer.h
+include/net/SipSubscribeServerEventHandler.h
+include/net/SipSubscriptionMgr.h
+include/net/SipTcpServer.h
+include/net/SipTlsServer.h
+include/net/SipTransaction.h
+include/net/SipTransactionList.h
+include/net/SipUdpServer.h
+include/net/SipUserAgent.h
+include/net/SipUserAgentBase.h
+include/net/SipUserAgentStateless.h
+include/net/SmimeBody.h
+include/net/StateChangeNotifier.h
+include/net/TapiMgr.h
+include/net/Url.h
+include/net/XmlRpcBody.h
+include/net/XmlRpcDispatch.h
+include/net/XmlRpcMethod.h
+include/net/XmlRpcRequest.h
+include/net/XmlRpcResponse.h
+include/net/version.h
+include/resparse/bzero.h
+include/resparse/ns_name.h
+include/resparse/poll.h
+include/resparse/res_config.h
+include/resparse/res_info.h
+include/resparse/rr.h
+include/resparse/types.h
+include/siptest/AuthCommand.h
+include/siptest/Command.h
+include/siptest/CommandMsgProcessor.h
+include/siptest/CommandProcessor.h
+include/siptest/ExitCommand.h
+include/siptest/HelpCommand.h
+include/siptest/HistoryCommand.h
+include/siptest/HttpGetCommand.h
+include/siptest/RespondCommand.h
+include/siptest/RespondTemplate.h
+include/siptest/SipLSendCommand.h
+include/siptest/SipLogCommand.h
+include/siptest/SipSendCommand.h
+include/tapi/SipXHandleMap.h
+include/tapi/SipXMessageObserver.h
+include/tapi/SipXtapiEventDispatcher.h
+include/tapi/doxyfile
+include/tapi/sipXtapi.h
+include/tapi/sipXtapiEvents.h
+include/tapi/sipXtapiInternal.h
+lib/libsipXtack.a
+lib/libsipXtack.la
+lib/libsipXtack.so
+lib/libsipXtack.so.2
+lib/sipviewer/jdom.jar
+lib/sipviewer/sipviewer.jar
+share/sipx/schema/sip_types.xsd
+@dirrm share/sipx/schema
+@dirrm share/sipx
+@dirrm lib/sipviewer
+@dirrm include/tapi
+@dirrm include/siptest
+@dirrm include/resparse
+@dirrm include/net