aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/rtmpdump/Makefile37
-rw-r--r--multimedia/rtmpdump/distinfo3
-rw-r--r--multimedia/rtmpdump/pkg-descr4
4 files changed, 45 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 71fd84d677a8..1223e4350098 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -260,6 +260,7 @@
SUBDIR += recordmydesktop
SUBDIR += replex
SUBDIR += rox-videothumbnail
+ SUBDIR += rtmpdump
SUBDIR += ruby-flvtool2
SUBDIR += sabbu
SUBDIR += schroedinger
diff --git a/multimedia/rtmpdump/Makefile b/multimedia/rtmpdump/Makefile
new file mode 100644
index 000000000000..43f799f4ffd3
--- /dev/null
+++ b/multimedia/rtmpdump/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: rtmpdump
+# Date created: March 15, 2010
+# Whom: hrs
+#
+# $FreeBSD$
+
+PORTNAME= rtmpdump
+PORTVERSION= 2.2
+CATEGORIES= multimedia net
+MASTER_SITES= http://rtmpdump.mplayerhq.hu/download/
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A tool to download RTMP streams
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+ALL_TARGET= posix
+
+MAN1= rtmpdump.1
+MAN8= rtmpgw.8
+
+PLIST_FILES_PROG= bin/rtmpdump bin/rtmpgw bin/rtmpsrv bin/rtmpsuck
+PORTDOCS= ChangeLog README
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PLIST_FILES_PROG:S,^bin/,,} \
+ ${PREFIX}/bin \
+ && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1 \
+ && ${INSTALL_MAN} ${MAN8} ${MAN1PREFIX}/man/man8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/rtmpdump/distinfo b/multimedia/rtmpdump/distinfo
new file mode 100644
index 000000000000..2b303d245466
--- /dev/null
+++ b/multimedia/rtmpdump/distinfo
@@ -0,0 +1,3 @@
+MD5 (rtmpdump-2.2.tar.bz2) = 1ce6753c95754d1a72b635d488757096
+SHA256 (rtmpdump-2.2.tar.bz2) = 2aef30c1f0fbda4d501e08892a6cfe0aa1d0213ee2bfad4e1926411573bd3736
+SIZE (rtmpdump-2.2.tar.bz2) = 83586
diff --git a/multimedia/rtmpdump/pkg-descr b/multimedia/rtmpdump/pkg-descr
new file mode 100644
index 000000000000..0b3baa598827
--- /dev/null
+++ b/multimedia/rtmpdump/pkg-descr
@@ -0,0 +1,4 @@
+rtmpdump is a tool to download RTMP streams. All forms of RTMP are supported,
+including rtmp://, rtmpt://, rtmpe://, rtmpte://, and rtmps://.
+
+WWW: http://rtmpdump.mplayerhq.hu/