aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.python.mk8
-rw-r--r--lang/python/Makefile9
-rw-r--r--lang/python24/Makefile8
-rw-r--r--lang/python24/files/patch-setup.py10
-rw-r--r--lang/python24/pkg-plist5
-rw-r--r--lang/python25/Makefile10
-rw-r--r--lang/python25/files/patch-setup.py10
-rw-r--r--lang/python25/pkg-plist7
-rw-r--r--lang/python26/Makefile10
-rw-r--r--lang/python26/files/patch-setup.py10
-rw-r--r--lang/python26/pkg-plist7
-rw-r--r--lang/python27/Makefile10
-rw-r--r--lang/python27/files/patch-setup.py10
-rw-r--r--lang/python27/pkg-plist7
-rw-r--r--lang/python30/Makefile10
-rw-r--r--lang/python30/files/patch-setup.py10
-rw-r--r--lang/python30/pkg-plist7
-rw-r--r--lang/python31/Makefile10
-rw-r--r--lang/python31/files/patch-setup.py10
-rw-r--r--lang/python31/pkg-plist7
-rw-r--r--lang/python32/Makefile10
-rw-r--r--lang/python32/files/patch-setup.py10
-rw-r--r--lang/python32/pkg-plist7
23 files changed, 97 insertions, 105 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index bc3a188183eb..3e82bbddb4db 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -159,8 +159,8 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# specific version of zope.
#
-_PYTHON_PORTBRANCH= 2.5
-_PYTHON_ALLBRANCHES= 2.5 2.4 2.3 2.2 2.1 # preferred first
+_PYTHON_PORTBRANCH= 2.4
+_PYTHON_ALLBRANCHES= 2.4 2.5 2.3 2.2 2.1 # preferred first
_ZOPE_PORTBRANCH= 2.7
_ZOPE_ALLBRANCHES= 2.7 2.8 2.9 3.2
@@ -358,8 +358,8 @@ check-makevars::
@${ECHO} " python2.1"
@${ECHO} " python2.2"
@${ECHO} " python2.3"
- @${ECHO} " python2.4"
- @${ECHO} " python2.5 (default)"
+ @${ECHO} " python2.4 (default)"
+ @${ECHO} " python2.5"
@${FALSE}
.endif
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 853ba7705af1..069966fc5f61 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= python
-PORTVERSION= 2.5
+PORTVERSION= 2.4.3
+PORTEPOCH= 1
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
DISTFILES= # empty
@@ -16,7 +17,7 @@ MAINTAINER= python@FreeBSD.org
COMMENT= The "meta-port" for the stable version of Python interpreter
USE_PYTHON_RUN= yes
-PYTHON_VERSION= python2.5
+PYTHON_VERSION= python2.4
NO_BUILD= yes
do-install: # empty
@@ -26,13 +27,13 @@ PORTUPGRADE?= ${LOCALBASE}/sbin/portupgrade
PKG_WHICH?= ${LOCALBASE}/sbin/pkg_which
upgrade-site-packages:
@if [ -x ${PORTUPGRADE} ]; then \
- for ver in 2.1 2.2 2.3 2.4; do \
+ for ver in 2.1 2.2 2.3 2.5; do \
if [ -d ${PREFIX}/lib/python$$ver ]; then \
UPD=`${FIND} ${PREFIX}/lib/python$$ver \
-type f -print0 | \
${XARGS} -0 ${PKG_WHICH} | \
${GREP} -Fv '?' | \
- ${EGREP} -v '^python2?[0-4]?-2' | \
+ ${EGREP} -v '^python2?[0-5]?-2' | \
${SORT} -u`; \
if [ "$$UPD" ]; then \
${PORTUPGRADE} -f $$UPD; \
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 089245f8b643..7a4bd0620c7f 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python24
PORTVERSION= 2.4.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,8 +23,8 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= altinstall
-MAN1= ${PYTHON_VERSION}.1
+INSTALL_TARGET= install
+MAN1= python.1 ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.4
@@ -181,6 +181,8 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
+ cd ${PREFIX}/bin; \
+ ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared
@# additional files installing by ports
@${MKDIR} ${MANPREFIX}/man/man1
diff --git a/lang/python24/files/patch-setup.py b/lang/python24/files/patch-setup.py
index 09ac786be1a6..93e2c278b468 100644
--- a/lang/python24/files/patch-setup.py
+++ b/lang/python24/files/patch-setup.py
@@ -27,13 +27,3 @@
curses_libs = ['ncursesw']
exts.append( Extension('_curses', ['_cursesmodule.c'],
libraries = curses_libs) )
-@@ -1187,8 +1187,7 @@
- ext_modules=[Extension('struct', ['structmodule.c'])],
-
- # Scripts to install
-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
-- 'Lib/smtpd.py']
-+ scripts = []
- )
-
- # --install-platlib
diff --git a/lang/python24/pkg-plist b/lang/python24/pkg-plist
index ec0051d4c9bb..886fe9cf0142 100644
--- a/lang/python24/pkg-plist
+++ b/lang/python24/pkg-plist
@@ -1,8 +1,13 @@
+bin/idle
bin/idle%%PYVER%%
+bin/pydoc
bin/pydoc%%PYVER%%
+bin/python
bin/python%%PYVER%%
+bin/python-shared
bin/python-shared%%PYVER%%
bin/smtpd%%PYVER%%.py
+bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h
%%PYTHON_INCLUDEDIR%%/bitset.h
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python25/files/patch-setup.py b/lang/python25/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python25/files/patch-setup.py
+++ b/lang/python25/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python25/pkg-plist b/lang/python25/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python25/pkg-plist
+++ b/lang/python25/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python26/files/patch-setup.py b/lang/python26/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python26/files/patch-setup.py
+++ b/lang/python26/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python26/pkg-plist b/lang/python26/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python26/pkg-plist
+++ b/lang/python26/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python27/files/patch-setup.py b/lang/python27/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python27/files/patch-setup.py
+++ b/lang/python27/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python30/files/patch-setup.py b/lang/python30/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python30/files/patch-setup.py
+++ b/lang/python30/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python30/pkg-plist b/lang/python30/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python30/pkg-plist
+++ b/lang/python30/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python31/files/patch-setup.py b/lang/python31/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python31/files/patch-setup.py
+++ b/lang/python31/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python31/pkg-plist b/lang/python31/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python31/pkg-plist
+++ b/lang/python31/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python32/pkg-plist b/lang/python32/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python32/pkg-plist
+++ b/lang/python32/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h