aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Tie-DBI/Makefile22
-rw-r--r--databases/p5-Tie-DBI/distinfo1
-rw-r--r--databases/p5-Tie-DBI/pkg-comment1
-rw-r--r--databases/p5-Tie-DBI/pkg-descr5
-rw-r--r--databases/p5-Tie-DBI/pkg-plist4
6 files changed, 34 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index f2def3b7854c..6514144ff257 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -47,6 +47,7 @@
SUBDIR += p5-Pg
SUBDIR += p5-SQL-Statement
SUBDIR += p5-Text-Query-SQL
+ SUBDIR += p5-Tie-DBI
SUBDIR += p5-hp200lx-db
SUBDIR += pgaccess
SUBDIR += phpmyadmin
diff --git a/databases/p5-Tie-DBI/Makefile b/databases/p5-Tie-DBI/Makefile
new file mode 100644
index 000000000000..c25924140096
--- /dev/null
+++ b/databases/p5-Tie-DBI/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Tie-DBI
+# Date created: Thu Mar 8 06:56:59 2001
+# Whom: clive
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-DBI
+PORTVERSION= 0.91
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Tie::RDBM.3 Tie::DBI.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Tie-DBI/distinfo b/databases/p5-Tie-DBI/distinfo
new file mode 100644
index 000000000000..f624073f3421
--- /dev/null
+++ b/databases/p5-Tie-DBI/distinfo
@@ -0,0 +1 @@
+MD5 (Tie-DBI-0.91.tar.gz) = c168bea09d31cdd5edecccf5af2dfa92
diff --git a/databases/p5-Tie-DBI/pkg-comment b/databases/p5-Tie-DBI/pkg-comment
new file mode 100644
index 000000000000..841ea8ca1848
--- /dev/null
+++ b/databases/p5-Tie-DBI/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing Tie hash to a DBI handle
diff --git a/databases/p5-Tie-DBI/pkg-descr b/databases/p5-Tie-DBI/pkg-descr
new file mode 100644
index 000000000000..b9c27bbcaf01
--- /dev/null
+++ b/databases/p5-Tie-DBI/pkg-descr
@@ -0,0 +1,5 @@
+Tie::DBI is a perl module implementing Tie hash to a DBI handle.
+
+Author: LDS (Lincoln D. Stein <lstein@genome.wi.mit.edu>)
+
+--clive
diff --git a/databases/p5-Tie-DBI/pkg-plist b/databases/p5-Tie-DBI/pkg-plist
new file mode 100644
index 000000000000..3d172e70178f
--- /dev/null
+++ b/databases/p5-Tie-DBI/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/Tie/RDBM.pm
+lib/perl5/site_perl/%%PERL_VER%%/Tie/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/DBI/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/DBI