aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/astrolog/Makefile8
-rw-r--r--misc/astrolog/distinfo2
-rw-r--r--misc/astrolog/files/patch-aa16
-rw-r--r--misc/astrolog/files/patch-src::sweodef.h17
4 files changed, 38 insertions, 5 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index 8dd6099105da..2c89e418d2a3 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -8,10 +8,13 @@
PORTNAME= astrolog
PORTVERSION= 5.41g
+PORTREVISION= 1
CATEGORIES= misc astro
MASTER_SITES= ftp://ftp.astro.com/pub/swisseph/ephe/archive_gzip/:ephe \
+ ftp://ftp.astro.com/pub/swisseph/:libswe \
http://astrolog.offline.ee/astrolog/changed/:dist
-DISTFILES= a541gsrc.tar.gz:dist ${EPHE}
+DISTFILES= a541gsrc.tar.gz:dist ${EPHE} \
+ swe_unix_src_1.78.00.tar.gz:libswe
MAINTAINER= ports@FreeBSD.org
COMMENT= An astrology program for X11 and alpha-numeric terminals
@@ -41,6 +44,9 @@ NO_WRKSUBDIR= yes
DOCS= helpfile.540 readme.541 changes.txt
+post-extract:
+ ${RM} ${WRKDIR}/swe[a-z]*
+
do-install:
-@${MKDIR} ${PREFIX}/lib/astrolog
cd ${WRKDIR} && \
diff --git a/misc/astrolog/distinfo b/misc/astrolog/distinfo
index 83b3b3c18cde..9417a15c3896 100644
--- a/misc/astrolog/distinfo
+++ b/misc/astrolog/distinfo
@@ -36,3 +36,5 @@ SHA256 (astrolog/swephm48.tar.gz) = 03dadea99521fbbccbc90e6c3f5315986ec308a3973a
SIZE (astrolog/swephm48.tar.gz) = 1988548
SHA256 (astrolog/swephm54.tar.gz) = 500b2ed7940ee593c7c361270ee808a74ab3940c24656b2b84c92e8578322748
SIZE (astrolog/swephm54.tar.gz) = 2000428
+SHA256 (astrolog/swe_unix_src_1.78.00.tar.gz) = 69abd9a49d16693768d223a0acad484b8c5b9ca46d434c8942f5ea815ffd81ee
+SIZE (astrolog/swe_unix_src_1.78.00.tar.gz) = 4517350
diff --git a/misc/astrolog/files/patch-aa b/misc/astrolog/files/patch-aa
index b6ff3e3fe81a..929ff56752e7 100644
--- a/misc/astrolog/files/patch-aa
+++ b/misc/astrolog/files/patch-aa
@@ -1,16 +1,24 @@
--- makefile.orig 2002-04-27 22:48:52.000000000 +0400
-+++ makefile 2012-02-25 22:50:00.000000000 +0400
-@@ -28,9 +28,15 @@
++++ makefile 2012-11-21 12:12:08.000000000 +0400
+@@ -17,6 +17,7 @@
+ # edited, is compile each source file, and link them together with the math
+ # library, and if applicable, the main X library.
+ #
++.PATH: src
+ NAME = astrolog
+ OBJ = astrolog.o data.o data2.o general.o io.o\
+ calc.o matrix.o charts0.o charts1.o charts2.o charts3.o\
+@@ -28,9 +29,15 @@
# LIBS = -lm -lX11
# with Debian Linux and X windows worked
# LIBS = -lm -L/usr/X11R6/lib -lX11
-LIBS= -lm
+.if defined(X11)
+LIBS = -L${LOCALBASE}/lib -lX11 -lm
-+CFLAGS += -DX11 -I${LOCALBASE}/include -DDEFAULT_DIR=\"${PREFIX}/lib/astrolog\"
++CFLAGS += -Isrc -DX11 -I${LOCALBASE}/include -DDEFAULT_DIR=\"${PREFIX}/lib/astrolog\"
+.else
+LIBS = -lm
-+CFLAGS += -DDEFAULT_DIR=\"${PREFIX}/lib/astrolog\"
++CFLAGS += -Isrc -DDEFAULT_DIR=\"${PREFIX}/lib/astrolog\"
+.endif
#
-CFLAGS = -O -DHPUX_SOURCE
diff --git a/misc/astrolog/files/patch-src::sweodef.h b/misc/astrolog/files/patch-src::sweodef.h
new file mode 100644
index 000000000000..1402803bba6f
--- /dev/null
+++ b/misc/astrolog/files/patch-src::sweodef.h
@@ -0,0 +1,17 @@
+--- src/sweodef.h.orig 2012-11-21 12:36:17.000000000 +0400
++++ src/sweodef.h 2012-11-21 12:37:03.000000000 +0400
+@@ -197,10 +197,10 @@
+ typedef unsigned int UINT2; /* unsigned 16 bits */
+ # define ABS4 labs /* abs function for long */
+ #else
+- typedef int int32;
+- typedef long long int64;
+- typedef unsigned int uint32;
+- typedef short int16;
++ typedef int32_t int32;
++ typedef int64_t int64;
++ typedef uint32_t uint32;
++ typedef int16_t int16;
+ typedef double REAL8; /* real with at least 64 bit precision */
+ typedef int INT4; /* signed integer with at least 32 bit precision */
+ typedef unsigned int UINT4;