aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/p5-Pod-Parser/Makefile4
-rw-r--r--textproc/p5-Pod-Parser/files/patch-Makefile.PL11
-rw-r--r--textproc/p5-PodParser/Makefile4
-rw-r--r--textproc/p5-PodParser/files/patch-Makefile.PL11
4 files changed, 26 insertions, 4 deletions
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index 18d4a2924eb3..861c0198138c 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -24,9 +24,9 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
MAN1PREFIX= ${PREFIX}
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
post-patch:
- ${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Parser/files/patch-Makefile.PL b/textproc/p5-Pod-Parser/files/patch-Makefile.PL
new file mode 100644
index 000000000000..94fb1e7dfb65
--- /dev/null
+++ b/textproc/p5-Pod-Parser/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Fri Aug 11 01:41:59 2000
++++ Makefile.PL Thu Sep 12 21:17:34 2002
+@@ -4,6 +4,8 @@
+ # you can redistribute it and/or modify it under the same terms
+ # as Perl itself.
+
++use Config;
++use lib $Config{installsitelib};
+ BEGIN {
+ require 5.005;
+ eval { require File::Spec };
diff --git a/textproc/p5-PodParser/Makefile b/textproc/p5-PodParser/Makefile
index 18d4a2924eb3..861c0198138c 100644
--- a/textproc/p5-PodParser/Makefile
+++ b/textproc/p5-PodParser/Makefile
@@ -24,9 +24,9 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
MAN1PREFIX= ${PREFIX}
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
post-patch:
- ${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
.include <bsd.port.mk>
diff --git a/textproc/p5-PodParser/files/patch-Makefile.PL b/textproc/p5-PodParser/files/patch-Makefile.PL
new file mode 100644
index 000000000000..94fb1e7dfb65
--- /dev/null
+++ b/textproc/p5-PodParser/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Fri Aug 11 01:41:59 2000
++++ Makefile.PL Thu Sep 12 21:17:34 2002
+@@ -4,6 +4,8 @@
+ # you can redistribute it and/or modify it under the same terms
+ # as Perl itself.
+
++use Config;
++use lib $Config{installsitelib};
+ BEGIN {
+ require 5.005;
+ eval { require File::Spec };