aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/denemo/Makefile3
-rw-r--r--audio/fluidsynth-dssi/Makefile4
-rw-r--r--audio/fluidsynth/Makefile70
-rw-r--r--audio/fluidsynth/distinfo4
-rw-r--r--audio/fluidsynth/files/patch-src__Makefile.in22
-rw-r--r--audio/fluidsynth/pkg-plist5
-rw-r--r--audio/lmms/Makefile4
-rw-r--r--audio/qsynth/Makefile2
-rw-r--r--audio/tuxguitar/Makefile4
-rw-r--r--multimedia/audacious-plugins/Makefile4
-rw-r--r--multimedia/gstreamer-plugins-buzztard/Makefile3
-rw-r--r--multimedia/vlc/Makefile4
12 files changed, 66 insertions, 63 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index ba8ce1d32c96..f4f700cbe6dd 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= denemo
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= GNU
@@ -15,7 +16,7 @@ COMMENT= Graphical score editor
BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
LIB_DEPENDS= aubio.3:${PORTSDIR}/audio/aubio \
- fluidsynth.4:${PORTSDIR}/audio/fluidsynth \
+ fluidsynth.1:${PORTSDIR}/audio/fluidsynth \
jack.0:${PORTSDIR}/audio/jack \
guile.21:${PORTSDIR}/lang/guile \
fftw3:${PORTSDIR}/math/fftw3 \
diff --git a/audio/fluidsynth-dssi/Makefile b/audio/fluidsynth-dssi/Makefile
index b16128343d55..d889629768bd 100644
--- a/audio/fluidsynth-dssi/Makefile
+++ b/audio/fluidsynth-dssi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fluidsynth-dssi
PORTVERSION= 1.0.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/dssi/${PORTNAME}/${PORTVERSION}
@@ -16,7 +16,7 @@ COMMENT= Wrapper for FluidSynth allowing it to function as a DSSI plugin
LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
lo.7:${PORTSDIR}/audio/liblo \
- fluidsynth.4:${PORTSDIR}/audio/fluidsynth \
+ fluidsynth.1:${PORTSDIR}/audio/fluidsynth \
jack.0:${PORTSDIR}/audio/jack
BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
index 4e73aca0ae3c..1ee3c6bd69ed 100644
--- a/audio/fluidsynth/Makefile
+++ b/audio/fluidsynth/Makefile
@@ -6,71 +6,95 @@
#
PORTNAME= fluidsynth
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.5
CATEGORIES= audio
-MASTER_SITES= SAVANNAH/fluid
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Real-time software synthesizer based on the SoundFont 2 specifications
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
+
OPTIONS= JACK "Enable Jack audio support" On \
+ ALSA "Enable ALSA audio support" Off \
+ DBUS "Enable D-Bus support" Off \
LADSPA "Enable LADSPA audio support" Off \
+ LASH "Enable LASH audio support" Off \
PORTAUDIO "Enable PortAudio support" Off \
PULSEAUDIO "Enable PulseAudio support" Off \
SNDFILE "Enable Libsndfile support" Off
-USE_GNOME= glib20 gnomehack pkgconfig
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --disable-alsa-support --disable-midishare \
- --disable-coreaudio --disable-coremidi \
- --disable-dart --disable-lash \
- --disable-ladcca
+USE_BZIP2= yes
+USE_GNOME= glib20 pkgconfig
+USE_CMAKE= yes
+CMAKE_ARGS= -Denable-ladcca:BOOL=FALSE \
+ -Denable-midishare:BOOL=FALSE
USE_LDCONFIG= yes
-MAN1= fluidsynth.1
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
-CPPFLAGS+= ${PA2_CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PA2_LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+MAN1= fluidsynth.1
.include <bsd.port.pre.mk>
.if defined(WITH_JACK)
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
.else
-CONFIGURE_ARGS+= --disable-jack-support
+CMAKE_ARGS+= -Denable-jack:BOOL=FALSE
+.endif
+
+.if defined(WITH_ALSA)
+LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+.else
+CMAKE_ARGS+= -Denable-alsa:BOOL=FALSE
+.endif
+
+.if defined(WITH_DBUS)
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+.else
+CMAKE_ARGS+= -Denable-dbus:BOOL=FALSE
.endif
.if defined(WITH_LADSPA)
BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
RUN_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-CONFIGURE_ARGS+= --enable-ladspa
+CMAKE_ARGS+= -Denable-ladspa:BOOL=TRUE
+.endif
+
+.if defined(WITH_LASH)
+LIB_DEPENDS+= lash:${PORTSDIR}/audio/lash
+.else
+CMAKE_ARGS+= -Denable-lash:BOOL=FALSE
.endif
.if defined(WITH_PORTAUDIO)
BUILD_DEPENDS+= ${LOCALBASE}/include/portaudio2/portaudio.h:${PORTSDIR}/audio/portaudio2
RUN_DEPENDS+= ${LOCALBASE}/include/portaudio2/portaudio.h:${PORTSDIR}/audio/portaudio2
-PA2_CFLAGS= `pkg-config --cflags-only-I portaudio-2.0`
-PA2_LIBS= `pkg-config --libs-only-L portaudio-2.0`
-.else
-CONFIGURE_ARGS+= --disable-portaudio-support
+CMAKE_ARGS+= -Denable-portaudio:BOOL=TRUE
.endif
.if defined(WITH_PULSEAUDIO)
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
.else
-CONFIGURE_ARGS+= --disable-pulse-support
+CMAKE_ARGS+= -Denable-pulseaudio:BOOL=FALSE
.endif
.if defined(WITH_SNDFILE)
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
.else
-CONFIGURE_ARGS+= --disable-libsndfile-support
+CMAKE_ARGS+= -Denable-libsndfile:BOOL=FALSE
.endif
post-patch:
- @${REINPLACE_CMD} -e 's| -O2 | |g ; \
- s|== "yes"|= "yes"|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '197 s/,/ /' ${WRKSRC}/include/fluidsynth/synth.h
+ @${REINPLACE_CMD} -e \
+ '/Linux/s|^|#| ; \
+ /_init_lib_suffix/s|"64"|""| ; \
+ /CMAKE_C_FLAGS_RELEASE/s|-O2|| ; \
+ s|enable_midishare|enable-midishare| ; \
+ s|$${LIB_INSTALL_DIR}$${LIB_SUFFIX}/pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's|share/man|man|' ${WRKSRC}/cmake_admin/DefaultDirs.cmake
.include <bsd.port.post.mk>
diff --git a/audio/fluidsynth/distinfo b/audio/fluidsynth/distinfo
index 175ccf96d136..c1edb1e7e8a1 100644
--- a/audio/fluidsynth/distinfo
+++ b/audio/fluidsynth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fluidsynth-1.1.1.tar.gz) = 55638cb04f39f4df76c081e22ca7feeea58ddd20ebf779a7db2d38b1ff374cd6
-SIZE (fluidsynth-1.1.1.tar.gz) = 756184
+SHA256 (fluidsynth-1.1.5.tar.bz2) = 44b40ee28f0ed1718c924d8a175e30381431edfb9320026480d56daf7351e3f4
+SIZE (fluidsynth-1.1.5.tar.bz2) = 800195
diff --git a/audio/fluidsynth/files/patch-src__Makefile.in b/audio/fluidsynth/files/patch-src__Makefile.in
deleted file mode 100644
index ec08afc27d51..000000000000
--- a/audio/fluidsynth/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/Makefile.in.orig 2009-10-31 04:23:15.000000000 +0900
-+++ src/Makefile.in 2009-11-03 15:44:55.000000000 +0900
-@@ -397,13 +397,15 @@
- fluid_filerenderer.c \
- fluid_aufile.c
-
--INCLUDES = -I$(top_srcdir)/include $(LASH_CFLAGS) $(LADCCA_CFLAGS) \
-+INCLUDES = -I$(top_srcdir)/include \
-+ $(PORTAUDIO_CFLAGS) $(LASH_CFLAGS) $(LADCCA_CFLAGS) \
- $(READLINE_CFLAGS) $(JACK_CFLAGS) $(ALSA_CFLAGS) $(PULSE_CFLAGS) \
-- $(PORTAUDIO_CFLAGS) $(DART_CFLAGS) $(GLIB_CFLAGS) $(LIBSNDFILE_CFLAGS)
-+ $(DART_CFLAGS) $(GLIB_CFLAGS) $(LIBSNDFILE_CFLAGS)
-
--libfluidsynth_la_LIBADD = $(LIBFLUID_LIBS) $(LASH_LIBS) $(LADCCA_LIBS) \
-+libfluidsynth_la_LIBADD = $(LIBFLUID_LIBS) \
-+ $(PORTAUDIO_LIBS) $(LASH_LIBS) $(LADCCA_LIBS) \
- $(READLINE_LIBS) $(COREAUDIO_LIBS) $(COREMIDI_LIBS) $(JACK_LIBS) \
-- $(ALSA_LIBS) $(PULSE_LIBS) $(PORTAUDIO_LIBS) $(DART_LIBS) \
-+ $(ALSA_LIBS) $(PULSE_LIBS) $(DART_LIBS) \
- $(GLIB_LIBS) $(LIBSNDFILE_LIBS)
-
- libfluidsynth_la_LDFLAGS = \
diff --git a/audio/fluidsynth/pkg-plist b/audio/fluidsynth/pkg-plist
index 29a8e1aa6ae7..53037850bdd7 100644
--- a/audio/fluidsynth/pkg-plist
+++ b/audio/fluidsynth/pkg-plist
@@ -17,9 +17,8 @@ include/fluidsynth/synth.h
include/fluidsynth/types.h
include/fluidsynth/version.h
include/fluidsynth/voice.h
-lib/libfluidsynth.a
-lib/libfluidsynth.la
lib/libfluidsynth.so
-lib/libfluidsynth.so.4
+lib/libfluidsynth.so.1
+lib/libfluidsynth.so.1.5.1
libdata/pkgconfig/fluidsynth.pc
@dirrm include/fluidsynth
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 724e2251dea2..81e6cb8cce63 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lmms
PORTVERSION= 0.4.6
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF
@@ -17,7 +17,7 @@ COMMENT= An all-in-one sequencer, drum machine, sampler and more
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
- fluidsynth.4:${PORTSDIR}/audio/fluidsynth \
+ fluidsynth.1:${PORTSDIR}/audio/fluidsynth \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
sndfile.1:${PORTSDIR}/audio/libsndfile \
vorbis.4:${PORTSDIR}/audio/libvorbis \
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index 9254af3dfdd3..f6d66388c8a9 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qsynth
PORTVERSION= 0.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
diff --git a/audio/tuxguitar/Makefile b/audio/tuxguitar/Makefile
index ff78d7d54667..7b9320cab8e7 100644
--- a/audio/tuxguitar/Makefile
+++ b/audio/tuxguitar/Makefile
@@ -8,7 +8,7 @@
PORTNAME= tuxguitar
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio java
MASTER_SITES= SF/${PORTNAME}/TuxGuitar/TuxGuitar-${PORTVERSION}:src \
${MASTER_SITE_LOCAL}/gahr/:fluid \
@@ -25,7 +25,7 @@ BUILD_DEPENDS= ${JAVALIBDIR}/swt-devel.jar:${PORTSDIR}/x11-toolkits/swt-devel \
${JAVALIBDIR}/itext.jar:${PORTSDIR}/devel/itext \
${JAVALIBDIR}/gervill.jar:${PORTSDIR}/audio/gervill
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= fluidsynth.4:${PORTSDIR}/audio/fluidsynth \
+LIB_DEPENDS= fluidsynth.1:${PORTSDIR}/audio/fluidsynth \
jack.0:${PORTSDIR}/audio/jack
MAKE_ENV+= PREFIX=${PREFIX} INSTALL_DOC_DIR=${DOCSDIR} \
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index f1715a5729cb..2608847079fd 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= audacious-plugins
PORTVERSION= 2.5.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
@@ -352,7 +352,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_AMIDI)
-LIB_DEPENDS+= fluidsynth.4:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS+= fluidsynth.1:${PORTSDIR}/audio/fluidsynth
CONFIGURE_ARGS+=--enable-amidiplug --enable-amidiplug-flsyn
PLIST_SUB+= AMIDIPLUGIN=""
.else
diff --git a/multimedia/gstreamer-plugins-buzztard/Makefile b/multimedia/gstreamer-plugins-buzztard/Makefile
index bf01595f79dd..21a85299c25e 100644
--- a/multimedia/gstreamer-plugins-buzztard/Makefile
+++ b/multimedia/gstreamer-plugins-buzztard/Makefile
@@ -7,6 +7,7 @@
PORTNAME= buzztard
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20gstreamer%20extensions/${PORTVERSION}
PKGNAMEPREFIX= gstreamer-plugins-
@@ -15,7 +16,7 @@ DISTNAME= gst-${PORTNAME}-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Buzztard gstreamer plugins
-LIB_DEPENDS= fluidsynth.4:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS= fluidsynth.1:${PORTSDIR}/audio/fluidsynth
USE_AUTOTOOLS= libtool
USE_GSTREAMER= yes
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index fbf6b5b640dc..2412ce289d22 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vlc
DISTVERSION= 1.1.11
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/ \
@@ -321,7 +321,7 @@ CONFIGURE_ARGS+=--enable-flac
.endif
.if defined(WITH_FLUID)
-LIB_DEPENDS+= fluidsynth.4:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS+= fluidsynth.1:${PORTSDIR}/audio/fluidsynth
CONFIGURE_ARGS+=--enable-fluidsynth
.else
CONFIGURE_ARGS+=--disable-fluidsynth