aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/e2fsprogs-libblkid/Makefile5
-rw-r--r--misc/e2fsprogs-libuuid/Makefile7
-rw-r--r--sysutils/e2fsprogs/Makefile4
-rw-r--r--sysutils/e2fsprogs/distinfo6
-rw-r--r--sysutils/e2fsprogs/files/patch-configure9
-rw-r--r--sysutils/e2fsprogs/files/patch-intl_Makefile.in25
-rw-r--r--sysutils/e2fsprogs/files/patch-misc_Makefile.in25
-rw-r--r--sysutils/e2fsprogs/files/patch-uuid-loop109
-rw-r--r--sysutils/e2fsprogs/files/patch-version.h8
9 files changed, 65 insertions, 133 deletions
diff --git a/misc/e2fsprogs-libblkid/Makefile b/misc/e2fsprogs-libblkid/Makefile
index 03045e65e283..bf677ae70cb2 100644
--- a/misc/e2fsprogs-libblkid/Makefile
+++ b/misc/e2fsprogs-libblkid/Makefile
@@ -19,6 +19,7 @@ CONFIGURE_ARGS= --enable-elf-shlibs
WITHOUT_NLS= yes
MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
MAKE_ARGS= LIB_SUBDIRS=lib/blkid
+USE_GMAKE= yes
USE_LDCONFIG= yes
ALL_TARGET= libs
INSTALL_TARGET= install install-shlibs
@@ -32,7 +33,7 @@ pre-build:
${MKDIR} ${WRKSRC}/lib/blkid/elfshared
post-build:
- cd ${WRKSRC}/lib/uuid && ${MAKE}
- cd ${INSTALL_WRKSRC} && ${MAKE} check
+ cd ${WRKSRC}/lib/uuid && ${GMAKE}
+ cd ${INSTALL_WRKSRC} && ${GMAKE} check
.include "${MASTERDIR}/Makefile"
diff --git a/misc/e2fsprogs-libuuid/Makefile b/misc/e2fsprogs-libuuid/Makefile
index 2b1179ea698b..d99af0db816f 100644
--- a/misc/e2fsprogs-libuuid/Makefile
+++ b/misc/e2fsprogs-libuuid/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= misc devel
PKGNAMESUFFIX= -libuuid
@@ -18,6 +18,7 @@ CONFIGURE_ARGS= --enable-elf-shlibs
WITHOUT_NLS= yes
MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
MAKE_ARGS= LIB_SUBDIRS=lib/uuid
+USE_GMAKE= yes
USE_LDCONFIG= yes
ALL_TARGET= libs
INSTALL_TARGET= install install-shlibs
@@ -47,8 +48,8 @@ pre-build:
# failure to launch uuidd is fine (one might be running, or we may lack
# privileges); if it works, it'll quit after 50 seconds
post-build:
- cd ${WRKSRC}/misc && ${MAKE} uuidgen uuidgen.1 uuidd uuidd.8
- ( ulimit -t 5 ; cd ${INSTALL_WRKSRC} && { ../../misc/uuidd -T50 || true ; ${MAKE} check ; } )
+ cd ${WRKSRC}/misc && ${GMAKE} uuidgen uuidgen.1 uuidd uuidd.8
+ cd ${INSTALL_WRKSRC} && ( ulimit -t 5 && ${GMAKE} check )
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/misc/uuidgen ${PREFIX}/bin/
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 1a4c09fa3a26..7a3da980f7af 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= e2fsprogs
-PORTVERSION= 1.41.5
+PORTVERSION= 1.41.8
PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -46,7 +46,7 @@ post-extract:
PKGDEINSTALL= ${PKGINSTALL}
-MAKE_JOBS=SAFE= yes
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
index fbaa99251b9b..eae5f7ef6ad9 100644
--- a/sysutils/e2fsprogs/distinfo
+++ b/sysutils/e2fsprogs/distinfo
@@ -1,3 +1,3 @@
-MD5 (e2fsprogs-1.41.5.tar.gz) = e218df6c84fc17c1126d31de9472a76c
-SHA256 (e2fsprogs-1.41.5.tar.gz) = b3d7d0e1058a3740ddae83d47285bd9dce161eec9e299dde7996ed721da32198
-SIZE (e2fsprogs-1.41.5.tar.gz) = 4415819
+MD5 (e2fsprogs-1.41.8.tar.gz) = 6708cc8e484809fc5cfb232882e48489
+SHA256 (e2fsprogs-1.41.8.tar.gz) = 782c9f281ca970d176c61759465beec12b40c7793bb5fa52c8d9a61741e33801
+SIZE (e2fsprogs-1.41.8.tar.gz) = 4436913
diff --git a/sysutils/e2fsprogs/files/patch-configure b/sysutils/e2fsprogs/files/patch-configure
index 095d4e54e476..7f0792aebceb 100644
--- a/sysutils/e2fsprogs/files/patch-configure
+++ b/sysutils/e2fsprogs/files/patch-configure
@@ -9,3 +9,12 @@
stdlib.h string.h unistd.h sys/param.h
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+@@ -16592,7 +16592,7 @@
+ lib/e2p/e2p.pc lib/blkid/blkid.pc lib/ext2fs/ext2fs.pc \
+ misc/Makefile ext2ed/Makefile e2fsck/Makefile \
+ debugfs/Makefile tests/Makefile tests/progs/Makefile \
+- resize/Makefile doc/Makefile intl/Makefile po/Makefile.in ; do
++ resize/Makefile doc/Makefile intl/Makefile intl/libgnuintl.h po/Makefile.in ; do
+ if test -d `dirname ${srcdir}/$i` ; then
+ outlist="$outlist $i"
+ fi
diff --git a/sysutils/e2fsprogs/files/patch-intl_Makefile.in b/sysutils/e2fsprogs/files/patch-intl_Makefile.in
new file mode 100644
index 000000000000..2dc7b72e2688
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-intl_Makefile.in
@@ -0,0 +1,25 @@
+--- ./intl/Makefile.in.orig 2009-07-02 04:46:40.000000000 +0200
++++ ./intl/Makefile.in 2009-07-15 16:36:29.000000000 +0200
+@@ -43,6 +43,22 @@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
++@SET_MAKE@
++
++@ifGNUmake@ V =
++@ifGNUmake@ ifeq ($(strip $(V)),)
++@ifGNUmake@ # E = @echo
++@ifGNUmake@ # Q = @
++@ifGNUmake@ E = @E@
++@ifGNUmake@ Q = @Q@
++@ifGNUmake@ else
++@ifGNUmake@ E = @\#
++@ifGNUmake@ Q =
++@ifGNUmake@ endif
++
++@ifNotGNUmake@ E = @E@
++@ifNotGNUmake@ Q = @Q@
++
+ l = @INTL_LIBTOOL_SUFFIX_PREFIX@
+
+ AR = ar
diff --git a/sysutils/e2fsprogs/files/patch-misc_Makefile.in b/sysutils/e2fsprogs/files/patch-misc_Makefile.in
index 17472088d46c..5d45b8a77a75 100644
--- a/sysutils/e2fsprogs/files/patch-misc_Makefile.in
+++ b/sysutils/e2fsprogs/files/patch-misc_Makefile.in
@@ -1,5 +1,5 @@
---- a/misc/Makefile.in.orig 2009-04-22 14:59:33.000000000 +0200
-+++ b/misc/Makefile.in 2009-04-24 09:47:25.000000000 +0200
+--- a/misc/Makefile.in.orig 2009-07-11 21:25:17.000000000 +0200
++++ b/misc/Makefile.in 2009-07-15 15:56:29.000000000 +0200
@@ -25,14 +25,14 @@
SPROGS= mke2fs badblocks tune2fs dumpe2fs $(BLKID_PROG) logsave \
@@ -12,18 +12,18 @@
+ logsave.8 e2undo.8 @FSCK_MAN@
FMANPAGES= mke2fs.conf.5
--UPROGS= chattr lsattr uuidgen
--UMANPAGES= chattr.1 lsattr.1 uuidgen.1
+-UPROGS= chattr lsattr @UUID_CMT@ uuidgen
+-UMANPAGES= chattr.1 lsattr.1 @UUID_CMT@ uuidgen.1
+UPROGS= chattr lsattr
+UMANPAGES= chattr.1 lsattr.1
LPROGS= @E2INITRD_PROG@
-@@ -456,35 +456,10 @@
+@@ -457,34 +457,9 @@
echo " INSTALL_DATA $(man5dir)/$$i"; \
$(INSTALL_DATA) $$i $(DESTDIR)$(man5dir)/$$i; \
done
-- @if test -f $(DESTDIR)$(root_sysconfdir)/mke2fs.conf; then \
+- $(Q) if test -f $(DESTDIR)$(root_sysconfdir)/mke2fs.conf; then \
- if cmp -s $(DESTDIR)$(root_sysconfdir)/mke2fs.conf \
- $(srcdir)/mke2fs.conf; then \
- true; \
@@ -48,14 +48,11 @@
- fi; \
- else \
- echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf"; \
-- $(INSTALL_DATA) $(srcdir)/mke2fs.conf \
++ $(Q) echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf"; \
+ $(INSTALL_DATA) $(srcdir)/mke2fs.conf \
- $(DESTDIR)$(root_sysconfdir)/mke2fs.conf; \
- fi
--
-+ echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf"; \
-+ $(INSTALL_DATA) $(srcdir)/mke2fs.conf \
-+ $(DESTDIR)$(root_sysconfdir)/mke2fs.conf.dist
-+
++ $(DESTDIR)$(root_sysconfdir)/mke2fs.conf.dist
+
install-strip: install
- @for i in $(SPROGS); do \
- echo " STRIP $(root_sbindir)/$$i"; \
+ $(Q) for i in $(SPROGS); do \
diff --git a/sysutils/e2fsprogs/files/patch-uuid-loop b/sysutils/e2fsprogs/files/patch-uuid-loop
deleted file mode 100644
index 2c5c7b4c7afe..000000000000
--- a/sysutils/e2fsprogs/files/patch-uuid-loop
+++ /dev/null
@@ -1,109 +0,0 @@
---- /dev/null
-+++ b/lib/read_all.h
-@@ -0,0 +1,32 @@
-+/*
-+ * read_all - a read variant that masks EAGAIN and EINTR.
-+ * This function tries hard to make sure to read the complete requested
-+ * length, and if it hits EOF while reading, it returns 0.
-+ *
-+ * Originally written by Theodore Y. Ts'o.
-+ * Factored out from misc/uuidd.c and lib/uuid/gen_uuid.c
-+ * and bugfixed by Matthias Andree, 2009.
-+ */
-+
-+ssize_t read_all(int fd, char *buf, size_t count)
-+{
-+ ssize_t ret;
-+ ssize_t c = 0;
-+
-+ memset(buf, 0, count);
-+ while (count > 0) {
-+ ret = read(fd, buf, count);
-+ if (ret == -1) {
-+ if ((errno == EAGAIN) || (errno == EINTR))
-+ continue;
-+ return -1;
-+ }
-+ if (ret == 0) {
-+ return c;
-+ }
-+ count -= ret;
-+ buf += ret;
-+ c += ret;
-+ }
-+ return c;
-+}
---- a/lib/uuid/Makefile.in
-+++ b/lib/uuid/Makefile.in
-@@ -190,7 +190,7 @@ clear.o: $(srcdir)/clear.c $(srcdir)/uuidP.h $(srcdir)/uuid.h
- compare.o: $(srcdir)/compare.c $(srcdir)/uuidP.h $(srcdir)/uuid.h
- copy.o: $(srcdir)/copy.c $(srcdir)/uuidP.h $(srcdir)/uuid.h
- gen_uuid.o: $(srcdir)/gen_uuid.c $(srcdir)/uuidP.h $(srcdir)/uuid.h \
-- $(srcdir)/uuidd.h
-+ $(srcdir)/uuidd.h $(top_srcdir)/lib/read_all.h
- isnull.o: $(srcdir)/isnull.c $(srcdir)/uuidP.h $(srcdir)/uuid.h
- pack.o: $(srcdir)/pack.c $(srcdir)/uuidP.h $(srcdir)/uuid.h
- parse.o: $(srcdir)/parse.c $(srcdir)/uuidP.h $(srcdir)/uuid.h
---- a/lib/uuid/gen_uuid.c
-+++ b/lib/uuid/gen_uuid.c
-@@ -415,25 +415,11 @@ try_again:
- return 0;
- }
-
--static ssize_t read_all(int fd, char *buf, size_t count)
--{
-- ssize_t ret;
-- ssize_t c = 0;
--
-- memset(buf, 0, count);
-- while (count > 0) {
-- ret = read(fd, buf, count);
-- if (ret < 0) {
-- if ((errno == EAGAIN) || (errno == EINTR))
-- continue;
-- return -1;
-- }
-- count -= ret;
-- buf += ret;
-- c += ret;
-- }
-- return c;
--}
-+/*
-+ * Import read_all function and make it static.
-+ */
-+static
-+#include "read_all.h"
-
- /*
- * Close all file descriptors
---- a/misc/uuidd.c
-+++ b/misc/uuidd.c
-@@ -85,25 +85,8 @@ static void create_daemon(void)
- die("setreuid");
- }
-
--static int read_all(int fd, char *buf, size_t count)
--{
-- ssize_t ret;
-- int c = 0;
--
-- memset(buf, 0, count);
-- while (count > 0) {
-- ret = read(fd, buf, count);
-- if (ret < 0) {
-- if ((errno == EAGAIN) || (errno == EINTR))
-- continue;
-- return -1;
-- }
-- count -= ret;
-- buf += ret;
-- c += ret;
-- }
-- return c;
--}
-+static
-+#include "read_all.h"
-
- static int write_all(int fd, char *buf, size_t count)
- {
diff --git a/sysutils/e2fsprogs/files/patch-version.h b/sysutils/e2fsprogs/files/patch-version.h
new file mode 100644
index 000000000000..fb1cee2685ee
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-version.h
@@ -0,0 +1,8 @@
+--- ./version.h~ 2009-07-11 23:24:37.000000000 +0200
++++ ./version.h 2009-07-15 16:47:11.000000000 +0200
+@@ -8,4 +8,4 @@
+ */
+
+ #define E2FSPROGS_VERSION "1.41.8"
+-#define E2FSPROGS_DATE "11-July-2009"
++#define E2FSPROGS_DATE "11-Jul-2009"