aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/cyrus-imapd23/Makefile1
-rw-r--r--mail/cyrus-imapd23/files/patch-imap::fetchnews.c37
-rw-r--r--mail/cyrus-imapd24/Makefile1
-rw-r--r--mail/cyrus-imapd24/files/patch-imap::fetchnews.c37
4 files changed, 74 insertions, 2 deletions
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 030ffc6bbc1a..189684fc9fe8 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -132,7 +132,6 @@ CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db${BDB_VER} \
--with-bdb=db${BDB_SUFFIX}
.if defined(WITH_NNTP)
-IGNORE= NNTP support is broken by the original distribution
CONFIGURE_ARGS+=--enable-nntp
PLIST_SUB+= NNTP=""
.else
diff --git a/mail/cyrus-imapd23/files/patch-imap::fetchnews.c b/mail/cyrus-imapd23/files/patch-imap::fetchnews.c
new file mode 100644
index 000000000000..4156a1e2eec6
--- /dev/null
+++ b/mail/cyrus-imapd23/files/patch-imap::fetchnews.c
@@ -0,0 +1,37 @@
+Index: imap/fetchnews.c
+diff -u -p imap/fetchnews.c.orig imap/fetchnews.c
+--- imap/fetchnews.c.orig Wed Mar 23 09:40:11 2005
++++ imap/fetchnews.c Fri Apr 14 23:36:14 2006
+@@ -60,6 +60,7 @@
+ #include "cyrusdb.h"
+ #include "exitcodes.h"
+ #include "global.h"
++#include "gmtoff.h"
+ #include "lock.h"
+ #include "prot.h"
+ #include "xmalloc.h"
+@@ -388,6 +389,7 @@ int main(int argc, char *argv[])
+ &ctime.tm_hour, &ctime.tm_min, &ctime.tm_sec);
+ ctime.tm_year -= 1900;
+ ctime.tm_mon--;
++ ctime.tm_isdst = -1;
+
+ /* read the previous timestamp */
+ if (!sfile[0]) {
+@@ -417,6 +419,7 @@ int main(int argc, char *argv[])
+ /* ask for new articles */
+ if (stamp) stamp -= 180; /* adjust back 3 minutes */
+ ptime = gmtime(&stamp);
++ ptime->tm_isdst = -1;
+ strftime(buf, sizeof(buf), datefmt, ptime);
+ prot_printf(pout, "NEWNEWS %s %s GMT\r\n", wildmat, buf);
+
+@@ -433,7 +436,7 @@ int main(int argc, char *argv[])
+ We can't change this, otherwise we'd be incompatible
+ with an old localtime timestamp.
+ */
+- stamp -= timezone;
++ stamp += gmtoff_of(&ctime, stamp);
+ }
+
+ if (!newnews) {
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 030ffc6bbc1a..189684fc9fe8 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -132,7 +132,6 @@ CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db${BDB_VER} \
--with-bdb=db${BDB_SUFFIX}
.if defined(WITH_NNTP)
-IGNORE= NNTP support is broken by the original distribution
CONFIGURE_ARGS+=--enable-nntp
PLIST_SUB+= NNTP=""
.else
diff --git a/mail/cyrus-imapd24/files/patch-imap::fetchnews.c b/mail/cyrus-imapd24/files/patch-imap::fetchnews.c
new file mode 100644
index 000000000000..4156a1e2eec6
--- /dev/null
+++ b/mail/cyrus-imapd24/files/patch-imap::fetchnews.c
@@ -0,0 +1,37 @@
+Index: imap/fetchnews.c
+diff -u -p imap/fetchnews.c.orig imap/fetchnews.c
+--- imap/fetchnews.c.orig Wed Mar 23 09:40:11 2005
++++ imap/fetchnews.c Fri Apr 14 23:36:14 2006
+@@ -60,6 +60,7 @@
+ #include "cyrusdb.h"
+ #include "exitcodes.h"
+ #include "global.h"
++#include "gmtoff.h"
+ #include "lock.h"
+ #include "prot.h"
+ #include "xmalloc.h"
+@@ -388,6 +389,7 @@ int main(int argc, char *argv[])
+ &ctime.tm_hour, &ctime.tm_min, &ctime.tm_sec);
+ ctime.tm_year -= 1900;
+ ctime.tm_mon--;
++ ctime.tm_isdst = -1;
+
+ /* read the previous timestamp */
+ if (!sfile[0]) {
+@@ -417,6 +419,7 @@ int main(int argc, char *argv[])
+ /* ask for new articles */
+ if (stamp) stamp -= 180; /* adjust back 3 minutes */
+ ptime = gmtime(&stamp);
++ ptime->tm_isdst = -1;
+ strftime(buf, sizeof(buf), datefmt, ptime);
+ prot_printf(pout, "NEWNEWS %s %s GMT\r\n", wildmat, buf);
+
+@@ -433,7 +436,7 @@ int main(int argc, char *argv[])
+ We can't change this, otherwise we'd be incompatible
+ with an old localtime timestamp.
+ */
+- stamp -= timezone;
++ stamp += gmtoff_of(&ctime, stamp);
+ }
+
+ if (!newnews) {