aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/gkleds2/Makefile26
-rw-r--r--sysutils/gkleds2/distinfo1
-rw-r--r--sysutils/gkleds2/files/patch-Makefile47
-rw-r--r--sysutils/gkleds2/pkg-descr9
-rw-r--r--sysutils/gkleds2/pkg-plist1
6 files changed, 85 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4d67bf9accb4..548d340c57e6 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -94,6 +94,7 @@
SUBDIR += gcombust
SUBDIR += gconf-editor
SUBDIR += gfslicer
+ SUBDIR += gkleds2
SUBDIR += gkrellflynn
SUBDIR += gkrellm
SUBDIR += gkrellm2
diff --git a/sysutils/gkleds2/Makefile b/sysutils/gkleds2/Makefile
new file mode 100644
index 000000000000..fab6f93348a6
--- /dev/null
+++ b/sysutils/gkleds2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gkleds2
+# Date Created: Dec 10 2002
+# Whom: Jan Stocker <Jan.Stocker@t-online.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkleds2
+PORTVERSION= 0.8.1
+CATEGORIES= sysutils
+MASTER_SITES= http://heim.ifi.uio.no/~oyvinha/files/files/
+DISTNAME= gkleds-${PORTVERSION}
+
+MAINTAINER= Jan.Stocker@t-online.de
+COMMENT= GKrellM Leds for CapsLock, NumLock and ScrollLock
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+MAKE_ENV+= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins \
+ INSTALL_PROG="${INSTALL_PROGRAM}"
+
+.include <bsd.port.mk>
diff --git a/sysutils/gkleds2/distinfo b/sysutils/gkleds2/distinfo
new file mode 100644
index 000000000000..d5f91b02703b
--- /dev/null
+++ b/sysutils/gkleds2/distinfo
@@ -0,0 +1 @@
+MD5 (gkleds-0.8.1.tar.gz) = 8329bc219c55f5b83c4dc5f097990d74
diff --git a/sysutils/gkleds2/files/patch-Makefile b/sysutils/gkleds2/files/patch-Makefile
new file mode 100644
index 000000000000..1833cfb3e18e
--- /dev/null
+++ b/sysutils/gkleds2/files/patch-Makefile
@@ -0,0 +1,47 @@
+$FreeBSD$
+
+--- Makefile.orig Tue Jan 28 17:14:08 2003
++++ Makefile Sun Jun 1 08:47:34 2003
+@@ -11,16 +11,14 @@
+ DEGUG = -DGKLEDS_DEBUG
+ LIBFLAGS = -shared
+ INCS = $(GTK_INCLUDES) -DGKLEDS_SELFCOMPILE
+-COMPFLAGS = -Wall -O2 -fPIC
+-CC = gcc
++COMPFLAGS = -Wall -fPIC ${CFLAGS}
++CC ?= gcc
+
+ SRCS = src/gkleds.c src/gkleds_ind.c src/gkleds_conf.c src/gkrellm2/win32-plugin.c
+ HDRS = src/gkleds.h src/gkleds_ind.c src/gkleds_conf.c src/gkrellm2/win32-plugin.h
+ WIN32_OBJS = gkleds.o gkleds_ind.o gkleds_conf.o win32-plugin.o
+ UNIX_OBJS = gkleds.o gkleds_ind.o gkleds_conf.o
+
+-INSTALL_PROG = install
+-
+ .PHONY : clean
+ .PHONY : install
+ .PHONY : uninstall
+@@ -29,7 +27,7 @@
+ #=======================================================================
+ #=======================================================================
+
+-unix : $(UNIX_OBJS)
++all : $(UNIX_OBJS)
+ $(CC) $(LIBFLAGS) $(UNIX_LIBS) -o gkleds.so $^
+
+ win32 : $(WIN32_OBJS)
+@@ -59,13 +57,4 @@
+ rm -rf src/gkrellm2/*~ src/gkrellm2/\#*
+
+ install : gkleds.so
+- @ if [ $$UID -ne 0 ]; \
+- then PLUGIN_DIR=$$HOME/.gkrellm2/plugins; \
+- elif [ -e /usr/bin/gkrellm ]; \
+- then PLUGIN_DIR=/usr/lib/gkrellm2/plugins; \
+- else \
+- PLUGIN_DIR=/usr/local/lib/gkrellm2/plugins; \
+- fi; \
+- $(INSTALL_PROG) -d $$PLUGIN_DIR; \
+- $(INSTALL_PROG) -s gkleds.so $$PLUGIN_DIR; \
+- printf "\ngkleds installed in $$PLUGIN_DIR\n"
++ $(INSTALL_PROG) gkleds.so $(PLUGIN_DIR);
diff --git a/sysutils/gkleds2/pkg-descr b/sysutils/gkleds2/pkg-descr
new file mode 100644
index 000000000000..959061c3b40c
--- /dev/null
+++ b/sysutils/gkleds2/pkg-descr
@@ -0,0 +1,9 @@
+gkleds is a GKrellM plugin which monitors the CapsLock, NumLock and
+ScrollLock keys and reports their current status via on-screen LEDs.
+This is useful for people who have keyboards without LEDs (typically
+cordless keyboards).
+
+Author: Oyvind Hagen <oyvinha@ifi.uio.no>
+WWW: http://www.stud.ifi.uio.no/~oyvinha/gkleds
+
+- Jan Stocker <Jan.Stocker@t-online.de>
diff --git a/sysutils/gkleds2/pkg-plist b/sysutils/gkleds2/pkg-plist
new file mode 100644
index 000000000000..67146acec5ce
--- /dev/null
+++ b/sysutils/gkleds2/pkg-plist
@@ -0,0 +1 @@
+libexec/gkrellm2/plugins/gkleds.so