aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/py-tldextract/Makefile22
-rw-r--r--dns/py-tldextract/distinfo2
-rw-r--r--dns/py-tldextract/pkg-descr4
3 files changed, 28 insertions, 0 deletions
diff --git a/dns/py-tldextract/Makefile b/dns/py-tldextract/Makefile
new file mode 100644
index 000000000000..c54bbf7d872e
--- /dev/null
+++ b/dns/py-tldextract/Makefile
@@ -0,0 +1,22 @@
+# Created by: Dan Langille <dvl@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tldextract
+PORTVERSION= 1.7.5
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Separate the TLD from the registered domain and subdomains of a URL
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}idna>=2.0:${PORTSDIR}/dns/py-idna
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/py-tldextract/distinfo b/dns/py-tldextract/distinfo
new file mode 100644
index 000000000000..746bd49b1f17
--- /dev/null
+++ b/dns/py-tldextract/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tldextract-1.7.5.tar.gz) = f01e6fbe872f0e9e5440a811ee33fbc562723dd1b4f239a8e9ef6f717b3392bd
+SIZE (tldextract-1.7.5.tar.gz) = 63860
diff --git a/dns/py-tldextract/pkg-descr b/dns/py-tldextract/pkg-descr
new file mode 100644
index 000000000000..57b908cafcd3
--- /dev/null
+++ b/dns/py-tldextract/pkg-descr
@@ -0,0 +1,4 @@
+Python module for separating the TLD from the registered domain and subdomains
+of a URL, using the Public Suffix List.
+
+WWW: https://github.com/john-kurkowski/tldextract