aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-rfc3987/Makefile20
-rw-r--r--www/py-rfc3987/distinfo2
-rw-r--r--www/py-rfc3987/pkg-descr9
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8af407346a6f..06db43b9ef86 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1674,6 +1674,7 @@
SUBDIR += py-requests-toolbelt
SUBDIR += py-requests1
SUBDIR += py-restclient
+ SUBDIR += py-rfc3987
SUBDIR += py-rhodecode
SUBDIR += py-routes
SUBDIR += py-satchmo
diff --git a/www/py-rfc3987/Makefile b/www/py-rfc3987/Makefile
new file mode 100644
index 000000000000..d8c1825eeb71
--- /dev/null
+++ b/www/py-rfc3987/Makefile
@@ -0,0 +1,20 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rfc3987
+PORTVERSION= 1.3.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}regex>0:${PORTSDIR}/textproc/py-regex
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-rfc3987/distinfo b/www/py-rfc3987/distinfo
new file mode 100644
index 000000000000..ae9d38aa0753
--- /dev/null
+++ b/www/py-rfc3987/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rfc3987-1.3.4.tar.gz) = 8bdd8bf28431bae754d34d60a23ca37aefa2cf8ade2de4a0e9d86e4a688b0c2e
+SIZE (rfc3987-1.3.4.tar.gz) = 7637
diff --git a/www/py-rfc3987/pkg-descr b/www/py-rfc3987/pkg-descr
new file mode 100644
index 000000000000..b181817f3e21
--- /dev/null
+++ b/www/py-rfc3987/pkg-descr
@@ -0,0 +1,9 @@
+This module provides regular expressions according to `RFC 3986 "Uniform
+Resource Identifier (URI): Generic Syntax" and `RFC 3987 "Internationalized
+Resource Identifiers (IRIs)" and utilities for composition and relative
+resolution of references.
+
+ * http://tools.ietf.org/html/rfc3986
+ * http://tools.ietf.org/html/rfc3987
+
+WWW: http://pypi.python.org/pypi/rfc3987