aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/mule-common/Makefile8
-rw-r--r--editors/mule/Makefile8
-rw-r--r--japanese/mule-canna/Makefile8
-rw-r--r--japanese/mule-freewnn/Makefile8
-rw-r--r--japanese/mule-wnn6/Makefile8
-rw-r--r--japanese/mule-wnn7/Makefile8
-rw-r--r--textproc/coco/Makefile8
7 files changed, 35 insertions, 21 deletions
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index b07b79651445..942146a025b7 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.21 1995/07/23 22:32:38 asami Exp $
+# $Id: Makefile,v 1.22 1995/09/15 01:41:22 asami Exp $
#
DISTNAME= mule-2.3
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cs.buffalo.edu/pub/mule/ \
MAINTAINER= asami@FreeBSD.ORG
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
STRIP=
@@ -31,8 +31,10 @@ post-install:
strip ${PREFIX}/bin/coco
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index b07b79651445..942146a025b7 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.21 1995/07/23 22:32:38 asami Exp $
+# $Id: Makefile,v 1.22 1995/09/15 01:41:22 asami Exp $
#
DISTNAME= mule-2.3
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cs.buffalo.edu/pub/mule/ \
MAINTAINER= asami@FreeBSD.ORG
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
STRIP=
@@ -31,8 +31,10 @@ post-install:
strip ${PREFIX}/bin/coco
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>
diff --git a/japanese/mule-canna/Makefile b/japanese/mule-canna/Makefile
index 81f41225c98c..ff219933d299 100644
--- a/japanese/mule-canna/Makefile
+++ b/japanese/mule-canna/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.21 1995/07/23 22:32:43 asami Exp $
+# $Id: Makefile,v 1.22 1995/08/08 10:04:43 asami Exp $
#
DISTNAME= mule-2.3
@@ -18,9 +18,9 @@ MAINTAINER= asami@FreeBSD.ORG
LIB_DEPENDS= canna\\.1\\.:${PORTSDIR}/japanese/Canna
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--canna --canna-libraries=/usr/local/lib \
--canna-includes=/usr/local/canna/include --terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
@@ -37,10 +37,12 @@ post-install:
strip ${PREFIX}/bin/etags
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/ctags.1
gzip -9nf ${PREFIX}/man/man1/etags.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>
diff --git a/japanese/mule-freewnn/Makefile b/japanese/mule-freewnn/Makefile
index dff8298a624f..cb3baa4f41c5 100644
--- a/japanese/mule-freewnn/Makefile
+++ b/japanese/mule-freewnn/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.22 1995/07/28 23:46:43 asami Exp $
+# $Id: Makefile,v 1.23 1995/10/11 00:31:49 asami Exp $
#
DISTNAME= mule-2.3
@@ -18,9 +18,9 @@ MAINTAINER= asami@FreeBSD.ORG
BUILD_DEPENDS= ${PREFIX}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--with-wnn4 --wnn-libraries=/usr/X11R6/lib \
--wnn-includes=/usr/X11R6/include/wnn --terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
@@ -37,10 +37,12 @@ post-install:
strip ${PREFIX}/bin/etags
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/ctags.1
gzip -9nf ${PREFIX}/man/man1/etags.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>
diff --git a/japanese/mule-wnn6/Makefile b/japanese/mule-wnn6/Makefile
index dff8298a624f..cb3baa4f41c5 100644
--- a/japanese/mule-wnn6/Makefile
+++ b/japanese/mule-wnn6/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.22 1995/07/28 23:46:43 asami Exp $
+# $Id: Makefile,v 1.23 1995/10/11 00:31:49 asami Exp $
#
DISTNAME= mule-2.3
@@ -18,9 +18,9 @@ MAINTAINER= asami@FreeBSD.ORG
BUILD_DEPENDS= ${PREFIX}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--with-wnn4 --wnn-libraries=/usr/X11R6/lib \
--wnn-includes=/usr/X11R6/include/wnn --terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
@@ -37,10 +37,12 @@ post-install:
strip ${PREFIX}/bin/etags
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/ctags.1
gzip -9nf ${PREFIX}/man/man1/etags.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>
diff --git a/japanese/mule-wnn7/Makefile b/japanese/mule-wnn7/Makefile
index dff8298a624f..cb3baa4f41c5 100644
--- a/japanese/mule-wnn7/Makefile
+++ b/japanese/mule-wnn7/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.22 1995/07/28 23:46:43 asami Exp $
+# $Id: Makefile,v 1.23 1995/10/11 00:31:49 asami Exp $
#
DISTNAME= mule-2.3
@@ -18,9 +18,9 @@ MAINTAINER= asami@FreeBSD.ORG
BUILD_DEPENDS= ${PREFIX}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--with-wnn4 --wnn-libraries=/usr/X11R6/lib \
--wnn-includes=/usr/X11R6/include/wnn --terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
@@ -37,10 +37,12 @@ post-install:
strip ${PREFIX}/bin/etags
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/ctags.1
gzip -9nf ${PREFIX}/man/man1/etags.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
index b07b79651445..942146a025b7 100644
--- a/textproc/coco/Makefile
+++ b/textproc/coco/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.21 1995/07/23 22:32:38 asami Exp $
+# $Id: Makefile,v 1.22 1995/09/15 01:41:22 asami Exp $
#
DISTNAME= mule-2.3
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cs.buffalo.edu/pub/mule/ \
MAINTAINER= asami@FreeBSD.ORG
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
--terminal-face \
--locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
STRIP=
@@ -31,8 +31,10 @@ post-install:
strip ${PREFIX}/bin/coco
strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
.include <bsd.port.mk>