aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/libgtksourceviewmm/Makefile5
-rw-r--r--x11-wm/ccsm/Makefile4
-rw-r--r--x11-wm/compiz/Makefile5
-rw-r--r--x11-wm/compizconfig-backend-gconf/Makefile4
-rw-r--r--x11-wm/compizconfig-python/Makefile4
-rw-r--r--x11-wm/evilwm/Makefile2
-rw-r--r--x11-wm/fbcmd/Makefile3
-rw-r--r--x11-wm/fvwm-crystal/Makefile3
-rw-r--r--x11-wm/hackedbox/Makefile1
-rw-r--r--x11-wm/ion/Makefile2
-rw-r--r--x11-wm/pwm/Makefile2
11 files changed, 10 insertions, 25 deletions
diff --git a/x11-toolkits/libgtksourceviewmm/Makefile b/x11-toolkits/libgtksourceviewmm/Makefile
index 9b110ddcef06..06ae447c0b2f 100644
--- a/x11-toolkits/libgtksourceviewmm/Makefile
+++ b/x11-toolkits/libgtksourceviewmm/Makefile
@@ -13,17 +13,14 @@ COMMENT= C++ binding of GtkSourceView
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
-USES= pkgconfig
+USES= pkgconfig gmake tar:bzip2
USE_LDCONFIG= yes
-USE_BZIP2= yes
USE_GNOME= gtksourceview2 gnomeprefix gnomehack
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBAS}/lib
CONFIGURE_ARGS= --disable-docs
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/gtksourceview/gtksourceviewmm/sourceiter.cc \
diff --git a/x11-wm/ccsm/Makefile b/x11-wm/ccsm/Makefile
index 113d5dbdb42c..f5a74d97ea8e 100644
--- a/x11-wm/ccsm/Makefile
+++ b/x11-wm/ccsm/Makefile
@@ -12,9 +12,7 @@ COMMENT= A Python/GTK based settings manager for CompizConfig
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compizconfig-python.pc:${PORTSDIR}/x11-wm/compizconfig-python
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake tar:bzip2
USE_GNOME= pygtk2
USE_PYTHON= 2
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 9d63af8d4873..30f0e5ea3b43 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -17,10 +17,7 @@ RUN_DEPENDS= glxinfo:${PORTSDIR}/graphics/mesa-demos \
XORG_CAT= app
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-#USE_TGZ= yes
-USE_GMAKE= yes
-USES= gettext pathfix
+USES= gettext pathfix gmake tar:bzip2
USE_GL= glu
USE_GNOME= gconf2 libxslt
USE_XORG= xcomposite xfixes xdamage xrandr xrender ice sm xinerama glproto
diff --git a/x11-wm/compizconfig-backend-gconf/Makefile b/x11-wm/compizconfig-backend-gconf/Makefile
index 326b8839c155..4f105bf17459 100644
--- a/x11-wm/compizconfig-backend-gconf/Makefile
+++ b/x11-wm/compizconfig-backend-gconf/Makefile
@@ -13,13 +13,11 @@ COMMENT= The gconf backend for CompizConfig
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz
LIB_DEPENDS= compizconfig.0:${PORTSDIR}/x11-wm/libcompizconfig
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake tar:bzip2
USE_GNOME= glib20 gconf2
NO_STAGE= yes
diff --git a/x11-wm/compizconfig-python/Makefile b/x11-wm/compizconfig-python/Makefile
index 0534b2aff88d..c59fb695e6fa 100644
--- a/x11-wm/compizconfig-python/Makefile
+++ b/x11-wm/compizconfig-python/Makefile
@@ -16,11 +16,9 @@ BUILD_DEPENDS= \
${PYTHON_SITELIBDIR}/Pyrex/Distutils/__init__.py:${PORTSDIR}/devel/pyrex
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_PYTHON= 2
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake tar:bzip2
USE_GNOME= glib20
USE_AUTOTOOLS= libtool
diff --git a/x11-wm/evilwm/Makefile b/x11-wm/evilwm/Makefile
index 52296519164b..ccc69c43ed7e 100644
--- a/x11-wm/evilwm/Makefile
+++ b/x11-wm/evilwm/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.6809.org.uk/evilwm/
MAINTAINER= lasg@lasg.dk
COMMENT= Minimalist window manager based on 9wm
-USE_GMAKE= yes
+USES= gmake
USE_XORG= x11 xpm xext xrandr xrender
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/x11-wm/fbcmd/Makefile b/x11-wm/fbcmd/Makefile
index ee72ec97a2a9..d7539cde66c8 100644
--- a/x11-wm/fbcmd/Makefile
+++ b/x11-wm/fbcmd/Makefile
@@ -12,8 +12,7 @@ COMMENT= A commandline utility for controlling fluxbox
RUN_DEPENDS= fluxbox:${PORTSDIR}/x11-wm/fluxbox
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
ALL_TARGET= first
CFLAGS+= "-I${LOCALBASE}/include"
diff --git a/x11-wm/fvwm-crystal/Makefile b/x11-wm/fvwm-crystal/Makefile
index 9265442c8edb..0e318ef3fa6b 100644
--- a/x11-wm/fvwm-crystal/Makefile
+++ b/x11-wm/fvwm-crystal/Makefile
@@ -13,8 +13,7 @@ COMMENT= Easy, eye-candy, light, and powerful window manager for X11
RUN_DEPENDS= fvwm>=2.5:${PORTSDIR}/x11-wm/fvwm2 \
bash:${PORTSDIR}/shells/bash
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake
USE_PYTHON= yes
MAKE_ENV= prefix="${PREFIX}" addondir="${DOCSDIR}/addons"
PORTDOCS= *
diff --git a/x11-wm/hackedbox/Makefile b/x11-wm/hackedbox/Makefile
index 57cf2258e80d..da406a46d90e 100644
--- a/x11-wm/hackedbox/Makefile
+++ b/x11-wm/hackedbox/Makefile
@@ -23,7 +23,6 @@ STYLES= artwiz bluebox cthulhain deep flux frobozz frobust nyz \
nyzclone operation outcomes shade steelblue \
steelblue2 the_orange trisb twice
PLIST= ${WRKDIR}/pkg-plist
-#USE_GMAKE= yes
USE_XORG= x11 xext xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-bg-utils
diff --git a/x11-wm/ion/Makefile b/x11-wm/ion/Makefile
index c1942385382e..1f564159e1ad 100644
--- a/x11-wm/ion/Makefile
+++ b/x11-wm/ion/Makefile
@@ -15,7 +15,7 @@ CONFLICTS= ion-2-*
MAN1= ion.1x
USE_XORG= x11
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11-wm/pwm/Makefile b/x11-wm/pwm/Makefile
index 01827d05de51..96c6ca72f947 100644
--- a/x11-wm/pwm/Makefile
+++ b/x11-wm/pwm/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= schot@a-eskwadraat.nl
COMMENT= A lightweight window manager with emphasis on usability
USE_XORG= x11
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= X11_PREFIX="${LOCALBASE}" HAS_SYSTEM_ASPRINTF=1
MAN1= pwm.1x