aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/qemu-devel/Makefile3
-rw-r--r--emulators/qemu-powernv/Makefile4
-rw-r--r--emulators/qemu-sbruno/Makefile3
-rw-r--r--emulators/qemu/Makefile5
-rw-r--r--emulators/qemu30/Makefile5
5 files changed, 9 insertions, 11 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 81a2c4700f80..4a5154f4441b 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= libnettle.so:security/nettle \
libepoxy.so:graphics/libepoxy \
libpcre2-8.so:devel/pcre2
-USES= bison cpe gmake gnome iconv:wchar_t perl5 pkgconfig python:build tar:xz xorg
+USES= bison compiler:c11 cpe gmake gnome iconv:wchar_t perl5 \
+ pkgconfig python:build tar:xz xorg
USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
USE_XORG= pixman
diff --git a/emulators/qemu-powernv/Makefile b/emulators/qemu-powernv/Makefile
index dcb466ea97c6..150238f7c295 100644
--- a/emulators/qemu-powernv/Makefile
+++ b/emulators/qemu-powernv/Makefile
@@ -13,8 +13,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libfdt.so:sysutils/dtc
-USES= bison:build gmake gnome libtool makeinfo pkgconfig \
- python:2.7,build tar:bz2
+USES= bison:build compiler:c11 gmake gnome libtool makeinfo \
+ pkgconfig python:2.7,build tar:bz2
USE_XORG= pixman
USE_GNOME= glib20
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index 26e029f9e48f..93519ff2d96d 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -15,13 +15,12 @@ USE_GITHUB= yes
GH_TUPLE= seanbruno:qemu-bsd-user:7b21781 \
qemu:keycodemapdb:10739aa:keycodemapdb/ui/keycodemapdb
HAS_CONFIGURE= yes
-USES= gmake pkgconfig bison perl5 python:2.7,build
+USES= bison compiler:c11 gmake perl5 pkgconfig python:2.7,build
USE_PERL5= build
MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
ONLY_FOR_ARCHS= amd64 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
BROKEN_i386= aarch64 system target is currently broken for i386 hosts, disable for now while dealing with upstream
-BROKEN_powerpc64= fails to build: async.c: internal compiler error: Segmentation fault
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR X86_TARGETS BSD_USER \
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index df2bb6e61e1c..f49e4b75f25e 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -12,8 +12,6 @@ COMMENT?= QEMU CPU Emulator
LICENSE= GPLv2
-BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
-
LIB_DEPENDS?= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
@@ -25,7 +23,8 @@ USE_XORG= pixman
USE_GNOME+= cairo glib20 libxml2
.endif
-USES?= cpe gmake gnome pkgconfig bison perl5 python:build tar:xz
+USES?= compiler:c11 cpe gmake gnome pkgconfig bison perl5 \
+ python:build tar:xz
USE_PERL5= build
PORTSCOUT= limit:^3\.0\.
diff --git a/emulators/qemu30/Makefile b/emulators/qemu30/Makefile
index 06e29422fc51..e799be47579a 100644
--- a/emulators/qemu30/Makefile
+++ b/emulators/qemu30/Makefile
@@ -13,13 +13,12 @@ COMMENT?= QEMU CPU Emulator
LICENSE= GPLv2
-BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
-
LIB_DEPENDS?= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES?= cpe gmake gnome pkgconfig bison perl5 python:build tar:xz
+USES?= compiler:c11 cpe gmake gnome pkgconfig bison perl5 python:build \
+ tar:xz
USE_PERL5= build
PORTSCOUT= limit:^3\.0\.