aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/dact/Makefile2
-rw-r--r--comms/ncid/Makefile8
-rw-r--r--databases/phppgadmin/Makefile4
-rw-r--r--deskutils/plans/Makefile8
-rw-r--r--devel/pear/Makefile2
-rw-r--r--ftp/proftpd/Makefile6
-rw-r--r--games/mangos/Makefile8
-rw-r--r--irc/darkbot/Makefile4
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php52/Makefile2
-rw-r--r--lang/php53/Makefile2
-rw-r--r--mail/postfixadmin/Makefile2
-rw-r--r--net-im/jggtrans/Makefile7
-rw-r--r--net-mgmt/xymon-client/Makefile2
-rw-r--r--net-mgmt/xymon-server/Makefile2
-rw-r--r--net/relayd/Makefile2
-rw-r--r--net/ushare/Makefile2
-rw-r--r--security/sancp/Makefile2
-rw-r--r--textproc/pootle/Makefile2
-rw-r--r--www/c-icap-modules/Makefile6
-rw-r--r--www/c-icap/Makefile10
-rw-r--r--x11/xdm/Makefile2
22 files changed, 34 insertions, 53 deletions
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index be5987d0676f..bd0d9cc32439 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -39,7 +39,7 @@ pre-install:
post-install:
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- ${CP} -n ${WRKSRC}/dact.conf ${EXAMPLESDIR}
+ ${CP} -n ${WRKSRC}/dact.conf ${EXAMPLESDIR} || ${TRUE}
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/comms/ncid/Makefile b/comms/ncid/Makefile
index 367633203c0a..c83afc293008 100644
--- a/comms/ncid/Makefile
+++ b/comms/ncid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ncid
-# Date created: 06 June 2005
-# Whom: David
-#
+# Created by: David
# $FreeBSD$
-#
PORTNAME= ncid
PORTVERSION= 0.84
@@ -53,7 +49,7 @@ post-install:
@cd ${WRKSRC};for i in server/*.alias scripts/*.conf;do\
ib=`basename $$i`;\
${INSTALL_DATA} $$i ${ETCDIR}/$$ib.dist;\
- ${CP} -n ${ETCDIR}/$$ib.dist ${ETCDIR}/$$ib;\
+ ${CP} -n ${ETCDIR}/$$ib.dist ${ETCDIR}/$$ib || ${TRUE} ;\
${ECHO_CMD} "@unexec cd %D/${ETCDIR_REL}/;! cmp -s $$ib $$ib.dist||\
${RM} -f $$ib">>${TMPPLIST};\
${ECHO_CMD} "${ETCDIR_REL}/$$ib.dist">>${TMPPLIST};\
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index 91d6b703058e..9cbea2022f1b 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -40,9 +40,9 @@ do-install:
${CP} -Rp ${WRKSRC}/ ${PREFIX}/${PGADMDIR}/
.if exists(${PREFIX}/${PGADMOLDDIR}/conf/config.inc.php)
${CP} -np ${PREFIX}/${PGADMOLDDIR}/conf/config.inc.php \
- ${PREFIX}/${PGADMDIR}/conf/config.inc.php
+ ${PREFIX}/${PGADMDIR}/conf/config.inc.php || ${TRUE}
.endif
${CP} -np ${PREFIX}/${PGADMDIR}/conf/config.inc.php-dist \
- ${PREFIX}/${PGADMDIR}/conf/config.inc.php
+ ${PREFIX}/${PGADMDIR}/conf/config.inc.php || ${TRUE}
.include <bsd.port.post.mk>
diff --git a/deskutils/plans/Makefile b/deskutils/plans/Makefile
index 37a5950c18ad..b098a976a012 100644
--- a/deskutils/plans/Makefile
+++ b/deskutils/plans/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: plans
-# Date created: 2004-12-17
-# Whom: Edwin Groothuis <edwin@mavetju.org>
-#
+# Created by: Edwin Groothuis <edwin@mavetju.org>
# $FreeBSD$
-#
PORTNAME= plans
PORTVERSION= 8.2.1
@@ -62,7 +58,7 @@ do-install:
@${FIND} ${WWWDIR} -name '*.cgi' -exec ${CHMOD} 755 {} \;
@${FIND} ${WWWDIR} -name '*.xml' -exec ${CHMOD} 664 {} \;
@for i in ${WWWDIR}/data/*default ${WWWDIR}/*default; do\
- ${CP} -np $$i $${i%.default}; done
+ ${CP} -np $$i $${i%.default} || ${TRUE} ; done
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
index c320f6fb0860..071ac83d444b 100644
--- a/devel/pear/Makefile
+++ b/devel/pear/Makefile
@@ -38,6 +38,6 @@ do-install:
${PEARDIR}/peclcmd.php
post-install:
- @${CP} -n ${PREFIX}/etc/pear.conf.sample ${PREFIX}/etc/pear.conf
+ @${CP} -n ${PREFIX}/etc/pear.conf.sample ${PREFIX}/etc/pear.conf || ${TRUE}
.include <bsd.port.mk>
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 97e76d2d1cb7..6d120a493375 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -247,10 +247,10 @@ pre-build:
@cd ${WRKSRC} && ${MAKE} include/buildstamp.h
.else
post-install:
- @cd ${PREFIX}/etc/ && ${CP} -n proftpd.conf.sample proftpd.conf
+ @cd ${PREFIX}/etc/ && ${CP} -n proftpd.conf.sample proftpd.conf || ${TRUE}
@${MKDIR} ${LOCALSTATEDIR}/proftpd
- @cd ${PREFIX}/etc/proftpd && ${CP} -n dhparams.pem.sample dhparams.pem
- @cd ${PREFIX}/etc/proftpd && ${CP} -n blacklist.dat.sample blacklist.dat
+ @cd ${PREFIX}/etc/proftpd && ${CP} -n dhparams.pem.sample dhparams.pem || ${TRUE}
+ @cd ${PREFIX}/etc/proftpd && ${CP} -n blacklist.dat.sample blacklist.dat || ${TRUE}
.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}
@cd ${WRKSRC} && ${CP} README* RELEASE_NOTES ${DOCSDIR}
diff --git a/games/mangos/Makefile b/games/mangos/Makefile
index 67adfcdb44b0..2a6922903ffd 100644
--- a/games/mangos/Makefile
+++ b/games/mangos/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mangos
-# Date created: 15 March 2007
-# Whom: Artemiy Kropachev <neon_cyrex@mail.ru>
-#
+# Created by: Artemiy Kropachev <neon_cyrex@mail.ru>
# $FreeBSD$
-#
PORTNAME= mangos
PORTVERSION= 5101
@@ -89,7 +85,7 @@ post-build:
post-install:
@for i in mangosd realmd;do cd ${PREFIX}/etc/&&\
${INSTALL_DATA} ${WRKSRC}/src/$$i/$$i.conf $$i.conf.sample&&\
- ${CP} -np $$i.conf.sample $$i.conf;done
+ ${CP} -np $$i.conf.sample $$i.conf || ${TRUE} ;done
.ifdef WITH_SCRIPTDEV2
@(cd ${INSTALL_WRKSRC}/src/bindings/ScriptDev2 && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endif
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
index 38b7253d7549..a253489c6620 100644
--- a/irc/darkbot/Makefile
+++ b/irc/darkbot/Makefile
@@ -35,12 +35,12 @@ post-install:
cd ${WRKSRC}/dat; \
for file in *; do \
${INSTALL_DATA} $$file ${ETCDIR}/dat/$${file}.dist; \
- ${CP} -np ${ETCDIR}/dat/$${file}.dist ${ETCDIR}/dat/$$file; \
+ ${CP} -np ${ETCDIR}/dat/$${file}.dist ${ETCDIR}/dat/$$file || ${TRUE} ; \
${ECHO_CMD} "@unexec cmp -s ${ETCDIR}/dat/$$file \
${ETCDIR}/dat/$${file}.dist && \
rm -f ${ETCDIR}/dat/$$file || true" >> ${TMPPLIST}; \
${ECHO_CMD} "${ETCDIR_REL}/dat/$${file}.dist" >> ${TMPPLIST}; \
- ${ECHO_CMD} "@exec cp -np %D/%F %B/$$file" >> ${TMPPLIST}; \
+ ${ECHO_CMD} "@exec cp -np %D/%F %B/$$file || true" >> ${TMPPLIST}; \
done
${ECHO_CMD} "@unexec rmdir ${ETCDIR}/logs 2>/dev/null || true" >> ${TMPPLIST}
${ECHO_CMD} "@unexec rmdir ${ETCDIR}/dat 2>/dev/null || true" >> ${TMPPLIST}
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index a6c47724232a..80665e19fe8e 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -195,7 +195,7 @@ post-install:
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
@${TOUCH} ${PREFIX}/include/php/ext/php_config.h
.if ${PORT_OPTIONS:MFPM}
- @${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf
+ @${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf || ${TRUE}
.endif
.if ${PORT_OPTIONS:MAPACHE}
@${CAT} ${PKGMESSAGE}
diff --git a/lang/php52/Makefile b/lang/php52/Makefile
index d34b2ef8d7a1..c5ed6752d336 100644
--- a/lang/php52/Makefile
+++ b/lang/php52/Makefile
@@ -216,7 +216,7 @@ post-install:
@${INSTALL_DATA} ${WRKDIR}/php-fpm.conf.sample ${PREFIX}/etc
@${MKDIR} `dirname ${PHP_FPM_PID}`
@${MKDIR} `dirname ${PHP_FPM_LOG}`
- @cd ${PREFIX}/etc && ${CP} -n php-fpm.conf.sample php-fpm.conf
+ @cd ${PREFIX}/etc && ${CP} -n php-fpm.conf.sample php-fpm.conf || ${TRUE}
.endif
.if defined(WITH_APACHE)
@${CAT} ${PKGMESSAGE}
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index c4e8a6925072..ceef43a79e86 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -185,7 +185,7 @@ post-install:
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
@${TOUCH} ${PREFIX}/include/php/ext/php_config.h
.if ${PORT_OPTIONS:MFPM}
- @${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf
+ @${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf || ${TRUE}
.endif
.if ${PORT_OPTIONS:MAPACHE}
@${CAT} ${PKGMESSAGE}
diff --git a/mail/postfixadmin/Makefile b/mail/postfixadmin/Makefile
index fe7e15b03155..910d779c7618 100644
--- a/mail/postfixadmin/Makefile
+++ b/mail/postfixadmin/Makefile
@@ -60,7 +60,7 @@ do-install:
(cd ${WRKSRC}/ && \
${COPYTREE_SHARE} \*.php ${PREFIX}/www/postfixadmin "! -name config.inc.php")
@${CP} ${WRKSRC}/config.inc.php ${PREFIX}/www/postfixadmin/config.inc.php.sample
- @${CP} -n ${WRKSRC}/config.inc.php ${PREFIX}/www/postfixadmin/config.inc.php
+ @${CP} -n ${WRKSRC}/config.inc.php ${PREFIX}/www/postfixadmin/config.inc.php || ${TRUE}
@${INSTALL_DATA} ${WRKSRC}/*.txt ${PREFIX}/www/postfixadmin
@${INSTALL_DATA} ${WRKSRC}/*.TXT ${PREFIX}/www/postfixadmin
@${INSTALL_DATA} ${WRKSRC}/css/* ${PREFIX}/www/postfixadmin/css
diff --git a/net-im/jggtrans/Makefile b/net-im/jggtrans/Makefile
index 345b1c19d8d0..92d5385f771d 100644
--- a/net-im/jggtrans/Makefile
+++ b/net-im/jggtrans/Makefile
@@ -1,7 +1,4 @@
-# Ports collection makefile for: jggtrans
-# Date created: 13 September 2006
-# Whom: Bartek Rutkowski <r@robakdesign.com>
-#
+# Created by: Bartek Rutkowski <r@robakdesign.com>
# $FreeBSD$
PORTNAME= jggtrans
@@ -49,7 +46,7 @@ SUB_LIST+= JABBER_USER=${JABBER_USER}
post-install:
@${INSTALL_DATA} ${WRKSRC}/jggtrans.xml ${PREFIX}/etc/jggtrans.xml.sample
- @${CP} -n ${WRKSRC}/jggtrans.xml ${PREFIX}/etc/jggtrans.xml
+ @${CP} -n ${WRKSRC}/jggtrans.xml ${PREFIX}/etc/jggtrans.xml || ${TRUE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/net-mgmt/xymon-client/Makefile b/net-mgmt/xymon-client/Makefile
index 23f733b956bb..e5013f21ce0f 100644
--- a/net-mgmt/xymon-client/Makefile
+++ b/net-mgmt/xymon-client/Makefile
@@ -35,7 +35,7 @@ do-configure:
post-install:
.for i in ${CONFIG_FILES}
${CP} -np ${WWWDIR}/client/etc/${i}.DIST \
- ${WWWDIR}/client/etc/${i}
+ ${WWWDIR}/client/etc/${i} || ${TRUE}
.endfor
.include <bsd.port.mk>
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index e2a69b13662d..9072959437f3 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -101,7 +101,7 @@ post-install:
.endfor
.for i in ${CONFIG_FILES}
${CP} -np ${WWWDIR}/server/etc/${i}.DIST \
- ${WWWDIR}/server/etc/${i}
+ ${WWWDIR}/server/etc/${i} || ${TRUE}
.endfor
.include <bsd.port.mk>
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index 1d899d5e4125..10eae269f469 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -58,6 +58,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/../etc/relayd.conf \
${PREFIX}/etc/relayd.conf.sample
@${CP} -n ${PREFIX}/etc/relayd.conf.sample \
- ${PREFIX}/etc/relayd.conf
+ ${PREFIX}/etc/relayd.conf || ${TRUE}
.include <bsd.port.post.mk>
diff --git a/net/ushare/Makefile b/net/ushare/Makefile
index 2145fbefa78c..7901a1fe3fa2 100644
--- a/net/ushare/Makefile
+++ b/net/ushare/Makefile
@@ -42,6 +42,6 @@ do-install:
post-install:
${CP} -np ${PREFIX}/etc/${PORTNAME}.conf.sample \
- ${PREFIX}/etc/${PORTNAME}.conf
+ ${PREFIX}/etc/${PORTNAME}.conf || ${TRUE}
.include <bsd.port.mk>
diff --git a/security/sancp/Makefile b/security/sancp/Makefile
index 2ae5f630fe08..8774aaf48bfe 100644
--- a/security/sancp/Makefile
+++ b/security/sancp/Makefile
@@ -31,7 +31,7 @@ post-extract:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/sancp ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/etc/sancp/sancp.conf ${PREFIX}/etc/sancp.conf-dist
- @${CP} -n ${PREFIX}/etc/sancp.conf-dist ${PREFIX}/etc/sancp.conf
+ @${CP} -n ${PREFIX}/etc/sancp.conf-dist ${PREFIX}/etc/sancp.conf || ${TRUE}
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/
diff --git a/textproc/pootle/Makefile b/textproc/pootle/Makefile
index 2e313f741f96..684aa3391057 100644
--- a/textproc/pootle/Makefile
+++ b/textproc/pootle/Makefile
@@ -94,7 +94,7 @@ post-patch:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CP} -n ${PREFIX}/etc/pootle/localsettings.py.sample \
- ${PREFIX}/etc/pootle/localsettings.py
+ ${PREFIX}/etc/pootle/localsettings.py || ${TRUE}
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
diff --git a/www/c-icap-modules/Makefile b/www/c-icap-modules/Makefile
index b68f073f4950..9df64531381c 100644
--- a/www/c-icap-modules/Makefile
+++ b/www/c-icap-modules/Makefile
@@ -2,7 +2,7 @@
# Date created: 15 August 2012
# Whom: Martin Matuska <mm@FreeBSD.org>
#
-# $FreeBSD: ports/www/c-icap-modules/Makefile,v 1.3 2012/08/15 01:47:11 mm Exp $
+# $FreeBSD$
#
PORTNAME= c-icap
@@ -33,8 +33,8 @@ CONFIGURE_ARGS+= --enable-static \
post-install:
@${CP} -np ${PREFIX}/etc/c-icap/srv_url_check.conf.default \
- ${PREFIX}/etc/c-icap/srv_url_check.conf
+ ${PREFIX}/etc/c-icap/srv_url_check.conf || ${TRUE}
@${CP} -np ${PREFIX}/etc/c-icap/virus_scan.conf.default \
- ${PREFIX}/etc/c-icap/virus_scan.conf
+ ${PREFIX}/etc/c-icap/virus_scan.conf || ${TRUE}
.include <bsd.port.mk>
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index b0c6d0dfd67f..c92f614b6376 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: c-icap
-# Date created: 30 January 2006
-# Whom: Elisey Savateev <b3k@mail.ru>
-#
+# Created by: Elisey Savateev <b3k@mail.ru>
# $FreeBSD$
-#
PORTNAME= c-icap
PORTVERSION= 0.2.3
@@ -122,9 +118,9 @@ post-patch:
post-install:
@${CP} -np ${PREFIX}/etc/c-icap/c-icap.conf.default \
- ${PREFIX}/etc/c-icap/c-icap.conf
+ ${PREFIX}/etc/c-icap/c-icap.conf || ${TRUE}
@${CP} -np ${PREFIX}/etc/c-icap/c-icap.magic.default \
- ${PREFIX}/etc/c-icap/c-icap.magic
+ ${PREFIX}/etc/c-icap/c-icap.magic || ${TRUE}
@${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/x11/xdm/Makefile b/x11/xdm/Makefile
index 862050b5cdff..d54413cb4528 100644
--- a/x11/xdm/Makefile
+++ b/x11/xdm/Makefile
@@ -49,7 +49,7 @@ post-configure:
post-install:
.for f in ${CFFILES}
- ${CP} -n ${EXAMPLESDIR}/$f ${PREFIX}/lib/X11/xdm/$f
+ ${CP} -n ${EXAMPLESDIR}/$f ${PREFIX}/lib/X11/xdm/$f || ${TRUE}
.endfor
${MKDIR} /var/lib/xdm/authdir
${LN} -sf /var/lib/xdm/authdir ${PREFIX}/lib/X11/xdm/authdir