aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/p5-GPS/Makefile3
-rw-r--r--astro/p5-Weather-Underground/Makefile9
-rw-r--r--astro/p5-ZConf-Weather/Makefile9
-rw-r--r--astro/weatherspect/Makefile8
-rw-r--r--comms/p5-Nexmo-SMS/Makefile9
-rw-r--r--comms/p5-SMS-Send-TW-ShareSMS/Makefile9
-rw-r--r--comms/p5-SMS-Send/Makefile9
-rw-r--r--math/p5-Math-BaseCnv/Makefile9
-rw-r--r--math/p5-Math-Geometry/Makefile9
-rw-r--r--math/p5-Math-Vec/Makefile8
-rw-r--r--math/p5-Math-VectorReal/Makefile9
-rw-r--r--math/p5-NetCDF/Makefile8
-rw-r--r--math/p5-Number-WithError/Makefile9
-rw-r--r--math/p5-Set-IntSpan/Makefile3
-rw-r--r--math/p5-Statistics-Lite/Makefile9
-rw-r--r--x11-fonts/geminifonts/Makefile9
-rw-r--r--x11-fonts/p5-type1inst/Makefile8
17 files changed, 45 insertions, 92 deletions
diff --git a/astro/p5-GPS/Makefile b/astro/p5-GPS/Makefile
index 9a787008dbdb..5fbe272e0f7c 100644
--- a/astro/p5-GPS/Makefile
+++ b/astro/p5-GPS/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl interface to GPS receivers
BUILD_DEPENDS= p5-Device-SerialPort>=0.07:${PORTSDIR}/comms/p5-Device-SerialPort
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GPS::Serial.3 \
GPS::NMEA.3 \
diff --git a/astro/p5-Weather-Underground/Makefile b/astro/p5-Weather-Underground/Makefile
index 119c196c0310..ff88488f03ff 100644
--- a/astro/p5-Weather-Underground/Makefile
+++ b/astro/p5-Weather-Underground/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Weather-Underground
-# Date created: 2006-05-16
-# Whom: Simon Olofsson <simon@olofsson.de>
-#
+# Created by: Simon Olofsson <simon@olofsson.de>
# $FreeBSD$
-#
PORTNAME= Weather-Underground
PORTVERSION= 3.03
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Weather::Underground.3
diff --git a/astro/p5-ZConf-Weather/Makefile b/astro/p5-ZConf-Weather/Makefile
index 669350b176a4..f6f77c158567 100644
--- a/astro/p5-ZConf-Weather/Makefile
+++ b/astro/p5-ZConf-Weather/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-ZConf-Weather
-# Date created: 2009-09-27
-# Whom: Zane C, Bowers <vvelox@vvelox.net>
-#
+# Created by: Zane C, Bowers <vvelox@vvelox.net>
# $FreeBSD$
-#
PORTNAME= ZConf-Weather
PORTVERSION= 1.0.0
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-ZConf>=6.1.0:${PORTSDIR}/net/p5-ZConf \
p5-Weather-Underground>=3.03:${PORTSDIR}/astro/p5-Weather-Underground
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::Weather.3
diff --git a/astro/weatherspect/Makefile b/astro/weatherspect/Makefile
index 525a801d4fd2..8657582677b0 100644
--- a/astro/weatherspect/Makefile
+++ b/astro/weatherspect/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: weatherspect
-# Date created: 2006-05-16
-# Whom: Simon Olofsson <simon@olofsson.de>
-#
+# Created by: Simon Olofsson <simon@olofsson.de>
# $FreeBSD$
-#
PORTNAME= weatherspect
PORTVERSION= 1.9
@@ -24,7 +20,7 @@ RUN_DEPENDS= p5-Term-Animation>=0:${PORTSDIR}/devel/p5-Term-Animation \
PORTSCOUT= skipv:1.31 # Wrong versioning upstream
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/weatherspect
do-install:
diff --git a/comms/p5-Nexmo-SMS/Makefile b/comms/p5-Nexmo-SMS/Makefile
index 5220ebd6f89d..3325ff995a8b 100644
--- a/comms/p5-Nexmo-SMS/Makefile
+++ b/comms/p5-Nexmo-SMS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Nexmo-SMS
-# Date created: 2011-11-25
-# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
-#
+# Created by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= Nexmo-SMS
PORTVERSION= 0.06
@@ -23,7 +19,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.08:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Nexmo::SMS.3 \
Nexmo::SMS::BinaryMessage.3 \
diff --git a/comms/p5-SMS-Send-TW-ShareSMS/Makefile b/comms/p5-SMS-Send-TW-ShareSMS/Makefile
index 3afd23cf2c20..4e9288674ac7 100644
--- a/comms/p5-SMS-Send-TW-ShareSMS/Makefile
+++ b/comms/p5-SMS-Send-TW-ShareSMS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-TW-ShareSMS
-# Date created: 2007-10-06
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-TW-ShareSMS
PORTVERSION= 0.02
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-SMS-Send>=0.03:${PORTSDIR}/comms/p5-SMS-Send \
p5-libwww>=2:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::ShareSMS.3
diff --git a/comms/p5-SMS-Send/Makefile b/comms/p5-SMS-Send/Makefile
index f93298d7961b..2f9d68d3f433 100644
--- a/comms/p5-SMS-Send/Makefile
+++ b/comms/p5-SMS-Send/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send
-# Date created: 2006-08-26
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send
PORTVERSION= 1.06
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Class-Adapter>=1.05:${PORTSDIR}/devel/p5-Class-Adapter \
p5-Params-Util>=1.00:${PORTSDIR}/devel/p5-Params-Util
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send.3 \
SMS::Send::AU::Test.3 \
diff --git a/math/p5-Math-BaseCnv/Makefile b/math/p5-Math-BaseCnv/Makefile
index 8a08eeb17670..2d69bec34ca5 100644
--- a/math/p5-Math-BaseCnv/Makefile
+++ b/math/p5-Math-BaseCnv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-BaseCnv
-# Date created: 3rd June, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Math-BaseCnv
PORTVERSION= 1.4.75
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::BaseCnv.3
diff --git a/math/p5-Math-Geometry/Makefile b/math/p5-Math-Geometry/Makefile
index 7f500fd37b96..956a515be3fe 100644
--- a/math/p5-Math-Geometry/Makefile
+++ b/math/p5-Math-Geometry/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Math-Geometry
-# Date created: 2006-08-19
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Math-Geometry
PORTVERSION= 0.04
@@ -16,7 +12,8 @@ COMMENT= Geometry related functions
RUN_DEPENDS= p5-Math-Matrix>=0:${PORTSDIR}/math/p5-Math-Matrix
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::Geometry.3
diff --git a/math/p5-Math-Vec/Makefile b/math/p5-Math-Vec/Makefile
index 74d517c50a21..61f837923dc1 100644
--- a/math/p5-Math-Vec/Makefile
+++ b/math/p5-Math-Vec/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Math::Vec
-# Date created: 6 May 2005
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Math-Vec
PORTVERSION= 1.01
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Object-Oriented Vector Math Methods in Perl
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Math::Vec.3
.include <bsd.port.mk>
diff --git a/math/p5-Math-VectorReal/Makefile b/math/p5-Math-VectorReal/Makefile
index 70196d4a02f7..459f99d6f1e3 100644
--- a/math/p5-Math-VectorReal/Makefile
+++ b/math/p5-Math-VectorReal/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-VectorReal
-# Date created: 11 May, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Math-VectorReal
PORTVERSION= 1.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wenheping@gmail.com
COMMENT= Perl Module to handle 3D Vector Mathematics
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::VectorReal.3
diff --git a/math/p5-NetCDF/Makefile b/math/p5-NetCDF/Makefile
index 5ca438acc243..efab8ec5acbf 100644
--- a/math/p5-NetCDF/Makefile
+++ b/math/p5-NetCDF/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-NetCDF
-# Date created: 2003-11-17
-# Whom: Douglas K. Rand (rand@meridian-enviro.com)
-#
+# Created by: Douglas K. Rand (rand@meridian-enviro.com)
# $FreeBSD$
-#
PORTNAME= NetCDF
PORTVERSION= 1.2.4
@@ -24,7 +20,7 @@ LIB_DEPENDS= netcdf.7:${PORTSDIR}/science/netcdf4
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
.endif
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/${DISTNAME}/src
GNU_CONFIGURE= yes
diff --git a/math/p5-Number-WithError/Makefile b/math/p5-Number-WithError/Makefile
index d0f9c83c2765..bc41fe7dc5f6 100644
--- a/math/p5-Number-WithError/Makefile
+++ b/math/p5-Number-WithError/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Number-WithError
-# Date created: 15 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Number-WithError
PORTVERSION= 1.01
@@ -22,6 +18,7 @@ TEST_DEPENDS= p5-Test-LectroTest>=0:${PORTSDIR}/devel/p5-Test-LectroTest
MAN3= Number::WithError.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/math/p5-Set-IntSpan/Makefile b/math/p5-Set-IntSpan/Makefile
index 56d9cf717f00..b9ba72a0b83b 100644
--- a/math/p5-Set-IntSpan/Makefile
+++ b/math/p5-Set-IntSpan/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= danilogondolfo@gmail.com
COMMENT= Manages sets of integers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Set::IntSpan.3
diff --git a/math/p5-Statistics-Lite/Makefile b/math/p5-Statistics-Lite/Makefile
index eb0d611fc66a..ae3ccda26001 100644
--- a/math/p5-Statistics-Lite/Makefile
+++ b/math/p5-Statistics-Lite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Statistics-Lite
-# Date created: 1 December 2004
-# Whom: Sergey A. Osokin <osa@FreeBSD.org>
-#
+# Created by: Sergey A. Osokin <osa@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Statistics-Lite
PORTVERSION= 3.2
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= osa@FreeBSD.org
COMMENT= The lightweight and functional object-oriented statistics
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_DOS2UNIX= yes
MAN3= Statistics::Lite.3
diff --git a/x11-fonts/geminifonts/Makefile b/x11-fonts/geminifonts/Makefile
index 66de0bdf44e8..e30e744fb9c5 100644
--- a/x11-fonts/geminifonts/Makefile
+++ b/x11-fonts/geminifonts/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: koi8rPS
-# Date created: Oct 30, 2000
-# Whom: mi@aldan.algebra.com
-#
+# Created by: mi@aldan.algebra.com
# $FreeBSD$
-#
PORTNAME= gemini
PORTVERSION= 1.0
@@ -22,7 +18,8 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
USE_XORG= x11
NO_WRKSUBDIR= yes
diff --git a/x11-fonts/p5-type1inst/Makefile b/x11-fonts/p5-type1inst/Makefile
index e61f46874375..797d0a473811 100644
--- a/x11-fonts/p5-type1inst/Makefile
+++ b/x11-fonts/p5-type1inst/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-type1inst
-# Date created: 7 Jan 1998
-# Whom: giffunip@asme.org
-#
+# Created by: giffunip@asme.org
# $FreeBSD$
-#
PORTNAME= type1inst
PORTVERSION= 0.6.1
@@ -21,7 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
.endif
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
PORTDOCS= README
PLIST_FILES= bin/t1embed bin/type1inst