aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/ebook2cwgui/Makefile1
-rw-r--r--comms/tilp2/Makefile3
-rw-r--r--devel/librcc/Makefile3
-rw-r--r--editors/xmlcopyeditor/Makefile2
-rw-r--r--ftp/multiget/Makefile2
-rw-r--r--ftp/wxdfast/Makefile2
-rw-r--r--graphics/eom/Makefile4
-rw-r--r--net/wireshark/Makefile3
-rw-r--r--x11-themes/gtk-oxygen-engine/Makefile2
-rw-r--r--x11-themes/gtk3-oxygen-engine/Makefile2
-rw-r--r--x11-toolkits/gtkglarea2/Makefile2
-rw-r--r--x11-toolkits/gtkmm20/Makefile2
-rw-r--r--x11/simdock/Makefile2
13 files changed, 17 insertions, 13 deletions
diff --git a/comms/ebook2cwgui/Makefile b/comms/ebook2cwgui/Makefile
index 45a71f98fb57..df935312f36d 100644
--- a/comms/ebook2cwgui/Makefile
+++ b/comms/ebook2cwgui/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ebook2cw:comms/ebook2cw
+USES= compiler:c++11-lang
USE_WX= 2.8
PORTDOCS= *
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index 846880bdd99d..38b6273b42c0 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libticables2.so:comms/libticables2 \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf desktop-file-utils gettext gmake groff localbase \
+USES= autoreconf compiler:c++11-lang desktop-file-utils gettext \
+ gmake groff localbase \
libtool pkgconfig shared-mime-info tar:bzip2
USE_GNOME= gtk20 intltool
diff --git a/devel/librcc/Makefile b/devel/librcc/Makefile
index 74887a397064..015de683cfcf 100644
--- a/devel/librcc/Makefile
+++ b/devel/librcc/Makefile
@@ -19,8 +19,9 @@ LIB_DEPENDS= librcd.so:devel/librcd \
libaspell.so:textproc/aspell
GNU_CONFIGURE= yes
+USES= compiler:c++11-lang gmake iconv libtool pathfix pkgconfig \
+ tar:bzip2
USE_GNOME= libxml2
-USES= gmake iconv libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index 76b09bd9834a..63e3912715f4 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= libxerces-c.so.3:textproc/xerces-c3 \
libxml2.so:textproc/libxml2 \
libexpat.so:textproc/expat2
+USES= compiler:c++11-lang dos2unix gettext gmake iconv libtool
USE_WX= 2.8+
WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
-USES= dos2unix gettext gmake iconv libtool
USE_GNOME= intltool
GNU_CONFIGURE= yes
diff --git a/ftp/multiget/Makefile b/ftp/multiget/Makefile
index 1f13ac7f561f..495bcf5474e3 100644
--- a/ftp/multiget/Makefile
+++ b/ftp/multiget/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2+
WRKSRC_SUBDIR= src
-USES= alias dos2unix
+USES= alias compiler:c++11-lang dos2unix
USE_WX= 2.8
MAKEFILE= makefile
ALL_TARGET= MultiGet
diff --git a/ftp/wxdfast/Makefile b/ftp/wxdfast/Makefile
index 38070378dbe2..ccb6b1737c53 100644
--- a/ftp/wxdfast/Makefile
+++ b/ftp/wxdfast/Makefile
@@ -19,9 +19,9 @@ BROKEN_armv7= fails to compile: no matching member function for call to 'Read'
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= autoreconf compiler:c++11-lang gettext libtool
USE_WX= 2.8+
WX_CONF_ARGS= relative
-USES= autoreconf gettext libtool
GNU_CONFIGURE= yes
CONFIGURE_ENV= WXRC="${WXRC_CMD}"
INSTALL_TARGET= install-strip
diff --git a/graphics/eom/Makefile b/graphics/eom/Makefile
index 1f58dcdb06c1..7b22e6cf1b41 100644
--- a/graphics/eom/Makefile
+++ b/graphics/eom/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake jpeg libtool localbase \
- pathfix pkgconfig tar:xz
+USES= compiler:c++11-lang desktop-file-utils gettext gmake jpeg \
+ libtool localbase pathfix pkgconfig tar:xz
USE_MATE= desktop icontheme
USE_XORG= x11
USE_GNOME= cairo gnomeprefix gtk30 intltool introspection \
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index e9475c4fe378..de1b8608a380 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -27,7 +27,8 @@ DATADIR_NAME= wireshark
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
GNU_CONFIGURE= yes
-USES= alias cpe gettext-runtime gmake libtool localbase pathfix \
+USES= alias cpe compiler:c++11-lang gettext-runtime gmake \
+ libtool localbase pathfix \
perl5 pkgconfig python:build ssl tar:xz
USE_PERL5= build
USE_GNOME= glib20 libxml2
diff --git a/x11-themes/gtk-oxygen-engine/Makefile b/x11-themes/gtk-oxygen-engine/Makefile
index 6e5460d710e0..0089e23d2fb2 100644
--- a/x11-themes/gtk-oxygen-engine/Makefile
+++ b/x11-themes/gtk-oxygen-engine/Makefile
@@ -17,7 +17,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libcairo.so:graphics/cairo \
libdbus-glib-1.so:devel/dbus-glib
+USES= cmake compiler:c++11-lang pkgconfig tar:bzip2
USE_GNOME= gtk20
-USES= cmake pkgconfig tar:bzip2
.include <bsd.port.mk>
diff --git a/x11-themes/gtk3-oxygen-engine/Makefile b/x11-themes/gtk3-oxygen-engine/Makefile
index dabead6268df..08a75f924b03 100644
--- a/x11-themes/gtk3-oxygen-engine/Makefile
+++ b/x11-themes/gtk3-oxygen-engine/Makefile
@@ -17,7 +17,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libcairo.so:graphics/cairo \
libdbus-glib-1.so:devel/dbus-glib
+USES= cmake:outsource compiler:c++11-lang pkgconfig tar:bzip2
USE_GNOME= gtk30
-USES= cmake:outsource pkgconfig tar:bzip2
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtkglarea2/Makefile b/x11-toolkits/gtkglarea2/Makefile
index 7735fa4eacb6..ce855a90391a 100644
--- a/x11-toolkits/gtkglarea2/Makefile
+++ b/x11-toolkits/gtkglarea2/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL widget for the GTK+2 GUI toolkit
-USES= libtool:keepla pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gtk20
USE_GL= yes
USE_LDCONFIG= yes
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index 47e509344505..a15fd4d4b5c1 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ wrapper for Gtk+, Pango, Atk, and Glib
-USES+= tar:bzip2
+USES+= compiler:c++11-lang tar:bzip2
PORTSCOUT= ignore:1
diff --git a/x11/simdock/Makefile b/x11/simdock/Makefile
index 4726f2562bf9..f17ec9665c08 100644
--- a/x11/simdock/Makefile
+++ b/x11/simdock/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= desktop-file-utils pathfix pkgconfig
+USES= compiler:c++11-lang desktop-file-utils pathfix pkgconfig
USE_GNOME= gnomeprefix gconf2 libwnck
USE_WX= 2.8
USE_XORG= x11