aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Xerces/Makefile32
-rw-r--r--textproc/p5-XML-Xerces/distinfo3
-rw-r--r--textproc/p5-XML-Xerces/pkg-descr7
-rw-r--r--textproc/p5-XML-Xerces/pkg-plist10
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 36640fc2aec7..79482dbf99b4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -587,6 +587,7 @@
SUBDIR += p5-XML-XSH
SUBDIR += p5-XML-XSLT
SUBDIR += p5-XML-XUpdate-LibXML
+ SUBDIR += p5-XML-Xerces
SUBDIR += p5-YAML
SUBDIR += p5-YAML-Syck
SUBDIR += p5-YAPE-HTML
diff --git a/textproc/p5-XML-Xerces/Makefile b/textproc/p5-XML-Xerces/Makefile
new file mode 100644
index 000000000000..1531162e9107
--- /dev/null
+++ b/textproc/p5-XML-Xerces/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-XML-Xerces
+# Date created: 29 March 2006
+# Whom: Ken Menzel <kenm@icarz.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Xerces
+PORTVERSION= 2.7.0
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+DISTNAME= XML-Xerces-${PORTVERSION}-0
+
+MAINTAINER= kenm@icarz.com
+COMMENT= The Perl API to the Apache project's Xerces XML parser
+
+LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+
+USE_GMAKE= YES
+PERL_CONFIGURE= YES
+CONFIGURE_ENV+= XERCES_LIB="${LOCALBASE}/lib" \
+ XERCES_INCLUDE="${LOCALBASE}/include" \
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= this port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Xerces/distinfo b/textproc/p5-XML-Xerces/distinfo
new file mode 100644
index 000000000000..a158a0c9950c
--- /dev/null
+++ b/textproc/p5-XML-Xerces/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Xerces-2.7.0-0.tar.gz) = e5bd871026bee1b291c5634e6e4daf35
+SHA256 (XML-Xerces-2.7.0-0.tar.gz) = ec9ad5482beb7f34feb2458d1c65807339cb2c1b01895c174e4fb3cb9ca87be6
+SIZE (XML-Xerces-2.7.0-0.tar.gz) = 291199
diff --git a/textproc/p5-XML-Xerces/pkg-descr b/textproc/p5-XML-Xerces/pkg-descr
new file mode 100644
index 000000000000..db2bd3707af3
--- /dev/null
+++ b/textproc/p5-XML-Xerces/pkg-descr
@@ -0,0 +1,7 @@
+XML::Xerces is the Perl API to the Apache project's Xerces XML
+parser. It is implemented using the Xerces C++ API, and it provides
+access to most of the C++ API from Perl.
+
+WWW: http://xerces.apache.org/xerces-p/
+
+-- Ken Menzel <kenm@icarz.com>
diff --git a/textproc/p5-XML-Xerces/pkg-plist b/textproc/p5-XML-Xerces/pkg-plist
new file mode 100644
index 000000000000..10f89f1fa0d6
--- /dev/null
+++ b/textproc/p5-XML-Xerces/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/XML/Xerces.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Handler/Handler.a
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Handler/extralibs.ld
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Xerces/Xerces.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Xerces/Xerces.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Xerces/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Xerces
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Handler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/XML