aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/kojoney/Makefile3
-rw-r--r--net/ldapsh/Makefile3
-rw-r--r--net/nepenthes/Makefile2
-rw-r--r--net/p5-AnyEvent-MPRPC/Makefile3
-rw-r--r--net/p5-BBS-UserInfo-Wretch/Makefile3
-rw-r--r--net/p5-Beanstalk-Client/Makefile3
-rw-r--r--net/p5-Net-DHCP/Makefile3
-rw-r--r--net/p5-Net-FS-Flickr/Makefile3
-rw-r--r--net/p5-Net-Google-Code/Makefile3
-rw-r--r--net/p5-Net-Growl/Makefile3
-rw-r--r--net/p5-Net-HL7/Makefile3
-rw-r--r--net/p5-Net-LDAP-Makepath/Makefile3
-rw-r--r--net/p5-Net-Libdnet/Makefile3
-rw-r--r--net/p5-Net-Proxy/Makefile3
-rw-r--r--net/p5-Net-SCP-Expect/Makefile3
-rw-r--r--net/p5-Net-SMPP/Makefile3
-rw-r--r--net/p5-Net-SSH-Expect/Makefile3
-rw-r--r--net/p5-Net-uFTP/Makefile3
-rw-r--r--net/p5-URI-Template-Restrict/Makefile3
19 files changed, 37 insertions, 19 deletions
diff --git a/net/kojoney/Makefile b/net/kojoney/Makefile
index 4f09f5da760d..3337dbed6b56 100644
--- a/net/kojoney/Makefile
+++ b/net/kojoney/Makefile
@@ -22,6 +22,7 @@ WRKSRC= ${WRKDIR}/kojoney
USE_PYTHON= 2.5+
USE_TWISTED= conch
USE_OPENSSL= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.include <bsd.port.mk>
diff --git a/net/ldapsh/Makefile b/net/ldapsh/Makefile
index 44d3fdeb77ba..5b7a5cca7591 100644
--- a/net/ldapsh/Makefile
+++ b/net/ldapsh/Makefile
@@ -29,7 +29,8 @@ MAN1= ldapsh.1
MAN3= Net::LDAP::Shell.3 Net::LDAP::Config.3 \
Net::LDAP::Shell::Parse.3 Net::LDAP::Shell::Util.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
post-patch:
${REINPLACE_CMD} -e "s,/usr/local/bin/perl,${PERL}," ${WRKSRC}/ldapsh
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index ed0be7637df1..25d1d99b0d48 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+= --enable-prelude
CONFIGURE_ARGS+= --enable-debug-logging
.endif
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
DOCS= README README.VFS logo-shaded.svg
diff --git a/net/p5-AnyEvent-MPRPC/Makefile b/net/p5-AnyEvent-MPRPC/Makefile
index 9274ad207dd1..93b1d18dac07 100644
--- a/net/p5-AnyEvent-MPRPC/Makefile
+++ b/net/p5-AnyEvent-MPRPC/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-TCP>=0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::MPRPC.3 \
AnyEvent::MPRPC::Client.3 \
diff --git a/net/p5-BBS-UserInfo-Wretch/Makefile b/net/p5-BBS-UserInfo-Wretch/Makefile
index 9e271a7fa715..4cadc45be669 100644
--- a/net/p5-BBS-UserInfo-Wretch/Makefile
+++ b/net/p5-BBS-UserInfo-Wretch/Makefile
@@ -17,7 +17,8 @@ COMMENT= Get user information of Wretch-style BBS
RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::UserInfo::Wretch.3
diff --git a/net/p5-Beanstalk-Client/Makefile b/net/p5-Beanstalk-Client/Makefile
index 3386db26a675..2bdfcba423b9 100644
--- a/net/p5-Beanstalk-Client/Makefile
+++ b/net/p5-Beanstalk-Client/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck \
p5-Error>=0:${PORTSDIR}/lang/p5-Error
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Beanstalk::Client.3 \
Beanstalk::Pool.3 \
diff --git a/net/p5-Net-DHCP/Makefile b/net/p5-Net-DHCP/Makefile
index 6a0ad51c0965..7e52734f2570 100644
--- a/net/p5-Net-DHCP/Makefile
+++ b/net/p5-Net-DHCP/Makefile
@@ -15,7 +15,8 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::DHCP::Constants.3 \
Net::DHCP::Packet.3
diff --git a/net/p5-Net-FS-Flickr/Makefile b/net/p5-Net-FS-Flickr/Makefile
index b92f4cf6e75f..4525d0d8a0ff 100644
--- a/net/p5-Net-FS-Flickr/Makefile
+++ b/net/p5-Net-FS-Flickr/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Flickr-Upload>=0:${PORTSDIR}/www/p5-Flickr-Upload
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= flickrfs.1
MAN3= Net::FS::Flickr.3 \
diff --git a/net/p5-Net-Google-Code/Makefile b/net/p5-Net-Google-Code/Makefile
index 0a32c4e546a5..eeacf567802c 100644
--- a/net/p5-Net-Google-Code/Makefile
+++ b/net/p5-Net-Google-Code/Makefile
@@ -32,7 +32,8 @@ RUN_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
p5-XML-FeedPP>=0:${PORTSDIR}/textproc/p5-XML-FeedPP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Google::Code.3 \
Net::Google::Code::AtomParser.3 \
diff --git a/net/p5-Net-Growl/Makefile b/net/p5-Net-Growl/Makefile
index 471ab0708dba..38305c9c03a2 100644
--- a/net/p5-Net-Growl/Makefile
+++ b/net/p5-Net-Growl/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= markun@onohara.to
COMMENT= Growl Notifications over the network
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Growl.3
diff --git a/net/p5-Net-HL7/Makefile b/net/p5-Net-HL7/Makefile
index e3a9a8c9fb0d..47878987b0a0 100644
--- a/net/p5-Net-HL7/Makefile
+++ b/net/p5-Net-HL7/Makefile
@@ -16,7 +16,8 @@ COMMENT= Net::HL7 - A simple yet flexible API for non-XML HL7 applications
PORTDOCS= README
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::HL7.3 \
Net::HL7::Request.3 \
diff --git a/net/p5-Net-LDAP-Makepath/Makefile b/net/p5-Net-LDAP-Makepath/Makefile
index 50f4293497c6..ece6445f8061 100644
--- a/net/p5-Net-LDAP-Makepath/Makefile
+++ b/net/p5-Net-LDAP-Makepath/Makefile
@@ -18,7 +18,8 @@ COMMENT= Provides a method for creating paths in LDAP simply
RUN_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::Makepath.3
diff --git a/net/p5-Net-Libdnet/Makefile b/net/p5-Net-Libdnet/Makefile
index 82f37c3de333..7d6bb345f2bb 100644
--- a/net/p5-Net-Libdnet/Makefile
+++ b/net/p5-Net-Libdnet/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Class-Gomor>=0:${PORTSDIR}/devel/p5-Class-Gomor
RUN_DEPENDS:= ${BUILD_DEPENDS}
LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= INC='-I${LOCALBASE}/include'
MAN3= Net::Libdnet.3 Net::Libdnet::Entry::Intf.3 Net::Libdnet::Intf.3 \
Net::Libdnet::Ip.3 Net::Libdnet::Eth.3 Net::Libdnet::Tun.3 \
diff --git a/net/p5-Net-Proxy/Makefile b/net/p5-Net-Proxy/Makefile
index 715be9cc26fb..f2aea05ed353 100644
--- a/net/p5-Net-Proxy/Makefile
+++ b/net/p5-Net-Proxy/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jadawin@FreeBSD.org
COMMENT= Framework for proxying network connections in many ways
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Proxy.3 \
Net::Proxy::Connector.3 \
diff --git a/net/p5-Net-SCP-Expect/Makefile b/net/p5-Net-SCP-Expect/Makefile
index 3db8d6ad2f2f..32e9936eb9ba 100644
--- a/net/p5-Net-SCP-Expect/Makefile
+++ b/net/p5-Net-SCP-Expect/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Expect>=1.14:${PORTSDIR}/lang/p5-Expect \
p5-Term-ReadPassword>=0.01:${PORTSDIR}/devel/p5-Term-ReadPassword
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SCP::Expect.3
diff --git a/net/p5-Net-SMPP/Makefile b/net/p5-Net-SMPP/Makefile
index a7b3b992195a..76b0f06f6138 100644
--- a/net/p5-Net-SMPP/Makefile
+++ b/net/p5-Net-SMPP/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jhay@FreeBSD.org
COMMENT= Net::SMPP - pure Perl implementation of SMPP 3.4 over TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SMPP.3
diff --git a/net/p5-Net-SSH-Expect/Makefile b/net/p5-Net-SSH-Expect/Makefile
index b5e3cd4db8b3..47cbc4e90694 100644
--- a/net/p5-Net-SSH-Expect/Makefile
+++ b/net/p5-Net-SSH-Expect/Makefile
@@ -17,7 +17,8 @@ COMMENT= SSH wrapper to execute remote commands
RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SSH::Expect.3
diff --git a/net/p5-Net-uFTP/Makefile b/net/p5-Net-uFTP/Makefile
index ff03ca5129f3..3489d19a376b 100644
--- a/net/p5-Net-uFTP/Makefile
+++ b/net/p5-Net-uFTP/Makefile
@@ -25,7 +25,8 @@ BUILD_DEPENDS= p5-Class-Accessor-Fast-XS>=0:${PORTSDIR}/devel/p5-Class-Accessor-
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::uFTP.3
diff --git a/net/p5-URI-Template-Restrict/Makefile b/net/p5-URI-Template-Restrict/Makefile
index 23a0cad854e2..5d9bb132b40e 100644
--- a/net/p5-URI-Template-Restrict/Makefile
+++ b/net/p5-URI-Template-Restrict/Makefile
@@ -25,7 +25,8 @@ BUILD_DEPENDS= \
p5-Unicode-Normalize>0:${PORTSDIR}/textproc/p5-Unicode-Normalize \
p5-URI>0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::Template::Restrict.3 \
URI::Template::Restrict::Expansion.3